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Welcome 
Feith Workflow iQ Manager is an administrative tool used to design, maintain, and monitor workflows. 

  

What is a Workflow? 

A workflow is a series of tasks and routes that moves a work item - an FDD document or folder - through a 
set of defined business rules until the work is completed. 

• A task is a node where work is done, such as by a user, a program called by command line, or 
other work. See Add Tasks for more information. 

• A route is a path that moves work from one task to another, defining how and why a work item 
arrives at a particular task. See Add Routes for more information. 

The workflow map illustrates the design of the workflow. Tasks are represented by icons and routes are 
represented by lines. The workflow may also contain other graphical elements such as text, labels, pictures, 
or boxes, which may be used for supplemental labeling or as visual aids. See Design Workflows for more 
information. 

 

  

What Do Workflow Users Do? 

When a step in the business process requires user action, a workflow user logs into the Feith client 
application, FDD or WebFDD, and views their Work To Do. The user then processes the items in their work 
queue as needed. 

The work performed by the user is specific to your FDD implementation. For example, the user may enter 
additional information for a document, verify the presence and accuracy of a document and its information 
before it moves forward, or review a document for approval. 

Once the workflow user finishes processing the work item and indicates that it is done, the work item is 
routed to the next task in the workflow. 

See the FDD User Guide and the WebFDD User Guide for more information on processing work items in a 
workflow task. 
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Monitor Workflows 

Once a workflow is designed, published, and in production, you can monitor it through Workflow iQ 
Manager. You can view how much work is in each task, the status of each work item, the history of where 
the work item has been, ad hoc route a work item to another task, clear errors, remove holds, withdraw work 
items from the workflow, and so on. See Monitor Workflows for more information. 

  

Maintain Workflows 

You may update the workflow design as needed to adapt it to the changing requirements of your business 
process. If a workflow is no longer needed, you may take it out of production while keeping the map 
structure in case you need it later. See Save, Publish, and Maintain Workflows for more information. 
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What's New? 
The following are features which have been added or improved in Workflow iQ Manager: 

• Interface Revamp: Workflow iQ Manager has been largely rewritten and with that comes 
numerous interface changes, including a toolbar with tool sets you can collapse or expand, a route 
will visually "jump over" an intersecting route, workflow tabs are in the upper left and can be 
rearranged using click-and-drag, the Rex tools are on a new, separate Rex Toolbar that can be 
moved to the desired location, essentially all dialogs can be re-sized and remember the new size, 
and so on. It is recommended to familiarize yourself with the new interface and refer to this updated 
help file as needed. 

• Custom SQL Rule Tokens: Write custom SQL in a rule token that you can put in a notification, 
work-o-gram, or hub task program. For example, rule tokens can be used to send a notification to a 
custom list of recipients or include information in the notification's body that is not in the file cabinet. 
See Rule Tokens for more information. 

• Max Concurrent Processes for a Hub Task: Optionally specify the Maximum Number of 
Concurrent External Processes allowed in a hub task. For an important hub task you would have 
a higher number; for an unimportant hub task you would have a lower number. For example, if you 
have an unimportant hub task with a lot of documents, you could lower the hub task down to 2 
concurrent processes. That way, the task is only working up to two documents at a time and 
doesn't take Rex's attention away from more important work. See Configure Program for more 
information. 

• Streamlined Import that Remembers Mappings: The import process has been streamlined, 
grouping like objects on a single screen. For example, all the notifications in the workflow are 
presented on one screen where you can review them all at once and choose to map, replace, or 
create as desired. Additionally, the mappings you made when you imported previous workflows will 
be remembered and suggested the next time you import a workflow. See Export and Import for 
more information. 

• Double-Click Work Item Count to View Work Info: Double-click the work item count above a 
task to view that task's Work Info. See View Work Info for more information. 

• View and Modify Some Things Without Checking Out Workflow: Notifications, Finishing 
Touches, and Integration Links can be viewed and modified without checking out the workflow. Just 
go into the task and open them to take a look or make a change. Additionally, you can view (not 
modify) wait-for rules in a wait-for task. See Notify, Finishing Touches, Integration Links, and Wait-
For Task for more information. 

• Move Route with Click-and-Drag: Move a route by selecting it and dragging the start point or end 
point to change the route's origin or destination task. See Add Routes for more information. 

• Mail Data, Copy Link, View Item, and Work from Work Info: From Work Info, email a 
document's metadata to somebody, copy the document's WebFDD link to the clipboard to use 
somewhere, or view/work a document in WebFDD. See View Work Info for more information. 

• Export and Import Calendars: Export and import calendars from one system to another (e.g. from 
a test system to a production system). See Calendars for more information. 

• Wormholes: If your routes are criss-crossing, getting too long, or otherwise cluttering up your map, 
try tidying it up with wormholes. See Wormhole for more information. 
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Frequently Asked Questions (FAQ) 
I cannot find the workflow I need to open? 

Make sure you have permission to the workflow.  To open a workflow you must be in the workflow's 
Administration Group, a Super Administrator, or be Assigned in the workflow's supplementary 
permissions list. See Workflow Permissions for more information. 

File>Open no longer lets me open a workflow .fwf file from my local computer? 

As of version 8, Workflow iQ Manager stores workflows in the database instead of saving them to the 
local machine. In order to open workflow .fwf. files saved by previous versions of Workflow iQ 
Manager, select Tools>Advanced Options>Restore Backup File. See Save and Restore Backup 
Files for more information. 

I do not see any of the task or route tools in the administrator bar that let me modify the workflow? 

As of version 8, workflow locking was added to Workflow iQ Manager. This prevents users from 
inadvertently overwriting each other's changes. What you see is the workflow in "read-only" mode, 
which is useful for monitoring. If you need to modify the workflow design, you need to Check Out the 
workflow. See Modify Workflow for more information. 

I cannot check out a workflow because Workflow iQ Manager says someone else has it checked out? 

Only one designer can have a workflow checked out for modifying, in order to avoid inadvertently 
overwriting of each other's changes. It is recommended that you contact the person who already has 
the workflow checked out. If necessary, you can Override the Check Out and break their lock on 
the workflow. See Override Check Out for more information. 

I cannot find the user I want to assign? 

A user must be a Workflow type user in order to do things in Workflow iQ, such as be assigned to a 
user task. The user type is set in Feith Control Panel. 

Rex is not running more hub task programs even though the Maximum Concurrent Processes setting on the 
hub task allows more? 

Rex has a global limit of concurrent external processes, which applies to all hub tasks, set in its 
initialization file. See Rex Manual for more information. 

How do I put my own icon on a task? 

Right-click on the task and select Change Picture. See Add Tasks for more information. 

Task-Customized and Personal notifications seem to be gone so how do I make a notification that can only 
be assigned in one workflow? 

When creating a notification, check on the Limit to Workflow option. The notification will only be 
available to assign in the one specific workflow. See Create and Maintain Notifications for more 
information. 

The notification's Limit to Workflow option is disabled? 

The Limit to Workflow option is only available when creating a new notification from inside a task (it 
is not available in Tools>Notification Administrator). If you turn Limit to Workflow off for an 
existing notification, it cannot be turned back on. 

There's a Deadline Route or Deadline Task in the workflow but the work items are not moving even though 
the deadline has passed? 

There are a couple reasons this may happen: 

• Rex has not checked deadlines yet. You may force Rex to check deadlines by clicking the 

down arrow on the Rex action button in the Rex toolbar and selecting Check 
Deadlines. See Monitor Rex for more information. 

• A Deadline Route's deadline is calculated when the work item arrives at the task, so if the 
work item was already in the task when the deadline was added then the deadline will not 
be calculated. To force the deadline to be calculated, you will have to Ad Hoc Route the 
work item away from the task then route it back. 
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A Deadline Task's deadline is calculated when the work item arrives in the workflow at the 
Start Task, so if the work item was already in the workflow when the deadline was added 
then the deadline will not be calculated. To force the deadline to be calculated, you will 
have to Ad Hoc Route the work item to the start task. 
 
See Ad Hoc Route for more information. 

A route is not visually "jumping over" or "going under" intersecting routes? 

Visually "jumping over" or "going under" intersecting routes is not supported for a Bezier Curve style 
route. See Add Routes for more information. 

I want to change the number of characters required in workflow comments? 

Writing down what you did to the workflow in comments is very important so that others and even 
yourself can know what changed in the workflow and why. The workflow is controlling your business 
process and taking a few seconds to record what you did can save time in the future. 
 
Sometimes a workflow designer's change may inadvertently conflict with another designer's change, 
or troubleshooting a bug may lead you back to the workflow's version history reading comments from 
the time that symptoms first appeared. 
 
If you want to increase or decrease the number of characters required in the comments, contact 
Feith Support for instructions on how to do so. 

Publish Workflow, Import Workflow, Delete Workflow, and Purge Workflow are disabled? 

You must be a Feith Admin user (on Oracle) or a Database Admin user (on MS SQL Server) in 
order to perform these operations. See Workflow Permissions for more information. 

Why is my Rex Connection in the Rex toolbar red? 

The Rex Connection is red when Rex is not working the workflow. This may be because: 

• The workflow was just published and Rex does not know about the workflow yet in order 
to process it. Rex will find the workflow and begin processing on its own, or you can force 

Rex to take over the workflow by clicking the down arrow on the Rex action button 
in the Rex toolbar and selecting Take Over Workflow Processing. 

• The selected Rex is intentionally not assigned to work the workflow. This may occur if you 
have more than one Rex running and different Rexes work different workflows for 
purposes of load balancing. 

I cannot see the workflow in the client (FDD or WebFDD) to add a document or folder manually to the 
workflow? 

In addition to having the Add To Workflow task permission, you must have permission on a 
workflow's Start Task in order to add documents or folders to the workflow manually from the client. 
See Assign Users to Start Task for more information. 

Why can't I withdraw a work item from the entire workflow? 

One of the copies of the work item is in a state which prohibits withdrawal (e.g. Locked). Work items 
can only be withdrawn if they have a status of Available, Complete, Error, or Subflow. 
 
Note: Withdrawing multiple work items at once from the entire workflow is not supported. 

If I withdraw a work item from a subflow task, is it withdrawing from all tasks in the subflow workflow? 

Yes. Note that if an instance of the work item in the subflow cannot be withdrawn (e.g. is currently 
Locked), that the work item will be marked to be withdrawn but will not actually be withdrawn until it 
can be withdrawn (e.g. is no longer Locked). 

Can I withdraw a work item from an entire workflow without withdrawing it from the subflow(s)? 

No. Since selecting Withdraw>From Entire Workflow will result in the work item being removed all 
tasks, including subflow tasks which point to subflows, you will have to withdraw the work item from 
each individual task in the "parent" workflow (excluding the subflow tasks where you want the work 
item to stay). 
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Tips and Tricks 
Take advantage of various tips and tricks in Workflow iQ Manager to better design, maintain, and monitor 
workflows. 

• When designing a workflow and adding tasks, routes, and graphical elements, hit CTRL+1 to 
quickly switch back to the Pointer tool to move and configure objects. 

• With the Pointer tool selected, temporarily switch to the Grabby Hand tool by holding down SHIFT 
to scroll around the map using click-and-drag. 

• Use CTRL+TAB to go to the next open workflow tab, moving left to right. Use SHIFT+CTRL+TAB 
to go to the previous open workflow, moving right to left. 

• Reorder the workflow tabs using click-and-drag. 

• Close a workflow with a "middle-click" on its tab using the mouse wheel. 

• If you are in a field that inserts a tab when you press the TAB key (e.g. notification Body), you can 
use CTRL+TAB to navigate to the next control in the dialog (or SHIFT+CTRL+TAB to go to the 
previous control). 

• See Appendix C: Keyboard Shortcuts for more information on keyboard shortcuts available in 
Workflow iQ Manager. 

• As soon as the Task Administrator opens, you can take advantage of one of the following 
keyboard shortcuts: 

o Hit the TAB key once to quickly move to the Name field. This may be helpful when first 
adding tasks, especially if you are adding many tasks. 

o Use the up and down arrow keys to navigate to the desired tab. 

• In lists such as Users in a user task, tasks in Edit>Find Task, workflows in File>Open, or other 
lists, hit the key of the first letter of the name to jump to that part of the list. Hit the letter key multiple 
times to cycle through all items that start with that letter. Also, use the up and down arrow keys in 
the list to select the desired item. 

• Notifications, Finishing Touches, and Integration Links can be viewed and modified without 
checking out the workflow. Just go into the task and open them to take a look or make a change. 
For example: 

o When the workflow is checked in, double-click the notification in the Notify tab to open the 
notification assignment. 

o When the workflow is checked in, double-click a wait-for rule to view (not modify) the 
condition. 

o You can also use the buttons to modify finishing touches and integration links while the 
workflow is checked in. 

• Clone a task with its input and output routes using Clone under the right-click menu (instead of 
Copy, which does not copy the routes). 

• Copy or move a route to a new origin or destination task. See Add Routes for more information. 

• If your routes are criss-crossing, getting too long, or otherwise cluttering up your map, try tidying it 
up with wormholes. 

• If a large number of work items could pile up in an end task, consider turning on Withdraw 
Documents Upon Completion so the work items don't pile up in the end task. If a large number of 
work items have already piled up in your end task, you can use the Withdraw All option to 
withdraw all work items from the end task. See End Task and Withdraw for more information. 

• If you do not want to configure a complex conditional route right away, enter a Description for the 
conditional route as to what it will be and the route will remain dashed and incomplete until you 
come back later to finish its configuration. See Conditional Route for more information. 
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• Use an Other conditional route to catch work items that do not meet any of the other conditional 
routes. 

• When creating or modifying a notification, work-o-gram, or hub task program, use Rule Tokens to 
write custom SQL (Structured Query Language) to retrieve values you want to use in the email or 
command line. For example, you may write SQL to retrieve a custom list of email addresses, stored 
in a location other than the file cabinet, to use as email recipients. 

• When creating or modifying a notification in the HTML format, click Show Source to add advanced 
HTML features, such as pictures, links, etc. 

• When creating or modifying a long notification, drag the gray split bar up to see more of the body. 

• To see everywhere a notification is assigned, go to Tools>Notification Administrator, select a 

notification, and click Current Assignments . 

• If you want a notification to only appear for a specific workflow, when creating the notification select 
the Limit to Workflow option. 

• Bookmark your favorite workflows or bookmark a group of workflows that go together, then select 
the bookmark in File>Workflow Bookmarks to open all its workflows at once. 

• If you want other designers to see the workflow version you are working on changing, Check In a 
Non-Published Version to the workflow's version history for others to see. See Check In Version 
for more information. 

• If you do not want Workflow iQ Manager to warn you about open workflows on exit, turn this 
warning off under Tools>Advanced Options>Warn On Exit. 

• Fit the workflow in the Workflow iQ Manager screen by clicking Zoom to Fit in the standard toolbar. 

• Change a task icon to your own custom icon by right-clicking the task and selecting Change 
Picture. See Add Tasks for more information. 

• If you want to show some task and route labels but hide others, in the right-click menu use Hide 
Text or Show Text. See Add Tasks and Add Routes for more information. 

• If you just created a new workflow and the Rex Connection in the Rex toolbar is red, Rex does not 
yet know about the workflow in order to process it. Rex will find the workflow and begin processing 
on its own, or you can force Rex to take over the workflow by clicking the down arrow on the Rex 

action button in the Rex toolbar and selecting Take Over Workflow Processing. 

• Use Edit>Find Task to find any task in the workflow by name. See Add Tasks for more 
information. 

• If you want to grant a user access to open a workflow in Workflow iQ Manager but not put them in 
the workflow's administration group, add them to the Workflow Permissions list. 

• Open Work Info by double-clicking the work item count above a task (instead of selecting Work 
Info under the right-click menu). 

• In Work Info, if a value does not display in its entirety, click the Best Fit Displayed Data button in 
the upper left of the grid. Alternatively, you can just mouse over the value and it will display in a 
tooltip in its entirety. 

• Use the Status Locator to find any work item in any workflow that is in Error or On Hold. 

• Double-click a row to open the workflow and go to the task, from the Status Locator, Locations 
dialog, and notification's Current Assignments. 

• If you are waiting for work items to leave a wait-for task, check the Wait-For Status to see whether 
the work items meet the specified rule(s). 

• If you are monitoring multiple workflows at once, instead of manually switching between the 
workflows have them automatically switch using View>Auto-Cycle. See The Workflow Tabs for 
more information. 
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• Use the Summarize feature in Information Tasks to show the count of work items across multiple 
tasks (or even multiple workflows). For example, you could configure an information task to show a 
sum of all work items in all user tasks in a given workflow. 

• Use a Box to visually group tasks in the workflow map. 

• If you have FDD Client installed, open a work item from Workflow iQ Manager's Work Info in FDD 
Client using View Item or Work or leap on a work item using Leap. See View Work Info for more 
information. 

• Find all locations where a work item exists in any workflow using Locate in Work Info. 

• If you have a route that is long or positioned in such a way that you are unsure of its origin and 
destination tasks, right-click the route and select Route Information. See Add Routes for more 
information. 

• If you are unsure why a work item has gone into error in your workflow process, view the Rex log to 
get more information on when and why Rex encountered the error. See Monitor Rex for more 
information. 

• Mouse over the text Rex Connection in the Rex toolbar to see how much time there is until the 
next time Rex is scheduled to process workflows. 

• If you do not want the Rex Monitor to launch every time you prompt Rex using the Rex action 

button   in the Rex toolbar, turn off Show Monitor on Requests under Tools>Rules 
Engine. 

• You can prompt Rex to immediately process workflows, polled insert conditions, wait-for tasks, 

rendezvous tasks, and deadline routes or tasks using the Rex action button in the Rex 
toolbar. Rex will perform these checks on its own at configured intervals and you may change the 
intervals for Rex's checks in order to tune Rex according to the needs of your system. See Monitor 
Rex and Rex Manual for more information. 

• If you do not want the Rex Monitor to open every time you prompt Rex to do work, turn it off under 
Tools>Rules Engine>Show Monitor on Requests. 

• When importing and mapping various objects, sometimes the Compare Objects option is available 
and can provide you with more information on what your mapping to and from (e.g. a file cabinet 
field's Description and Type). 

• When importing and replacing mapped objects (e.g. notifications, finishing touches, rule tokens, 
etc), right-click on the Replace checkbox and choose Check All or Uncheck All to change the 
selection for multiple objects quickly. 

• If you want to reuse a workflow design, select File>Clone Workflow (see Clone Workflow for more 
information). If you want to reuse a workflow design on a different base file cabinet, export and 
import the workflow design, creating a new workflow built on the desired base file cabinet (see 
Export and Import for more information). 

• If you are disconnected from the FDD database while in Workflow iQ Manager, attempt to repair 
the connection using File>Repair Connection or save your work using Tools>Advanced 
Options>Save Backup File. See Disconnected for more information. 
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Login 
To login to Workflow iQ Manager: 

1. In your start menu programs list select Workflow iQ Manager under Feith Systems. The Feith 
Workflow iQ Manager Login dialog opens. 

2. Enter your Login name. 

3. Enter your Password. 

4. Enter your Database. 

5. Optionally select the following: 

• Remember Password: Turn this option on for Workflow iQ Manager to remember your 
password and fill it in for you. 

• Auto Login: Turn this option on to remember all your login information and automatically 
log into Workflow iQ Manager next time, skipping the login dialog. 
 

 

6. Click OK. You are logged into Workflow iQ Manager. 
 
If you have chosen to have Workflow iQ Manager Remember Open Workflows (under the File 
menu), workflows left open the last time you exited Workflow iQ Manager are opened. 
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Single Sign-On 

To login to Workflow iQ Manager if your FDD system is configured for Single Sign-On: 

1. In your start menu programs list select Workflow iQ Manager under Feith Systems. The Feith 
Workflow iQ Manager Login dialog opens. 

2. Leave the Login and Password fields empty. 

3. Enter your Database. 

4. Optionally, if you want to skip the login dialog in future, turn on the Auto Login option and 
Workflow iQ Manager will login for you automatically, skipping the login dialog. 
 

 

5. Click OK. You are Single Signed-On to Workflow iQ Manager. 
 
If you have chosen to have Workflow iQ Manager Remember Open Workflows (under the File 
menu), workflows left open the last time you exited Workflow iQ Manager are opened. 
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Disconnected 
When Workflow iQ Manager loses connectivity to the FDD database, it goes into the "disconnected" state. 
Workflow iQ Manager provides options to attempt to repair the connection and save your work. 

  

When Happens When I am Disconnected? 

When Workflow iQ Manager loses connectivity to the FDD database, it goes into the "disconnected" state. In 
the disconnected state, the title bar says ***DISCONNECTED*** and all operations requiring database 
connectivity are disabled. It may be that there is a network issue or the FDD database is down. 

  

What Should I Do When I am Disconnected? 

Wait and see if the connection will be re-established without closing Workflow iQ Manager. Depending on 
the nature of the issue, it may take more or less time before the FDD database is available again for 
Workflow iQ Manager to connect. 

• Attempt to repair Workflow iQ Manager's connection to the FDD database. 

o When the Auto-Repair Connection option is on, Workflow iQ Manager will automatically 
attempt to repair the connection to the database every five minutes. You may toggle this 
option in Tools>Advanced Options>Auto-Repair Connection. 

o Attempt to repair the connection manually by selecting File>Repair Connection. Repair 
Connection is a better alternative to File>Reconnect because Repair Connection does 
not close your workflows. 
 
Note: This option only appears when in the disconnected state. 

Save your work if it seems that the disconnection issue will last for a while, you need or want to close 
Workflow iQ Manager, or just to be safe. 

• Save your changes to any checked out workflows. 
 
Save a backup .fwf file of the workflow map with your changes using Tools>Advanced 
Options>Save Backup File. See Save and Restore Backup Files for more information. 

  

What Should I Do When the Connection is Restored? 

If you are still in Workflow iQ Manager when the FDD database connection is restored, you can move on 
normally. To be safe, you may want to immediately save any workflows you have checked out with changes. 
See Save Draft for more information. 

If you have a backup .fwf file that you saved when disconnected, restore the workflow map from the file 
using Tools>Advanced Options>Restore Backup File. See Save and Restore Backup Files for more 
information. 
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The Menus 
Workflow iQ Manager has the following menus: File, Edit, View, Tools, and Help. 

  

File Menu 

MENU OPTION ACTION 

New (CTRL+N) Create a new workflow. 

Open (CTRL+O) Open a workflow. 

Close Close the workflow. 

Tip: Close a workflow with a "middle-click" on its tab using the mouse wheel. 

Close All Close all open workflows. 

Close Others Close all open workflows except the current workflow. 

Save Draft (CTRL+S) Save a personal draft of the workflow with the changes you have made 
without putting the changes into production. 

Publish Workflow Publish the workflow and put it into production. 

Clone Workflow Clone the workflow, creating a new workflow with the same design as the 
original. 

Delete Workflow Delete the workflow. The workflow is no longer in production, but the 
workflow map and version history are saved. A deleted workflow can be re-
published if desired. 

Version History View the workflow's version history. 

Check Out Check out the workflow to modify the design. 

Check in Version Check in a non-published version of the workflow into the workflow's version 
history. 

Undo Check Out Undo the check out of a workflow, which will lose all changes made since 
the workflow was last checked out. 

Print (CTRL+P) Print the workflow map. 

Print Preview View a preview of a printed workflow map before printing it. 

Page Setup Adjust the page settings for printing, such as the orientation, layout, margins, 
etc. 

Properties View or modify the workflow's properties, including its name, description, 
base file cabinet, and administration group. 
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Permissions View or modify supplemental permissions to the workflow for users or groups 
that are not in the administration group or are not a super administrator user. 

Export Export the workflow design. 

Import Import an exported workflow design. 

Report View a report of the workflow design. 

Remember Open 
Workflows 

Turn this option on to have Workflow iQ Manager remember which 
workflows you had open when you last exited Workflow iQ Manager. The 
next time you open Workflow iQ Manager those workflows are opened 
automatically. 

Recent Workflows Lists the last six opened workflows. 

Reconnect Close the current database connection and connect again. This is useful for 
switching your user login or database, or for re-establishing a connection to 
the database after being disconnected. 

Repair Connection Attempt to repair the connection to the database. This option only appears 
when Workflow iQ Manager has become disconnected from the database. 

Exit Exit Workflow iQ Manager and close the database connection. If a workflow 
map is open, it is closed and you are prompted to save any changes. 

  

Edit Menu 

MENU OPTION ACTION 

Undo (CTRL+Z) Undo the previous action. There are four levels of undo per workflow. 

Redo (CTRL+Y) Redo the previous undone action. 

Cut (CTRL+X) Cut a task, graphical element, or text and move it to the clipboard. If you 
want to move a route, see Add Routes for more information. 

Copy (CTRL+C) Copy a task, graphical element, or text to the clipboard. If you want to copy a 
task with its routes, use Clone instead. If you want to copy a route, see Add 
Routes for more information. 

Paste (CTRL+V) Paste the contents of the clipboard, such as a task, graphical element, or 
text. 

Clone (CTRL+L) Clone a task with its input and output routes, graphical element, or text. If 
you want to copy a route, see Add Routes for more information. 

Delete (DELETE key) Delete the selected object, such as a task, route, or graphical element. 
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Select All (CTRL+A) Select all objects in the workflow map. This is useful for moving the entire 
workflow diagram around in the map or changing the task and route label 
display to show or hide labels for all tasks and routes in the workflow at 
once. See Add Tasks and Add Routes for more information on task and 
route labels. 

Select All Tasks Select all tasks in the workflow map. This is useful for changing the task 
label display to show or hide labels for all tasks in a workflow at once. See 
Add Tasks for more information on task labels. 

Select All Routes Select all routes in the workflow map. This is useful for changing the route 
label display to show or hide labels for all routes in a workflow at once. See 
Add Routes for more information on route labels. 

Find Task Find a task in the workflow by selecting it from the task list. You are scrolled 
to the task in the workflow map. 

Tip: In the task list hit the key of the first letter of the task name to jump to 
that part of the task list. Hit the letter key multiple times to cycle through all 
tasks that start with that letter. Also, use the up and down arrow keys in the 
task list to select the desired task. 

  

View Menu 

MENU OPTION ACTION 

Standard Toolbar Toggle the display of the standard toolbar. See The Toolbars for more 
information. 

Administrator Toolbar Toggle the display of the administrator toolbar. See The Toolbars for more 
information. 

Rex Toolbar Toggle the display of the Rex toolbar. See The Toolbars for more 
information. 

Dashboard iQ Display a dashboard made in Feith Dashboard iQ below your workflow. A 
dashboard may be configured to display workflow processing and other 
relevant information. See The Dashboard iQ Pane for more information. 

Theme Display workflows in the desired theme. 

Grid Density Display the grid in a Dense or Sparse pattern. The grid displays when the 
workflow is checked out. See The Workflow Map for more information. 

Background Color Display workflows with the desired map background color. See The 
Workflow Map for more information. 

Background Image Display workflows with the desired map background image. See The 
Workflow Map for more information. 

Default Route Style Choose the default route style from the options Polyline, Polyline with 
Destination Arrow, and Bezier Curve. See Add Routes for more 
information. 
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Default Font Choose the default font, size, style, and color for text in the workflow map, 
such as task labels, route labels, and text in graphical elements. 

Animation Toggle animation of routes that indicates the progress of work items through 
the workflow. 

Auto-Cycle Turn this option on to have Workflow iQ Manager automatically switch the 
display between open workflows at a specified interval. See The Workflow 
Tabs for more information. 

Next Workflow 
(CTRL+TAB) 

Go to the next open workflow, moving left to right. 

Zoom Percentage Select or enter the desired zoom percentage. 

Zoom to Fit Zoom to fit the entire workflow map in the Workflow iQ Manager screen. 

Task Labels Toggle the display of all task labels. 

Route Labels Toggle the display of all route labels. 

Work Item Counts Toggle the display of work item counts above tasks. 

Work Item Count Font Choose the font, size, style, and color of the work item counts above tasks. 

  

Tools Menu 

MENU OPTION ACTION 

Status Locator Open the status locator to locate work items in error or on hold across all 
workflows to which you have access. See Status Locator for more 
information. 

Notification 
Administrator 

Create and maintain notifications. See Notify for more information. 

Integration Link 
Administrator 

Create and maintain integration links. See Assign Integration Link for more 
information. 

Finishing Touch 
Administrator 

Create and maintain finishing touches. See Finishing Touches for more 
information. 

Rule Token 
Administrator 

Create and maintain rule tokens. See Rule Tokens for more information. 

Calendar Editor Create and maintain calendars. See Calendars for more information. 

Vacation Planner Create and maintain substitute assignments for users on vacation. See 
Vacation Planner for more information. 
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Advanced Options Choose from the following advanced options: 

• Save Backup File: Save the workflow in a .fwf file on your local 
computer. See Save and Restore Backup Files for more 
information. 

• Restore Backup File: Restore the workflow from a .fwf file on your 
local computer. This may need to be done to restore changes that 
were lost when Workflow iQ Manager was disconnected from the 
database. See Save and Restore Backup Files for more 
information. 

• Auto-Repair Connection: Turn this option on to have Workflow iQ 
Manager attempt to repair a lost database connection every five 
minutes. See Disconnected for more information. 

• Warn On Exit: Turn this option on to have Workflow iQ Manager 
prompt you with a warning when you try to exit with workflows still 
open. Turn this option off to not get any warning and Workflow iQ 
Manager will just close the workflows and exit. 

Feith Control Panel Launch the desired Feith Control Panel module. 

Note: This option is only available if Feith Control Panel is installed on your 
computer. 

Forms iQ Designer Launch Feith Forms iQ Designer. 

Note: This option is only available if Forms iQ Designer is installed on your 
computer. 

Rules Engine Choose from the following Rules Engine (Rex) options: 

• Allow Connections: Turn this option on to allow Rex connections 
to Workflow iQ Manager. 

• Rex Connection: Lists available Rex engines with the current Rex 
selected. Select a different Rex as desired. 

• Refresh Connection: Refresh the list of available Rex engines. 
Refreshing the connection also switches to the Rex working the 
workflow (e.g. if you have more than one Rex running and different 
Rexes work different workflows for purposes of load balancing). 

• Rex Monitor: View the Rex Monitor, which displays what Rex is 
doing and when. See Monitor Rex for more information. 

• Show Monitor on Requests: Turn this option on to automatically 
launch the Rex Monitor when you prompt Rex to process work 

items using the Rex action button  in the Rex toolbar. See 
Monitor Rex for more information. 
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Help Menu 

MENU OPTION ACTION 

Feith Workflow iQ 
Manager Help (F1) 

View the Workflow iQ Manager help file. 

About Feith Workflow 
iQ Manager 

View Workflow iQ Manager version, build, and copyright information. You 
may also view Session Info including the user logged in, database server, 
and when you connected. 
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The Toolbars 
There are a few toolbars used when working in Workflow iQ Manager. You may toggle the display of each 
toolbar in the View menu by checking them on or un-checking them off as desired. 

• Standard Toolbar: Perform standard actions such as create a new workflow, open a workflow, 
view workflow properties, copy, paste, zoom, etc. 

• Administrator Toolbar: Interact with the workflow map using navigation tools and add tasks, 
routes, and graphical elements. 

• Rex Toolbar: Interact with and control the Feith Rules Engine (Rex), which moves work items 
through the workflow. 

  

Standard Toolbar 

Perform standard actions such as create a new workflow, open a workflow, view workflow properties, copy, 
paste, zoom, etc. 

To toggle the display of the standard toolbar select View>Standard Toolbar. 

TOOL ACTION 

Refresh Work Item 
Counts 

Refresh the work item counts displayed above the tasks. Hover your mouse 
over this button to see how long before Workflow iQ Manager automatically 
refreshes the counts. 

New Workflow Create a new workflow. 

Open Workflow Open a workflow. 

Save Draft 
Save a personal draft of the workflow with the changes you have made without 
putting the changes into production. 

Print Print the workflow map. 

Workflow Properties 
View or modify the workflow's properties, including its name, description, base 
file cabinet, and administration group. 

Workflow 
Permissions 

View or modify supplemental permissions to the workflow for users or groups 
that are not in the administration group or are not a super administrator user. 

Cut 
Cut a task, graphical element, or text and move it to the clipboard. If you want 
to move a route, see Add Routes for more information. 

Copy 

Copy a task, graphical element, or text to the clipboard. If you want to copy a 
task with its routes, use Clone instead. If you want to copy a route, see Add 
Routes for more information. 

Paste Paste the contents of the clipboard, such as a task, graphical element, or text. 

Undo Undo the previous action. There are four levels of undo per workflow. 
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Redo Redo the previous undone action. 

Zoom In Zoom in the workflow map. 

Zoom Out Zoom out the workflow map. 

Zoom 
Percentage 

Select or enter the desired zoom percentage. 

Zoom to Fit Zoom to fit the entire workflow map in the Workflow iQ Manager screen. 

  

Administrator Toolbar 

Interact with the workflow map using navigation tools and add tasks, routes, and graphical elements. The 
administrator toolbar is located on the left-hand side of the Workflow iQ Manager screen when viewing a 
workflow. 

To toggle the display of the administrator toolbar select View>Administrator Toolbar. 

TOOL ACTION 

Pointer 

Select an object in the workflow map. You may select 
multiple objects by clicking on the map and drawing a box 
around the objects you want to select, or by holding down 
CTRL or SHIFT and selecting the desired objects. With one 
or more objects selected, click-and-drag to move the objects 
in the workflow map. To de-select one or more objects click in 
an empty space in the workflow map. 

Tips: 

• Switch to the Pointer tool using CTRL+1. This may 
be helpful when you want to quickly switch back to 
the pointer tool after placing tasks or drawing routes. 

• With the Pointer tool selected, hold down SHIFT to 
temporarily switch to the Grabby Hand tool and 
scroll the map with click-and-drag. 

Grabby Hand 
Click-and-drag to scroll the workflow map. 

Zoom Box 

Left-click to zoom in and CTRL+left-click to zoom out. You 
may also click on the map and drag to draw a box around the 
part of the map you want to zoom in on. 
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Tasks 

Expand   or collapse  the list of task types. See Add 
Tasks for more information on task types and adding tasks to 
a workflow. 

To add a task to a workflow: 

1. Select the desired task tool in the administrator 
toolbar. 

2. Click on the workflow map to add a task. Click in 
multiple locations to add more tasks. 

User 
Add user task. 

Hub Add hub task. 

Rendezvous 
Add rendezvous task. 

Wait-For 
Add wait-for task. 

Subflow Add subflow task. 

End 
Add end task. 

Deadline Add deadline task. 

Information 
Add information task. 

Routes 

Expand   or collapse  the list of route types. See Add 
Routes for more information on route types and adding routes 
to a workflow. 

To add a route to a workflow: 

1. Select the desired route tool in the administrator 
toolbar. 

2. Click on the origin task and drag the cursor over the 
destination task and release the mouse button. The 
route is drawn between the two tasks and the route 
arrow indicates the route direction. 

Automatic Add automatic route. 

Single-Select Manual 
Add single-select manual route. 

Multi-Select Manual Add multi-select manual route. 

Optional 
Add optional route. 

Conditional 
Add conditional route. 

Deadline Add deadline route. 

Error 
Add error route. 



Workflow Manager Interface 

Feith Workflow iQ Manager 9.2 User Guide     31 

Auto-Distribute 
Add auto-distribute route. 

Information Add information route. 

Graphical Elements 
Expand   or collapse  the list of graphical elements. See 
Add Graphical Elements for more information. 

Text 
Click on the workflow map to add a text box and then type the 
desired text. 

Label 
Click on the workflow map to add a label. You may double-
click the label to enter text if desired. 

Picture 

Click on the workflow map to add a picture and then double-
click the picture to select the desired picture file. It is 
recommended to use small images. 

Box Click on the workflow map and drag to draw a box. 

Wormhole 

Click on the workflow map to add a wormhole then draw a 
route that goes through the wormhole. 

 
Admin Button 

The admin button changes between common administrative 
actions depending on the state of the workflow, including 
Publish Workflow, Check Out Workflow, and Undo Check 
Out. 

 
Current Workflow Information 

Information on the workflow, including: 

• Workflow Status. A workflow may be In 
Development, Live, or Deleted. See Workflow and 
Version Status for more information. 

• Workflow Version number. If the workflow is 
checked out it says the workflow map is a Checked 
Out Draft and displays the version number the draft 
is Based On. 

• The Total number of work items in the workflow. 

• The number of work items in Error in the workflow. 

  

  



Workflow Manager Interface 

Feith Workflow iQ Manager 9.2 User Guide     32 

Rex Toolbar 

Interact with and control the Feith Rules Engine (Rex), which moves work items through the workflow. 

To toggle the display of the Rex toolbar select View>Rex Toolbar. 

TOOL ACTION 

 
Rex Connection 

Your Rex connection. If the Rex connection text is blue 
then Rex is working the workflow; if the Rex connection is 
red then Rex is not working the workflow. 

Tip: Mouse over the text Rex Connection to see how 
much time there is until the next time Rex is scheduled to 
process workflows. 

/   Rex Status 
The status of Rex, either connected to Workflow iQ 
Manager or disconnected from Workflow iQ Manager. 

Process Workflows (and other 
actions) 

Process work items in the workflows now or request Rex 
to do other types of processing, such as checking polled 
conditions, wait-for task rules, or deadlines. 

Rex Monitor 
View the Rex Monitor, which displays what Rex is doing 
and when. 
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The Workflow Tabs 
Each open workflow has a tab and the workflow tabs display in the upper left of the Workflow iQ Manager 
screen next to the administrator toolbar. 

Note: A workflow tab with a checkmark icon   is checked out by you. See Modify Workflow for more 
information. 

  

Select Workflow Tabs 

Left-click a workflow tab to view that open workflow. 

Tip: Use the keyboard shortcut CTRL+TAB to go to the next open workflow, moving left to right. Use 
SHIFT+CTRL+TAB to go to the previous open workflow, moving right to left. 

  

Remember Open Workflows 

Have Workflow iQ Manager remember which workflows you had open when you last exited Workflow iQ 
Manager. The next time you open Workflow iQ Manager those workflows are opened automatically. 

Turn this option on by selecting File>Remember Open Workflows. 

  

Reorder Workflow Tabs 

Arrange the workflows in the desired order. 

To reorder workflow tabs: 

• Click-and-drag the workflow tab to the desired location. 

  

Close Workflow Tabs 

To close one or more workflow tabs: 

• Right-click on a workflow tab and select the desired option: 

o Close: Close the right-clicked workflow. 

o Close All: Close all workflows. 

o Close Others: Close all open workflows except the right-clicked workflow. 

Tip: Close a workflow with a "middle-click" on its tab using the mouse wheel. 

  

  



Workflow Manager Interface 

Feith Workflow iQ Manager 9.2 User Guide     34 

Auto-Cycle Workflow Tabs 

Turn on Auto-Cycle to have Workflow iQ Manager automatically switch the display between open workflows 
at a specified interval. This is useful for monitoring multiple workflows at once if you do not want to manually 
switch between them. 

To turn on auto-cycle: 

1. Select View>Auto-Cycle. The Auto-Cycle Workflow dialog opens. 

2. Enter how often you want to cycle to the next workflow 
 

 

3. Click OK. Workflow iQ Manager auto-cycles from one workflow to the next at the specified interval. 
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The Workflow Map 
The workflow map contains the tasks, routes, and graphical elements illustrating the workflow. There are a 
few basic tools for interacting with the workflow map as well as several display options. You may also print 
the workflow map. 

• Basic Tools 

• Map Display Options 

• Print the Workflow Map 

For information on adding tasks, routes, and graphical elements see Add Tasks, Add Routes, and Add 
Graphical Elements. 

  

Basic Tools 

There are a few basic tools for interacting with the workflow map: 

• Pointer: Select and interact with objects in the workflow map using the Pointer tool from the 
administrator toolbar. 
 
Tips: 

o Switch to the Pointer tool using CTRL+1. This may be helpful when you want to quickly 
switch back to the pointer tool after placing tasks or drawing routes. 

o With the Pointer tool selected, hold down SHIFT to temporarily switch to the Grabby 
Hand tool and scroll the map with click-and-drag. 

• Grabby Hand: Besides the traditional scroll bars, you may scroll the workflow map with click-and-

drag using the Grabby Hand tool from the administrator toolbar. With the grabby hand tool 
selected you may also double-click a task or route to view its properties. 

• Zoom Box: Left-click to zoom in and CTRL+left-click to zoom out using the Zoom Box tool 
from the administrator toolbar. You may also click on the map and drag to draw a box around the 
part of the map you want to zoom in on. 

• Standard Toolbar: On the standard toolbar use the Zoom In  and Zoom Out   buttons or 

specify a Zoom Percentage   by selecting or entering the desired zoom. You may also 

click Zoom to Fit to fit the entire workflow map in the Workflow iQ Manager screen. 

  

Map Display Options 

There are several display options for the workflow map. 

To choose your preferred theme for the workflows: 

1. Select View>Theme. The theme list displays. 

2. Select the desired theme. The selected theme is applied to the workflows. 

To choose you preferred background color for the workflows: 

1. Select File>Background Color. The Color dialog opens. 

2. Select the desired color. 

3. Click OK. The selected background color is applied to the workflows. 
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To choose a background image for the workflows. 

1. Select View>Background Image>Choose Image. The Open dialog displays. 

2. Choose the desired image and click Open. The background image is applied to the workflows. 
 
You may optionally tile the background image by selecting View>Background Image>Tile Image. 

To clear the background image: 

• Select View>Background Image>Clear Image. 

To choose the desired grid density when viewing a checked-out workflow. 

• Select View>Grid Density and select either the Dense or Sparse pattern. The selected density is 
applied to the workflows. 

To choose the default route style: 

• Select View>Default Route Style and choose from the options Polyline, Polyline with 
Destination Arrow, and Bezier Curve. See Add Routes for more information. 

To choose the default font, size, style, and color for task labels, route labels, and graphical elements: 

1. Select View>Default Font. The Font dialog opens. 

2. Choose the desired font options and click OK. Objects with text added from this point forward will 
use the new font options. 

To turn animation on or off: 

• Select View>Animation to toggle animation of routes that indicates the progress of work items 
through the workflow. 

To turn all task labels on or off: 

• Select View>Task Labels. 

To turn all route labels on or off: 

• Select View>Route Labels. 

To turn work item counts above tasks on or off: 

• Select View>Work Item Counts. 

To choose the font, size, style, and color for work item counts above tasks: 

1. Select View>Work Item Count Font. The Font dialog opens. 

2. Choose the desired font options and click OK. The new font options are applied to the work item 
counts. 
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Print the Workflow Map 

You may print the workflow map as well as preview the printout and set the desired print settings. 

To print the workflow map: 

1. Select File>Print. The Print dialog opens. 

2. Select the desired options and click OK. The workflow is printed. 

Notes: 

• The printout always has a plain white background (regardless of your selected background color or 
whether you have a background image). 

• The printing time will be considerably longer if a high number of tasks have custom pictures. 

To preview the printout: 

• Select File>Print Preview. The Print preview dialog opens. 

To adjust the page settings for printing: 

1. Select File>Page Setup. The Page Setup dialog opens. 

2. Select the desired options and click OK. The page settings are saved. 
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The Dashboard iQ Pane 
View a Dashboard iQ dashboard, which may be configured to show workflow processing or other relevant 
information, inside Workflow iQ Manager next to your workflows. Dashboards are created in Feith 
Dashboard iQ. 

  

To turn on the Dashboard iQ Pane: 

1. Select View>Dashboard iQ. The Choose Dashboard dialog opens. 
 

 

2. Double-click a dashboard. The Dashboard iQ Pane opens at the bottom of the Workflow iQ 
Manager screen and displays the selected dashboard. 
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Dashboard iQ Pane Display Options 

• Mouse over the top of the Dashboard iQ pane to get a re-sizing cursor and click-and-drag the pane 
to adjust it to the desired height. 

• Click Refresh  to refresh the dashboard and display the latest data. The dashboard will refresh 
on its own at a regular interval. 

• Click Choose Dashboard   to choose a different dashboard to view. 

• Click Pop Dashboard To Web Browser  to view the dashboard in the full web browser. 
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Undo and Redo 
You may undo your previous action or redo the previous undone action. There are four levels of undo per 
workflow. 

  

To undo an action: 

1. Select Edit>Undo. Alternatively, click Undo on the standard toolbar or use CTRL+Z. 
 
The Undo menu option under Edit specifies the action that will be undone (e.g., Undo Add Task, 
Undo Delete, Undo Edit Route). If the action cannot be undone (e.g. publish a workflow), the 
Undo menu option is disabled and states Can't Undo. 

2. The previous action in the current workflow is undone. 

  

To redo an undone action: 

1. Select Edit>Redo. Alternatively, click Redo on the standard toolbar or use CTRL+Y. 
 
The Redo menu option under Edit specifies the action that will be redone (e.g., Redo Add Task, 
Redo Delete, Redo Edit Route). 

2. The previous undone action in the current workflow is redone. 

  

Note: Once you have published or checked in a version of the workflow, you cannot undo or redo an action 
that you performed beforehand. 
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Design Workflows 
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Create a New Workflow 
Create a new workflow to process your FDD documents through a set of defined business rules. 

Note: In order to create a new workflow you must have the Workflow Administration task permission. See 
Workflow Permissions for more information. 

  

To create a new workflow: 

1. Click New Workflow in the standard toolbar. The Create New Workflow dialog opens. 

2. Enter the workflow Name. The name may be up to 32 characters long. 

3. Optionally enter a Description. The description may be up to 128 characters long. 

4. Select the workflow's Base File Cabinet which contains the FDD documents you want to process 
through the workflow. FDD documents that meet the workflow's start condition will be added to the 
workflow (see Set Start Condition for more information). 

5. Select the workflows Administration Group, the members of which may access the workflow in 
Workflow iQ Manager and the workflow's admin file cabinet in the clients, as well as receive an 
email from Rex when an error occurs in the workflow (see Errors for more information). 
 
Note: Only workflow users and groups with members that are workflow users are included in the 
list. See Feith Control Panel User Guide for more information. 
 

 

6. Click OK. The new workflow is displayed and begins with a start task (see Start Task for more 
information). 
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7. Add tasks, routes, and graphical elements to the workflow map as desired. See Add Tasks, Add 
Routes, and Add Graphical Elements for more information. 
 
Some task and route types have required settings that must be configured in order to be 
considered "complete". An incomplete task has a dashed outline; an incomplete route is a dashed 
line. 
 
Tip: While adding tasks, routes, and graphical elements, you can quickly switch back to the 
Pointer tool using CTRL+1. 
 

 
 
As you develop the workflow, click Save Draft to save a personal draft of your workflow. If you 
want another user to see or work on the workflow in development, you can select File>Check In 

Version   to make a non-published version of the workflow available for them to access. See 
Save Draft and Check In Version for more information. 
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8. When the workflow design is complete, Publish the workflow to put it into production (see Publish 
Workflow for more information). The Publish New Workflow dialog opens, prompting for a 
comment on the new workflow version. 

9. Enter a comment on the workflow version and, if desired, check Keep checked out to keep the 
workflow checked out after the publish. 
 

 

10. Click OK. The Workflow Publication Progress dialog opens and the workflow publishing process 
begins and shows a progress bar for each step taken until the workflow publish is completed. 
 
Note: If there are any incomplete tasks or routes, you will be prompted to complete their 
configuration when attempting to publish the workflow. Once all tasks and routes are complete, 
then publish the workflow. 
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11. When publication is complete, click OK. The workflow is published and live. 
 
Tip: If the Rex Connection in the Rex toolbar is red, Rex does not yet know about the workflow in 
order to process it. Rex will find the workflow and begin processing on its own, or you can force 

Rex to take over the workflow by clicking the down arrow on the Rex action button in the Rex 
toolbar and selecting Take Over Workflow Processing. 
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Add Tasks 
A task is a node where work is done, such as by a user, a program called by command line, or other work. 
A task is represented by an icon in the workflow map. There are several task types as well as various 
display options. 

See the following sections for instructions: 

• Task Types 

• Add and Arrange Tasks 

• Task Display Options 

• Find Task 

  

Task Types 

There are several task types: 

ICON TYPE 

 

Start Task 

Where work items - FDD documents or folders - enter the workflow. Every workflow 
beings with a start task and there is only one start task in a workflow. 

 

User Task 

A step requiring user action where an FDD user retrieves and processes work items. 
 
For example, a user may enter additional information for a document, verify the presence 
and accuracy of a document and its information before it moves forward, or review a 
document for approval. 

 

Hub Task 

An intersection in the workflow. Hub tasks can also be used to run an automated 
program. 

For example, an intersection may be used to conditionally route work items to other 
tasks or a program may run to export the work item's pages. 

 

Rendezvous Task 

Collects and combines copies of a work item, such as when the work item was split 
across multiple paths earlier in the workflow. 

 

Wait-For Task 

Waits for one or more specified conditions to be true for a given work item. 

For example, a work item may wait until another needed document exists in order to 
move forward in the process. 

 

Subflow Task 

Routes a work item to another workflow, which will be processed there until it returns 
back "up" to the "parent" workflow. 
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End Task 

An end point of the workflow where a work item arrives when it has finished going 
through the workflow process. 

 

Deadline Task 

Work items that have been in the workflow "too long" by reaching a specified deadline 
are sent to this task. Each workflow can only have one deadline task. 

For example, tasks following a deadline task may be designed to make sure these "late" 
work items get addressed. 

 

Information Task 

A purely illustrative task that represents a step in the process that occurs outside the 
workflow. Information tasks can also be used to show a summary of the work item 
counts across multiple tasks and even multiple workflows. 

For example, a scan step may occur before the start of the workflow and an email step 
may occur after the end of the workflow. Also, a work item count could be shown for a 
section of related tasks in the workflow. 

  

Add and Arrange Tasks 

There are various ways to add and arrange tasks. 

To add a task to the workflow map: 

1. Select the desired task tool in the administrator toolbar. 

2. Click on the workflow map to add a task. Click in multiple locations to add more tasks. 
 
Tip: After adding tasks, you can quickly switch back to the Pointer tool using CTRL+1. 

To move tasks or align them horizontally or vertically: 

1. Use the Pointer tool to select one or more tasks. You can select multiple tasks by clicking-and-
dragging a selection box around the desired tasks or using CTRL+click. 

2. Move or align the tasks: 

• Move the task(s) to the desired location using click-and-drag or the arrow keys. 

• Right-click one of the selected tasks and select Align Horizontally or Align Vertically. 

To copy a task: 

1. Right-click the desired task and select Copy. The task is copied to the clipboard. 
 
To copy multiple tasks, use the Pointer tool to select multiple tasks by clicking-and-dragging a 
selection box around the desired tasks or using CTRL+click, and then right-click one of the 
selected tasks and select Copy. 

2. Right-click in the desired location and select Paste. A copy of the original task(s) is pasted on the 
map. 

To clone a task with its input and output routes: 

• Right-click the desired task and select Clone. The task with its input and output routes is cloned 
and added to the map. 
 
To clone multiple tasks, use the Pointer tool to select multiple tasks by clicking-and-dragging a 
selection box around the desired tasks or using CTRL+click, and then right-click one of the 
selected tasks and select Clone. 
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Task Display Options 

There are various display options for tasks. 

To change a task icon to another picture: 

1. Right-click the desired task and select Change Picture. The Open dialog displays. 

2. Choose the desired image and click Open. The task's picture is changed. 

To revert a custom task picture back to the original icon: 

• Right-click the desired task and select Revert Picture. The task picture is reverted back to the 
original icon. 

To show or hide a task label: 

• Right-click the desired task and select Hide Text to hide the label or Show Text to show the label. 
 
To show or hide labels for multiple tasks, use the Pointer tool to select multiple tasks by clicking-
and-dragging a selection box around the desired tasks or using CTRL+click, and then right-click 
one of the selected tasks and select Hide Text or Show Text. 
 
To show or hide all task labels in a workflow, first select Edit>Select All Tasks then right-click a 
selected task and select Hide Text or Show Text. 
 
Tip: The view setting View>Task Labels may be used to toggle the display of all task labels across 
all workflows. 

To change a task label's font, size, style, and color: 

1. Right-click the desired task and select Font. The Font dialog opens. 
 
To change the label font for multiple tasks, use the Pointer tool to select multiple tasks by clicking-
and-dragging a selection box around the desired tasks or using CTRL+click, and then right-click 
one of the selected tasks and select Font. 

2. Choose the desired font options and click OK. The label font on the task(s) is changed. 

Tip: Change the default font for all text in all workflows using View>Default Font. 

  

Find Task 

Find a task in the workflow by selecting Edit>Find Task and selecting the task from the task list. You are 
scrolled to the task in the workflow map. 

Tip: In the task list hit the key of the first letter of the task name to jump to that part of the task list. Hit the 
letter key multiple times to cycle through all tasks that start with that letter. Also, use the up and down arrow 
keys in the task list to select the desired task. 
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Start Task 

The Start Task  is where work items - FDD documents or folders - enter the workflow. Every 
workflow beings with a start task and there is only one start task in a workflow. 

  

To configure the start task: 

1. Double-click the start task. The Task Administrator opens. 
 
Tip: As soon as the Task Administrator opens, you can take advantage of one of the following 
keyboard shortcuts: 

• Hit the TAB key once to quickly move to the Name field. This may be helpful when first 
adding tasks, especially if you are adding many tasks. 

• Use the up and down arrow keys to navigate to the desired tab. 

2. On the Main tab: 

a. Enter the task Name  The name may be up to 64 characters long. 

b. Optionally enter a Description. The description may be up to 80 characters long. 
 

 

3. Set the Start Condition. The start condition restricts which FDD documents are added to the 
workflow from the workflow's base file cabinet. See Set Start Condition for more information. 

4. Optionally assign Users who can manually add FDD documents to the workflow. See Assign Users 
to Start Task for more information. 

5. Optionally Notify workers or other parties by email. See Notify for more information. 

6. Optionally change a work item's Priority. See Priority for more information. 

7. Optionally specify how many work items Rex should be Processing in the task in a given cycle. 
See Processing for more information. 

8. Optionally assign Finishing Touches to run custom SQL when a work item leaves the task. See 
Finishing Touches for more information. 

9. Click OK. The task is configured. The dashed outline is removed, indicating the task is complete. 
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Set Start Condition 

The Start Condition  restricts which FDD documents are added to the workflow from the workflow's base 
file cabinet. By default, all documents that are indexed into the workflow's base file cabinet are added to the 
workflow. 

  

To configure the start condition: 

1. Double-click the start task. The Task Administrator opens. 

2. On the Start Condition tab, choose the desired condition: 

• Insert Condition: FDD documents indexed into the base file cabinet that match the 
specified condition are automatically added to the workflow. 

• Polled Condition: FDD documents in the base file cabinet that match the specified 
condition are added to the workflow by Rex as it polls the base file cabinet. 

• Manual Insertion or Subflow Only: FDD documents in the base file cabinet can only be 
added to the workflow manually by a user or added from a "parent" workflow with a 
subflow task pointing to this workflow (see Subflow Task for more information). 

• Note: For a workflow built on a virtual file cabinet, it is generally recommended to not use 
an Insert Condition. When using an Insert Condition or Polled Condition for a workflow 
built on a virtual file cabinet, make sure that the start condition matches the virtual file 
cabinet condition (e.g. if the virtual file cabinet only contains documents of type 
"Application" then the start condition should also only look for documents of type 
"Application"). 

3. If you choose Insert Condition or Polled Condition, optionally enter a more specific condition for 

which FDD documents will be added. You may Create  a "constructed" condition or write the 

SQL  yourself: 
 
(Note: If you want to create a FeithDrive condition, see FeithDrive Start Condition.) 

• Create a "constructed" condition: 

1. Click Create. The Edit Condition dialog opens. 

2. Select the desired field or system value 

3. Select the desired operator. Operators include equal to =, not equal to <>, less 
than <, less than or equal to <=, greater than >, greater than or equal to >=, IS 
(NULL or NOT NULL), IN (SQL), NOT IN (SQL). 

4. Select whether you want to compare a Value, Field, Function, or SQL. 

5. If you selected to compare a Value or SQL, enter the value or SQL. If the field 
has a lookup table, you can select a value from the lookup values. If you selected 
to compare a Field or Function, select the field or function. 

6. Choose whether to check the value in a Case Insensitive or Case Sensitive 
manner. 
 
Tips: 

o Click Test to see if your condition works. 

o Click Show SQL to switch to the SQL view. Note that if you make 
changes in the SQL view, you cannot go back to the "constructed" 
condition unless you revert the SQL. 
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7. Click OK. The condition is added. 

8. Optionally add more conditions by clicking And or Or . You can add more 

criteria to an and or or statement by selecting and or or and clicking Add . 
 
You can change an existing and to and or, or vice versa, by double-clicking the 
and or or and changing it to the desired operator in the And or Or dialog. 
 

Modify  or Delete conditions as needed. 

• Enter a SQL condition: 

1. Click SQL. The Edit Condition dialog opens. 

2. Enter a SQL condition. 
 

 

3. Click OK. The condition is added. 

4. Optionally restrict the start condition further by specifying the "types" of FDD objects you want to go 
into the workflow (e.g. documents, static folders). To do so: 

a. Click the current select (e.g. All Items). The Limit Items To dialog opens. 

b. Check and uncheck the desired items. 
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c. Click OK. The items are limited. 
 

 

5. Click OK. Your start condition is saved. 
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FeithDrive Start Condition 

In the case of FeithDrive, if you want to specify in the start condition which FeithDrive documents will be 
added to the workflow, you will see a FeithDrive option if your workflow is built on: 

• The FeithDrive Base file cabinet. 

• Any virtual file cabinet based on the FeithDrive Base file cabinet. 

To set a FeithDrive start condition: 

1. Click Create  and the Edit Condition dialog opens. 

2. Select FeithDrive. The FeithDrive condition options display. 

3. Select the desired Volume. The directories in the volume display. 

4. The volume's root directory is selected by default. Optionally find and select a specific directory in 
the volume. The volume/directory path displays in blue text at the bottom of the dialog. 
 
Documents in the specified volume/directory will be added to the workflow. 
 
Tip: Click Show SQL to switch to the SQL view. Note that if you make changes in the SQL view, 
you cannot go back to the "constructed" condition unless you revert the SQL. 
 

 

5. Click OK. The condition is added. 

6. Optionally add more conditions by clicking And or Or . You can add more criteria to an and 

or or statement by selecting and or or and clicking Add . 
 
You can change an existing and to and or, or vice versa, by double-clicking the and or or and 
changing it to the desired operator in the And or Or dialog. 
 

Modify   or Delete conditions as needed. 
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Assign Users to Start Task 

Assign Users   who can manually add FDD documents to the workflow. 

  

To assign users to the start task: 

1. Double-click the start task. The Task Administrator opens. 

2. On the Users tab, click Show All Selectable Groups and Users . All workflow users and 
groups with members that are workflow users are displayed in the list. 

3. Check the desired groups and users. 
 
Tip: In the group/user list hit the key of the first letter of the group/user name to jump to that part of 
the list. Hit the letter key multiple times to cycle through all groups/users that start with that letter. 
Also, use the up and down arrow keys to navigate in the group/user list. 
 

 

4. Click OK. Your user assignment is saved. 
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User Task 

A User Task   is a step requiring user action where an FDD user retrieves and processes work items. 
For example, a user may enter additional information for a document, verify the presence and accuracy of a 
document and its information before it moves forward, or review a document for approval. 

  

To add a user task: 

1. Select the User task tool in the administrator toolbar. 

2. Click on the workflow map. The task is added. 

3. Double-click the user task. The Task Administrator opens. 
 
Tip: As soon as the Task Administrator opens, you can take advantage of one of the following 
keyboard shortcuts: 

• Hit the TAB key once to quickly move to the Name field. This may be helpful when first 
adding tasks, especially if you are adding many tasks. 

• Use the up and down arrow keys to navigate to the desired tab. 

4. On the Main tab: 

a. Enter the task Name. The name may be up to 64 characters long. 

b. Optionally enter a Description. The description may be up to 80 characters long. 

c. Optionally enter Instructions that the end user can read in the client (FDD or WebFDD). 
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5. Assign Users and groups who will process work in the task and their permissions in the task. You 
may also optionally configure an Overflow Condition to add more workers to the task when the 
task's work item count reaches a certain number. See Assign Users to User Task for more 
information. 

6. Configure the task Fields that will appear to users who process work in the task. See Configure 
Fields for more information. 

7. Optionally configure Integration options to help workers process documents, including Integration 
Links and Work-o-grams. An integration link sends the worker to a related form, application, or 
URL when they are processing work in the task. A work-o-gram enables workers to process work in 
a task by email. See Assign Integration Link and Configure Work-o-gram for more information. 

8. Optionally Notify workers or other parties by email. See Notify for more information. 

9. Optionally change the work item's Priority. See Priority for more information. 

10. Optionally specify how many work items Rex should be Processing in the task in a given cycle. 
See Processing for more information. 

11. Optionally set an Advanced Condition to restrict which work items are available to which users. 
See Set Advanced Condition for more information. 

12. Optionally assign Finishing Touches to run custom SQL when a work item leaves the task. See 
Finishing Touches for more information. 

13. Click OK. The task is configured. The dashed outline is removed, indicating the task is complete. 
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Assign Users to User Task 

Assign Users   and groups who will process work in the task and their permissions in the task. The task 
appears in their Work to Do list in the clients (FDD and WebFDD). You may also optionally configure an 
Overflow Condition to add more workers to the task when the task's work item count reaches a certain 
number (see Set Overflow Condition for more information). 

Permissions include: 

• Search: Users can see the task and retrieve work in it. 

• View: Users can view the work item's pages. 

• Insert: Users can add pages to the work item. 

• Update: Users can update the work item's index values. 

• Delete: Users can delete pages from the work item. 

  

To assign groups and users to a user task: 

1. Double-click the user task. The Task Administrator opens. 

2. On the Users tab, click Show All Selectable Groups and Users . All workflow users and 
groups with members that are workflow users are displayed in the list. 

3. Select the groups and users to assign and their permissions: 

• To grant all permissions to a group or user, check the checkbox next to their name. 
 
Tip: In the group/user list hit the key of the first letter of the group/user name to jump to 
that part of the list. Hit the letter key multiple times to cycle through all groups/users that 
start with that letter. Also, use the up and down arrow keys to navigate in the group/user 
list. 

• To grant all permissions to multiple groups and users at once, select multiple groups and 
users using CTRL+click or SHIFT+click then right-click one of the selected groups/users 

and select Grant Permission . 

• To grant specific permissions to a group or user, click in the desired boxes to the right for 
the Search, View, Insert, Update, and Delete permissions to change them to Y for 
granted or blank for denied. 

• To remove a group or user from the task, uncheck the checkbox next to their name. 
 

 

4. Click OK. Your user assignment is saved. 
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 Set Overflow Condition 

An Overflow Condition adds more workers to the task when the task's work item count reaches a certain 
number, for the purpose of helping the usual workers to address the large number of work items. The 
additional workers get all resource permissions on the task, including Search, View, Insert, Update, and 
Delete. When the task's work item count falls back below a certain number, the extra workers are removed. 

To set an overflow condition: 

1. Double-click the user task. The Task Administrator opens. 

2. On the Users tab, check on Set Overflow Condition. The overflow condition options are enabled. 

3. In the When Count Equals field, enter the high number of work items that will cause additional 
workers to be added to the task. 

4. In the Add Group/User field, choose the group or user that will be added when the high count is 
reached. 
 
Note: Adding a group/user is optional; you may leave it set to <None>. In this case, no extra 
workers are assigned to the task but the usual workers are still notified when an overflow occurs. 

5. In the Until Count Equals field, enter the low number of work items that will cause the additional 
workers to be removed from the task, when they are no longer needed. 
 

 

6. Click OK. Your overflow condition is saved. 

  

  



Design Workflows 

Feith Workflow iQ Manager 9.2 User Guide     59 

Configure Fields 

Configure the task Fields  that will appear to users who process work in the task. By default, all fields 
with their properties from the workflow's base file cabinet are included in the user task. You may remove 
fields from the task and change the task field's properties, such as making a field required or assigning a 
lookup table. 

Note: Changing field properties in a user task does not affect the field properties in the workflow's base file 
cabinet. For example, if you assign a lookup table to a user task field, that lookup will not be assigned to the 
field in the workflow's base file cabinet. 

  

To configure user task fields: 

1. Double-click the user task. The Task Administrator opens. 

2. On the Fields tab, check on fields you want to include in the user task and uncheck fields you do 

not want to include in the user task. Quickly check on all fields by clicking Include All   or 

quickly check off all fields by clicking Exclude All . 
 
Note: You must include at least one field in a user task. If no fields are included, the user task is 
considered incomplete and has a dashed outline. 

3. Optionally configure fields to be Read Only, preventing them from being modified. 
 
Note: A Signature type field must be read only. 

4. Optionally configure fields to be Required, requiring them to contain a value. 
 
Notes: 

• If the field in the base file cabinet is required, then the Required setting cannot be 
changed and will remain on for that field in the user task. 

• This option is disabled if the field is already marked as Read Only. 

5. Optionally configure fields to have a Lookup Assignment, assigning a lookup table which provides 
the user with a list of values to choose from for that field. 
 
To assign a lookup to a field: 

a. In the Lookup Assignment column, click None. The Modify Lookup Assignment dialog 
opens. 

b. Choose whether to use a Feith Lookup or External Lookup: 

o A Feith Lookup is a standard Feith lookup table made in Feith Control Panel. 
See Feith Control Panel User Guide for more information. 

o An External Lookup is any table or view in the database, which you may want to 
use if the data you want is not in a standard Feith lookup table. 

c. Select or enter the lookup Table name. 

d. Select or enter the Value from the lookup that will be stored in the field. 

e. Optionally select or enter the friendly Display from the lookup table that can be used to 
clarify or help find the Value (e.g. a "Department Name" display for a "Department ID" 
value). 

f. Optionally select or enter the column by which to Order the lookup values. If an order 
column is not selected, order defaults to the Value column. 

g. Optionally select whether to Allow Override, allowing users to enter a value that is not in 
the lookup table. If you leave this option off, the users must select a value from the lookup 
table. 
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6. If you are using lookup tables, optionally select a Cascade Field to filter the field's lookup values 
based on another field. You can only select a Cascade Field that is based on the same lookup 
table. For example, if you have a "State" field with the "Locations" lookup assigned you may have a 
"City" field also with the "Locations" lookup assigned and choose to filter the lookup values for 
"City" based on the value selected for "State". 
 
Note: The following file cabinet field types are not available in the Cascade Field list: Signatures, 
List of Strings, List of Numbers, and List of Dates. 

7. Optionally reorder fields by selecting a field Name and using the Move Selected Field Up and 

Move Selected Field Down buttons. 
 

 

8. Click OK. Your field configuration is saved. 

  



Design Workflows 

Feith Workflow iQ Manager 9.2 User Guide     61 

Assign Integration Link 

Integration Links Overview 

Optionally assign an Integration Link  to help workers process work items by taking them to a related 
form, application, or URL when they are processing work in the task. When an integration link is configured 
on a user task, it is indicated by an icon representing the type of integration link. 

There integration link types are as follows: 

• Forms iQ: The specified Feith Forms iQ form opens and the user fills out the form as needed 
for that work item. 

• Application: The specified application opens and the user performs the needed actions in the 
application for that work item. 

• URL: The specified URL opens and the user performs the needed actions on the web page for 
that work item. 

See Assign Integration Link for more information on assigning an integration link to a user task. See Create 
and Maintain Integration Links for more information on creating and maintaining integration links. 
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Assign Integration Link 

Optionally assign an Integration Link  to help workers process work items by taking them to a related 
form, application, or URL when they are processing work in the task. 

See Integration Links Overview for more general information on integration links and their types. See Create 
and Maintain Integration Links for more information on creating and maintaining integration links. 

  

To assign an integration link to a user task: 

1. Double-click the user task. The Task Administrator opens. 

2. On the Integration tab, select the desired Integration Link. If needed, you may Create an 

Integration Link  (see Create and Maintain Integration Links for more information). 
 

 

3. Click OK. Your integration link assignment is saved. The integration link is indicated as assigned to 

the task by an icon representing the integration link type, including Forms iQ , Application , or 

URL . 

  

To remove an integration link from a user task: 

a. Double-click the user task. The Task Administrator opens. 

b. On the Integration tab, in the Integration Link field select <None>. 

c. Click OK. Your changes are saved. 
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Create and Maintain Integration Links 

Create and maintain integration links which may be optionally assigned to a user task in order to help 
workers process work items by taking them to a related form, application, or URL when they are processing 
work in the task. 

See Assign Integration Link for more information on assigning an integration link to a user task. 

See the following sections for instructions: 

• Create Integration Link 

• Modify Integration Link 

• Clone Integration Link 

• Delete Integration Link 

Note: Integration links can also be created and maintained in the Integration Link Administrator under the 
Tools menu. 

  

Create Integration Link 

To create an integration link: 

1. Select Tools>Integration Link Administrator. The Integration Link Administrator opens. 
 
You can also create an integration link from inside a task in the Task Administrator on the 
Integration tab. 

2. Click Create Integration Link . The Create Integration Link dialog opens. 
 

Alternatively, you may Clone  an existing integration link. See Clone Integration Link for more 
information. 

3. Choose the desired link type and configure it as needed: 

• Forms iQ: The specified Feith Forms iQ form opens and the user fills out the form as 
needed for that work item. 

• Application: The specified application opens and the user performs the needed actions in 
the application for that work item. 

• URL: The specified URL opens and the user performs the needed actions on the web 
page for that work item. 

4. Click OK. The integration link is created. See Assign Integration Link for more information on 
assigning an integration link to a user task. 

  

Modify Integration Link 

To modify an integration link: 

1. Select Tools>Integration Link Administrator. The Integration Link Administrator opens. 
 
You can also modify an integration link from inside a task in the Task Administrator on the 
Integration tab. 

2. Select the desired integration link and click Modify Integration Link . The Modify Integration 
Link dialog opens. 

3. Modify the integration link as needed according to its type, including Forms iQ, Application, or URL. 

4. Click OK. The integration link is modified. 
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Clone Integration Link 

To clone an integration link: 

1. Select Tools>Integration Link Administrator. The Integration Link Administrator opens. 
 
You can also clone an integration link from inside a task in the Task Administrator on the 
Integration tab. 

2. Select the desired integration link and click Clone Integration Link . The Clone Integration 
Link dialog opens. 

3. Modify the clone integration link as needed according to its type, including Forms iQ, Application, or 
URL. 

4. Click OK. The integration link is created. 

  

Delete Integration Link 

To delete an integration link: 

1. Select Tools>Integration Link Administrator. The Integration Link Administrator opens. 
 
You can also delete an integration link from inside a task in the Task Administrator on the 
Integration tab. 

2. Select the desired integration link and click Delete Integration Link . A prompt opens to confirm 
the delete. 

3. Click Yes to proceed with the delete. The integration link is deleted. 
 
Note: An integration link assigned to a task cannot be deleted. 
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Forms iQ Links 

Use a Forms iQ integration link which may be optionally assigned to a user task in order to help workers 
process work items by taking them to a related form that they fill out as needed for that work item. When the 
user is done filling out the form, they submit the form and the work item is marked as done and moves on to 
the next step in the workflow. 

See Assign Integration Link for more information on assigning an integration link to a user task. See Create 
and Maintain Integration Links for more information on creating and maintaining integration links. 

Notes: 

• When working in a user task with a Forms iQ link, the index values of the workflow document 
cannot be modified. The file cabinet fields are disabled in the client interface (FDD or WebFDD). 

• Manual routes are not supported as output routes for user tasks with Forms iQ links. 

  

To configure a Forms iQ integration link: 

1. Choose Forms iQ as the link type. 

2. Enter the link Name. 

3. Optionally enter a Description. 

4. Select the form Action: 

• form.do: Opens a new, blank form. 

• SignIn.do: Signs into and opens a new, blank form using the provided sign-in parameters. 
For example, the sign-in values may be used to autofill values on the form. The specified 
Form Set must have a "Sign In Page". 

• ShowLiveForm.do: Opens the existing form in the task. Select <Any Workflowed 
Form> to have the integration link open any form in the task. If you do not want to open 
any form in the task, specify a Form Set to only open forms of that form set (forms from 
other form sets will not be opened by the integration link). 

5. Select the Form Set, identifying the form you want to launch for the worker: 

• You must select a form set for an Action of form.do or SignIn.do. 

• Selecting a form set for an Action of ShowLiveForm.do is optional. Select <Any 
Workflowed Form> to have the integration link open any form in the task. If you do not 
want to open any form in the task, specify a Form Set to only open forms of that form set 
(forms from other form sets will not be opened by the integration link). 

6. Select the Forms iQ Server to be used for submitting new forms for an Action of form.do or 
SignIn.do. The Forms iQ Server is not specified for an Action of ShowLiveForm.do. 

7. If an Action of SignIn.do is selected, specify the sign-in parameters in the Additional Parameters 
field. You may use the Add Forms iQ Sign-In Field Name and Add Token lists to Insert form field 
names and tokens in order to help you build your parameters. See Appendix A: Tokens for more 
information. 
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For example, the additional parameter f_5=<FC_VALUE:Expense Report ID> would sign into the 
form by entering the work item's value for file cabinet field Expense Report ID into form field f_5, 
and values may be autofilled in the form based on that Expense Report ID (depending on the 
form's configuration). 
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Application Links 

Use an Application link which may be optionally assigned to a user task in order to help workers process 
work items by taking them to a related application where they perform the needed actions in the application 
for that work item. 

See Assign Integration Link for more information on assigning an integration link to a user task. See Create 
and Maintain Integration Links for more information on creating and maintaining integration links. 

Note: When working in a user task with an application link, the user will need to exit the application before 
returning to FDD and processing the work item. 

  

To configure an Application integration link: 

1. Choose Application as the link type. 

2. Enter the link Name. 

3. Optionally enter a Description. 

4. Enter the application Command. The path to the application should point to where it is installed on 
the user's local machine. You may use the Add Token list to Insert tokens into the command. See 
Appendix A: Tokens for more information. 
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URL Links 

Use a URL link which may be optionally assigned to a user task in order to help workers process work items 
by taking them to a related URL where they perform the needed actions on the web page for that work item. 

See Assign Integration Link for more information on assigning an integration link to a user task. See Create 
and Maintain Integration Links for more information on creating and maintaining integration links. 

  

To configure a URL integration link: 

1. Choose URL as the link type. 

2. Enter the link Name. 

3. Optionally enter a Description. 

4. Enter the URL. You may use the Add Token list to Insert tokens into the URL. See Appendix A: 
Tokens for more information. 
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Configure Work-o-gram 

Optionally configure a Work-o-gram in order to enable workers to process work in a task by email. The 
work-o-gram email includes the work item's index values and provides the recipient with the ability to "done" 
the work item by responding to the email, selecting manual routes and adding document notes if desired or 
applicable. Note that the work-o-gram text is not configurable. When a work-o-gram is configured on a user 

task, it is indicated by a mail icon . (Note that a mail icon could also indicate that there is a notification on 
the task. See Notify for more information.) 

Work-o-grams are processed by the Feith Work-o-gram Portal. 

  

To configure a work-o-gram on a user task: 

1. Double-click the user task. The Task Administrator opens. 

2. On the Integration tab, check on Send E-Mail Work-o-gram. The work-o-gram options are 
enabled. 

3. Click Show All Selectable Groups and Users . All workflow users and groups with members 
that are workflow users are displayed in the list. 

4. Check the desired groups and users. 
 
Tip: In the group/user list hit the key of the first letter of the group/user name to jump to that part of 
the list. Hit the letter key multiple times to cycle through all groups/users that start with that letter. 
Also, use the up and down arrow keys to navigate in the group/user list. 

5. Optionally enter additional recipients in the To field. When entering multiple email addresses, 
separate each value with a semicolon ;. You may use the Token list to Insert tokens into the To 
field. See Appendix A: Tokens for more information. 
 
For example, jsmith@abc.com;{FC_VALUE|mgr_email};jdoe@abcinc.com;{RULE|7} 
 
Tip: If the desired email addresses are stored in a location in the database other than the file 

cabinet, you may create a Rule Token   and write custom SQL (Structured Query Language) to 
retrieve those email addresses. See Rule Tokens for more information. 

6. Optionally select one or more Attachments to include in the work-o-gram email. 

• Document as PDF: The work item in PDF format. 
 
Note: PDF files cannot be created for FDD GOS pages or Forms iQ pages. 

• Document in Native Format: The work item in its native format. 

• URL: A WebFDD link to the work item. The recipient may click the URL to launch 
WebFDD and login to view the work item. 

• FRL: A FDD URL to the work item. The recipient may click on the .frl to launch FDD Client 
and login to view the work item. 
 
Note: FDD must be installed on the recipient's computer. 
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7. Click OK. Your work-o-gram configuration is saved. 
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Set Advanced Condition 

Optionally set an Advanced Condition  to restrict which work items are available to which users. For 
example, an advanced condition may restrict a user to only access work items where their FDD user name 
is in the work item's index values. 

  

To set an advanced condition on a user task: 

1. Double-click the user task. The Task Administrator opens. 

2. On the Advanced Condition tab, Create  a "constructed" condition or write the SQL  
yourself: 

• Create a "constructed" condition: 

1. Click Create . The Edit Condition dialog opens. 

2. Select the desired field or system value 

3. Select the desired operator. Operators include equal to =, not equal to <>, less 
than <, less than or equal to <=, greater than >, greater than or equal to >=, IS 
(NULL or NOT NULL), IN (SQL), NOT IN (SQL). 

4. Select whether you want to compare a Value, Field, Function, or SQL. 

5. If you selected to compare a Value or SQL, enter the value or SQL. If the field 
has a lookup table, you can select a value from the lookup values. If you selected 
to compare a Field or Function, select the field or function. 

6. Choose whether to check the value in a Case Insensitive or Case Sensitive 
manner. 
 
Tips: 

o Click Test to see if your condition works. 

o Click Show SQL to switch to the SQL view. Note that if you make 
changes in the SQL view, you cannot go back to the "constructed" 
condition unless you revert the SQL. 
 

 

7. Click OK. The condition is added. 

8. Optionally add more conditions by clicking And  or Or . You can add more 

criteria to an and or or statement by selecting and or or and clicking Add . 
 
You can change an existing and to and or, or vice versa, by double-clicking the 
and or or and changing it to the desired operator in the And or Or dialog. 
 

Modify  or Delete conditions as needed. 

• Enter a SQL condition: 

1. Click SQL . The Edit Condition dialog opens. 

2. Enter a SQL condition. 
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Note: The table referenced in the above SQL is not in the standard Feith FDD 
Schema but is used only for the purpose of this example. 

3. Click OK. The condition is added. 
 

 

3. Click OK. Your advanced condition is saved. 
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Hub Task 

A Hub Task   is an intersection in the workflow. Hub tasks can also be used to run an automated 
program. For example, an intersection may be used to conditionally route work items to other tasks or a 
program may run to export the work item's pages. 

  

To add a hub task: 

1. Select the Hub task tool in the administrator toolbar. 

2. Click on the workflow map. The task is added. 

3. Double-click the hub task. The Task Administrator opens. 
 
Tip: As soon as the Task Administrator opens, you can take advantage of one of the following 
keyboard shortcuts: 

• Hit the TAB key once to quickly move to the Name field. This may be helpful when first 
adding tasks, especially if you are adding many tasks. 

• Use the up and down arrow keys to navigate to the desired tab. 

4. On the Main tab: 

a. Enter the task Name. The name may be up to 64 characters long. 

b. Optionally enter a Description. The description may be up to 80 characters long. 
 

 

5. Optionally configure a Program to run for a work item when it enters the task. See Configure 
Program for more information. 

6. Optionally Notify workers or other parties by email. See Notify for more information. 

7. Optionally change the work item's Priority. See Priority for more information. 

8. Optionally specify how many work items Rex should be Processing in the task in a given cycle. 
See Processing for more information. 

9. Optionally assign Finishing Touches to run custom SQL when a work item leaves the task. See 
Finishing Touches for more information. 

10. Click OK. The task is configured. The dashed outline is removed, indicating the task is complete. 
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Configure Program 

Optionally configure a Program  to run for a work item when it enters the task. For example, a program 
may run to export the work item's pages. Rex starts and runs the program for every work item that enters the 
task and waits for the program to successfully exit before sending the work item on to the next step in the 

workflow. When a program is configured on a hub task, it is indicated by a command window icon . 

  

To configure a program on a hub task: 

1. Double-click the user task. The Task Administrator opens. 

2. On the Program tab, enter the Command Line you want to run on the work items. You may use 
the Token list to Insert tokens into the Command Line. See Appendix A: Tokens for more 
information. 
 
Tip: If a desired value for the Command Line is stored in a location in the database other than the 

file cabinet, you may create a Rule Token  and write custom SQL (Structured Query Language) 
to retrieve that value. See Rule Tokens for more information. 

3. Optionally specify the Maximum Number of Concurrent External Processes. For an important 
hub task you would have a higher number; for an unimportant hub task you would have a lower 
number. For example, if you have an unimportant hub task with a lot of documents, you could lower 
the hub task down to 2 concurrent processes. That way, the task is only working up to two 
documents at a time and doesn't take Rex's attention away from more important work. 
 
Note: Rex has a global limit of concurrent external processes, which applies to all hub tasks, set in 
its initialization file. See Rex Manual for more information. 
 

 

4. Click OK. Your program configuration is saved. 
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Rendezvous Task 

A Rendezvous Task collects and combines copies of a work item, such as when the work item was 
split across multiple paths earlier in the workflow. When a work item arrives at a rendezvous task, it waits 
until all its other copies in previous tasks in the workflow arrive at the rendezvous task. When all copies 
arrive at the rendezvous task, the work item moves on to the next step in the workflow. 

  

To add a rendezvous task: 

1. Select the Rendezvous task tool in the administrator toolbar. 

2. Click on the workflow map. The task is added. 

3. Double-click the rendezvous task. The Task Administrator opens. 
 
Tip: As soon as the Task Administrator opens, you can take advantage of one of the following 
keyboard shortcuts: 

• Hit the TAB key once to quickly move to the Name field. This may be helpful when first 
adding tasks, especially if you are adding many tasks. 

• Use the up and down arrow keys to navigate to the desired tab. 

4. On the Main tab: 

a. Enter the task Name. The name may be up to 64 characters long. 

b. Optionally enter a Description. The description may be up to 80 characters long. 
 

 

5. Optionally Notify workers or other parties by email. See Notify for more information. 

6. Optionally change the work item's Priority. See Priority for more information. 

7. Optionally specify how many work items Rex should be Processing in the task in a given cycle. 
See Processing for more information. 

8. Optionally assign Finishing Touches to run custom SQL when a work item leaves the task. See 
Finishing Touches for more information. 

9. Click OK. The task is configured. The dashed outline is removed, indicating the task is complete. 
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Wait-For Task 

A Wait-For Task  waits for one or more specified conditions to be true for a given work item. For 
example, a work item may wait until another needed document exists in order to move forward in the 
process. A work item must meet all conditions in order to move on to the next step in the workflow. You may 
view the conditions a given work item meets or does not meet by right-clicking the wait-for task and selecting 
Wait-For Status. See Wait-For Status for more information. 

  

To add a wait-for task: 

1. Select the Wait-For task tool in the administrator toolbar. 

2. Click on the workflow map. The task is added. 

3. Double-click the wait-for task. The Task Administrator opens. 
 
Tip: As soon as the Task Administrator opens, you can take advantage of one of the following 
keyboard shortcuts: 

• Hit the TAB key once to quickly move to the Name field. This may be helpful when first 
adding tasks, especially if you are adding many tasks. 

• Use the up and down arrow keys to navigate to the desired tab. 

4. On the Main tab: 

a. Enter the task Name. The name may be up to 64 characters long. 

b. Optionally enter a Description. The description may be up to 80 characters long. 
 

 

5. Set one or more Wait-For rules that a work item must meet in order to move on to the next step in 
the workflow. You can set up Expected Documents rules or Wait-For Condition rules. See Set 
Expected Documents or Set Wait-For Condition for more information. 

6. Optionally Notify workers or other parties by email. See Notify for more information. 

7. Optionally change the work item's Priority. See Priority for more information. 

8. Optionally specify how many work items Rex should be Processing in the task in a given cycle. 
See Processing for more information. 

9. Optionally assign Finishing Touches to run custom SQL when a work item leaves the task. See 
Finishing Touches for more information. 

10. Click OK. The task is configured. The dashed outline is removed, indicating the task is complete. 
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Set Expected Documents 

Set one or more Expected Documents rules that a work item must meet in order to move on to the next 
step in the workflow. Expected Documents rules check for the existence of a document in any file cabinet. 

Note: The following file cabinet field types are not available in the This File Cabinet Key Field, Join File 
Cabinet Field, or Document Type Field lists: Signatures, List of Strings, List of Numbers, and List of Dates. 

See the following sections for instructions: 

• Create Expected Documents Rule 

• Modify Expected Documents Rule 

• Delete Expected Documents Rule 

  

Create Expected Documents Rule 

To create an expected documents rule: 

1. Double-click the wait-for task. The Task Administrator opens. 

2. On the Wait-For tab, click Create Wait-For Rule . The Wait-For Rule dialog opens and the 
Expected Documents screen displays. 

3. Select This File Cabinet Key Field whose value will be used for comparison in the other file 
cabinet. 

4. Select the Join File Cabinet where you are looking for the expected documents. 

5. Select the Join File Cabinet Key Field whose value is compared to the value from the This File 
Cabinet Key Field. 

6. Select the Document Type Field of the file cabinet that contains the document type of the 
expected documents. 

7. In the Document Type list, enter one or more document types you are looking for and the Count 
of how many of each must exist to satisfy the rule: 

a. You can click in the Document Type field and start typing or, if the Document Type Field 
has a lookup table, you can select a document type value from the lookup values. 

b. Hit the TAB key or click in the Count column. The Document Type is added. If needed, 
change the Count from the default of 1 to the desired value. 
 

 
 

To delete a Document Type, right-click a row and select Delete Rows . You can 
select multiple rows to delete using CTRL+click or SHIFT+click. 
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8. Click OK. Your expected documents rule is created. You may optionally add more wait-for rules, 
whether expected documents rules or wait-for condition rules (see Set Wait-For Conditions for 
more information). Note if you specify more than one wait-for rule, a work item must meet all the 
rules to move on. 
 

 

  

Modify Expected Documents Rule 

To modify an expected documents rule: 

1. Double-click the wait-for task. The Task Administrator opens. 

2. On the Wait-For  tab, select the desired expected documents rule and click Modify Wait-For 

Rule . The Wait-For Rule dialog opens. 

3. Modify the expected documents rule as desired. 

4. Click OK. The expected documents rule is modified. 

  

Delete Expected Documents Rule 

To delete an expected documents rule: 

1. Double-click the wait-for task. The Task Administrator opens. 

2. On the Wait-For  tab, select the desired expected documents rule and click Delete Wait-For 

Rule . The expected documents rule is deleted. 
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Set Wait-For Condition 

Set one or more Wait-For Condition rules that a work item must meet in order to move on to the next step 
in the workflow. Wait-for Conditions check for a value in the file cabinet for This Work Item or elsewhere in 
the database in an External Table. 

See the following sections for instructions: 

• Create Wait-For Condition Based on This Work Item 

• Create Wait-For Condition Based on an External Table 

• Modify Wait-For Condition 

• Delete Wait-For Condition 

Tip: Double-click a wait-for rule while the workflow is checked in to view (not modify) the condition. 

  

Create Wait-For Condition Based On This Work Item 

To create a wait-for condition based on a value in the file cabinet for this work item: 

1. Double-click the wait-for task. The Task Administrator opens. 

2. On the Wait-For tab, click Create Wait-For Rule . The Wait-For Rule dialog opens. 

3. Select Wait-For Condition. The Wait-For Condition screen displays. 

4. Indicate that the condition is Based On a value in the file cabinet for This Work Item. 

5. Specify and configure the desired Wait Condition: 

• To compare a file cabinet Field value to an expected value: 

a. Choose Field as the Wait Condition. 

b. Select the file cabinet Field for the comparison. 

c. Select the desired operator. Operators include equal to =, not equal to <>, less 
than <, less than or equal to <=, greater than >, greater than or equal to >=, IS 
(NULL or NOT NULL). 

d. Select whether you want to compare a Value or a Field. 

e. If you selected to compare a Value, enter the value. If the field has a lookup 
table, you can select a value from the lookup values. If you selected to compare 
a Field, select the file cabinet field or enter a system value (e.g. SYSDATE on 
Oracle or getdate() on MS SQL Server). 
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• To Wait Until a specified time referencing a file cabinet field: 

a. Choose Wait Until as the Wait Condition. 

b. Enter the number of Day(s) to wait. 

c. Select whether to wait After or Before the date to be specified. 

d. Select the file cabinet field containing the date value you want to reference. 
 

 

• To set an Advanced SQL Condition using the file cabinet fields: 

a. Choose Advanced SQL Condition as the Wait Condition. 

b. Enter the desired SQL using the file cabinet fields. 
 
Tip: To avoid a potential conflict with a file cabinet field column name, put the 
alias "t." in front of the file cabinet field column name. For example 
t.work_status='pending'. 
 

 
 
Note: The table referenced in the above SQL is not in the standard Feith FDD 
Schema but is used only for the purpose of this example. 

6. Click OK. Your wait-for condition is created. You may optionally add more wait-for rules, whether 
wait-for condition rules or expected documents rules (see Set Expected Documents for more 
information). Note if you specify more than one wait-for rule, a work item must meet all the rules to 
move on. 
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Create Wait-For Condition Based On an External Table 

To create a wait-for condition based on a value in an external table: 

1. Double-click the wait-for task. The Task Administrator opens. 

2. On the Wait-For tab, click Create Wait-For Rule . The Wait-For Rule dialog opens. 

3. Select Wait-For Condition. The Wait-For Condition screen displays. 

4. Indicate that the condition is Based On a value in an External Table and enter the table name. 

5. Specify the Join Condition, selecting a field in the file cabinet or the system {DOC_ID} and 
entering the Column it matches in the external table. 

6. Indicate the Count of rows you want the work item to wait for in the external table (that meet the 
Join Condition and Wait Condition). 

7. Specify and configure the desired Wait Condition: 

• To compare a Database Table Column value to an expected value: 

a. Choose Database Table Column as the Wait Condition. 

b. Enter the table column for the comparison. 

c. Select the desired operator. Operators include equal to =, not equal to <>, less 
than <, less than or equal to <=, greater than >, greater than or equal to >=, IS 
(NULL or NOT NULL). 

d. Select whether you want to compare a Value or a Column. 

e. If you selected to compare a Value, enter the value. If you selected to compare a 
Column, enter the table column or a system value (e.g. SYSDATE on Oracle or 
getdate() on MS SQL Server). 
 

 
 
Note: The table referenced above is not in the standard Feith FDD Schema but 
is used only for the purpose of this example. 

• To Wait Until a specified time referencing a table column: 

a. Choose Wait Until as the Wait Condition. 

b. Enter the number of Day(s) to wait. 

c. Select whether to wait After or Before the date to be specified. 

d. Enter the table column containing the date value you want to reference. 
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• To set an Advanced SQL Condition using the table columns: 

a. Choose Advanced SQL Condition as the Wait Condition. 

b. Enter the desired SQL using the table columns. 
 
Tip: To avoid a potential conflict with an external table column name, put the 
alias "t." in front of the external table column name. For example 
t.work_status='pending'. 
To avoid a potential conflict with a file cabinet field column name, which you can 
also use inside an Advanced SQL Condition based on an external table, put 
the alias "f." in front of the file cabinet field column name. For example 
f.work_status='pending'. 
 

 
 
Note: The table referenced in the above SQL is not in the standard Feith FDD 
Schema but is used only for the purpose of this example. 

8. Click OK. Your wait-for condition is created. You may optionally add more wait-for rules, whether 
wait-for condition rules or expected documents rules (see Set Expected Documents for more 
information). Note if you specify more than one wait-for rule, a work item must meet all the rules to 
move on. 
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Modify Wait-For Condition 

To modify a wait-for condition: 

1. Double-click the wait-for task. The Task Administrator opens. 

2. On the Wait-For tab, select the desired wait-for condition rule and click Modify Wait-For Rule . 
The Wait-For Rule dialog opens. 

3. Modify the wait-for condition as desired. 

4. Click OK. The wait-for condition is modified. 

  

Delete Wait-For Condition 

To delete a wait-for condition: 

1. Double-click the wait-for task. The Task Administrator opens. 

2. On the Wait-For tab, select the desired wait-for condition rule and click Delete Wait-For Rule . 
The wait-for condition is deleted. 
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Subflow Task 

A Subflow Task routes a work item to another workflow, which will be processed there until it returns 
back "up" to the "parent" workflow. When a work item reaches an end task in the subflow, it is removed from 
the subflow and moves on in the parent workflow to the next step after the subflow task. 

Notes: 

• When designing a workflow to be used as a subflow, the start task condition should be set to 
Manual Insertion or Subflow Only. This prevents work items from be added directly to the 
subflow from either an insert or polled start condition. See Set Start Condition for more 
information. 

• When designing a workflow to be used as a subflow, start task permissions should generally not 
be granted to any users or groups. This will prevent users from having permission to manually 
add items to the subflow. See Assign Users to Start Task for more information. 

  

To add a subflow task: 

1. Select the Subflow task tool in the administrator toolbar. 

2. Click on the workflow map. The task is added. 

3. Double-click the subflow task. The Task Administrator opens. 
 
Tip: As soon as the Task Administrator opens, you can take advantage of one of the following 
keyboard shortcuts: 

• Hit the TAB key once to quickly move to the Name field. This may be helpful when first 
adding tasks, especially if you are adding many tasks. 

• Use the up and down arrow keys to navigate to the desired tab. 

4. On the Main tab: 

a. Enter the task Name. The name may be up to 64 characters long. 

b. Optionally enter a Description. The description may be up to 80 characters long. 

c. Select the Workflow to be used as a subflow. The list includes all workflows built on the 
same file cabinet as the current workflow. 
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5. Optionally Notify workers or other parties by email. See Notify for more information. 

6. Optionally change the work item's Priority. See Priority for more information. 

7. Optionally specify how many work items Rex should be Processing in the task in a given cycle. 
See Processing for more information. 

8. Optionally assign Finishing Touches to run custom SQL when a work item leaves the task. See 
Finishing Touches for more information. 

9. Click OK. The task is configured. The dashed outline is removed, indicating the task is complete. 
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End Task 

An End Task   is an end point of the workflow where a work item arrives when it has finished going 
through the workflow process. When a work item reaches an end task, it is "complete". A workflow may have 
multiple end tasks. 

  

To add an end task: 

1. Select the End task tool in the administrator toolbar. 

2. Click on the workflow map. The task is added. 

3. Double-click the end task. The Task Administrator opens. 
 
Tip: As soon as the Task Administrator opens, you can take advantage of one of the following 
keyboard shortcuts: 

• Hit the TAB key once to quickly move to the Name field. This may be helpful when first 
adding tasks, especially if you are adding many tasks. 

• Use the up and down arrow keys to navigate to the desired tab. 

4. On the Main tab: 

a. Enter the task Name. The name may be up to 64 characters long. 

b. Optionally enter a Description. The description may be up to 80 characters long. 

c. Optionally choose to Withdraw Documents Upon Completion, withdrawing the work 
items from the workflow once they reach an end task and are marked as "complete". 
 
Tip: The Withdraw Documents Upon Completion option is helpful if many work items 
could pile up in the end task. Viewing work info in an end task can get slower as the 
number of work items increases. 
 

 

5. Optionally Notify workers or other parties by email. See Notify for more information. 

6. Optionally change the work item's Priority. See Priority for more information. 

7. Optionally specify how many work items Rex should be Processing in the task in a given cycle. 
See Processing for more information. 

8. Optionally assign Finishing Touches to run custom SQL when a work item leaves the task. See 
Finishing Touches for more information. 

9. Click OK. The task is configured. The dashed outline is removed, indicating the task is complete. 
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Deadline Task 

The Deadline Task receives work items that have been in the workflow "too long" by reaching a 
specified deadline. When a work item reaches the specified deadline, it is moved from its current location in 
the workflow to the deadline task. For example, tasks following a deadline task may be designed to make 
sure these "late" work items get addressed. Each workflow can only have one deadline task. 

The deadline assigned by a Deadline Task is also known as a "Workflow Deadline", since the deadline 
applies to the entire workflow. 

If you want to set a deadline for a task, see Deadline Route for more information. 

  

To add a deadline task: 

1. Select the Deadline task tool in the administrator toolbar. 

2. Click on the workflow map. The task is added. 

3. Double-click the deadline task. The Task Administrator opens. 
 
Tip: As soon as the Task Administrator opens, you can take advantage of one of the following 
keyboard shortcuts: 

• Hit the TAB key once to quickly move to the Name field. This may be helpful when first 
adding tasks, especially if you are adding many tasks. 

• Use the up and down arrow keys to navigate to the desired tab. 

4. On the Main tab: 

a. Enter the task Name. The name may be up to 64 characters long. 

b. Optionally enter a Description. The description may be up to 80 characters long. 

c. Select the Calendar on which to base the deadline. 

d. Enter the deadline time in Months, Days, Hours, and/or Minutes. 

e. In the After field, select the system or file cabinet field date and/or time you want to 
reference to start counting down to the deadline. 
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5. Optionally Notify workers or other parties by email. See Notify for more information. 

6. Optionally change the work item's Priority. See Priority for more information. 

7. Optionally specify how many work items Rex should be Processing in the task in a given cycle. 
See Processing for more information. 

8. Optionally assign Finishing Touches to run custom SQL when a work item leaves the task. See 
Finishing Touches for more information. 

9. Click OK. The task is configured. The dashed outline is removed, indicating the task is complete. 

  

Note: Using the interval of Months, Days, Hours, and/or Minutes and the After reference date, Rex 
calculates the future deadline date and time in the following sequence: 

1. Rex counts forward the given number of Months, taking into account changes in the year and the 
day of the month (based on the available days in the determined month). The time of day does 
not change and stays the same time as the After reference date. 

2. Rex counts forward the given number of Days, taking into account the Work Week business days 
of the selected Calendar. The time of day does not change and stays the same time as the After 
reference date. 

3. Rex counts forward the given number of Hours, taking into account the Business Hours of the 
Work Week in the selected Calendar. 

4. Rex counts forward the given number of Minutes, taking into account the Business Hours of the 
Work Week in the selected Calendar. 
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Information Task 

An Information Task  is a purely illustrative task that represents a step in the process that occurs 
outside the workflow. Information tasks can also be used to show a summary of the work item counts across 
multiple tasks and even multiple workflows. 

For example, a scan step may occur before the start of the workflow and an email step may occur after the 
end of the workflow. 

 

Also, a work item count could be shown for a section of related tasks in the workflow. 

 

  

To add an information task: 

1. Select the Information task tool in the administrator toolbar. 

2. Click on the workflow map. The task is added. No additional configuration is required, but you may 
want to configure the information task further. 

3. Double-click the information task. The Modify Information Task dialog opens. 

4. Optionally enter the task Name. 

5. Optionally enter a Description. 

6. Optionally Summarize the work item counts of other tasks: 

a. Click Add Task . The Add Task to Summary dialog opens. 

b. Select the Workflow from which you want to add tasks. 
 
Note: The Workflow list only contains workflows built on the same base file cabinet as 
the workflow that has the information task. 

c. Select one or more Tasks you want to summarize from the selected workflow. Select 
multiple tasks using CTRL+click or SHIFT+click. 
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d. Click OK. The tasks are added to the Summarize list. You may continue to Add Tasks 

 or Remove Tasks  as desired. 
 

 

7. Click OK. The task is configured. 

8. Optionally change the task icon by right-clicking the information task and selected Change Picture. 
Workflow iQ Manager provides some standard icons for external processes in its install directory 

under the Icons folder, such as an inbox  or scanner . See Add Tasks for more information 
on changing a task's icon. 
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Notify 

Optionally Notify  workers or other parties by email. For example, a notification may be sent to alert a 
worker of an important event in the workflow process. When a notification is assigned to a task, it is 

indicated by a mail icon . (Note that a mail icon could also indicate that there is a work-o-gram for a user 
task. See Configure Work-o-gram for more information.) 

Once you create a notification it is available to assign to any task in any workflow. If desired, when creating 
a notification you may limit it to only be available in one specific workflow. See Create and Maintain 
Notifications for more information. 

Notifications may be sent at different times as follows: 

• On Arrival: The notification is sent each time a work item arrives at the task. 

• On Departure: The notification is sent each time a work item leaves the task. 

• As Reminder: The notification is sent for each work item that has spent a specified amount of time 
in the task. 
 
Note: You can only assign one notification as a reminder to a task. 

• As Repeating Reminder: A notification is sent for each work item that has spent a specified 
interval in the task every time the specified interval passes. 
 
Note: You can only assign one notification as a repeating reminder to a task. 

The time a notification can be sent is limited by task type as follows: 

TASK TYPE ON ARRIVAL ON DEPARTURE AS REMINDER AS REPEATING 

REMINDER 

Start Task N/A Available N/A N/A 

User Task Available Available Available Available 

Hub Task Available Available N/A N/A 

Rendezvous Task Available Available Available Available 

Wait-For Task Available Available Available Available 

Subflow Task Available Available Available Available 

End Task Available N/A N/A N/A 

Deadline Task Available Available N/A N/A 
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Assign Notification 

Optionally Notify  workers or other parties by email. For example, a notification may be sent to alert a 
worker of an important event in the workflow process. When a notification is assigned to a task, it is 

indicated by a mail icon . (Note that a mail icon could also indicate that there is a work-o-gram for a user 
task. See Configure Work-o-gram for more information.) 

See Notifications Overview for more general information on notifications and when they can be sent. See 
Create and Maintain Notifications for more information on creating and maintaining notifications. 

See the following sections for instructions: 

• Assign Notification 

• Modify Notification Assignment 

• Remove Notification 

Tip: To see everywhere a notification is assigned, go to Tools>Notification Administrator, select a 

notification, and click Current Assignments . Double-click a row to open the workflow and go to the task. 

  

Assign Notification 

To assign a notification to a task: 

1. Double-click the desired task. The Task Administrator opens. 

2. On the Notify tab, click Assign Notification . The Assign Notification dialog opens. 

3. Select the desired Notification. If needed, you may Create a Notification   (see Create and 
Maintain Notifications for more information). 

4. Select When the notification will be sent: 

• On Arrival: The notification is sent each time a work item arrives at the task. 

• On Departure: The notification is sent each time a work item leaves the task. 

• As Reminder: The notification is sent for each work item that has spent a specified 
amount of time in the task. 
 
Note: You can only assign one notification as a reminder to a task. 

• As Repeating Reminder: A notification is sent for each work item that has spent a 
specified interval in the task every time the specified interval passes. 
 
Note: You can only assign one notification as a repeating reminder to a task. 

• Note: The time a notification can be sent is limited by task type. See Notifications 
Overview for more information. 

5. If you are sending the notification As a Reminder or As a Repeating Reminder: 

a. Select the Calendar on which to base the reminder time. 

b. Enter the reminder time in Months, Days, Hours, and/or Minutes. 

6. Optionally select one or more Attachments to include in the notification email: 

• Document as PDF: The work item in PDF format. 
 
Note: PDF files cannot be created for FDD GOS pages or Forms iQ pages. 

• Document in Native Format: The work item in its native format. 
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• URL: A WebFDD link to the work item. The recipient may click the URL to launch 
WebFDD and login to view the work item. 

• FRL: A FDD URL to the work item. The recipient may click on the .frl to launch FDD Client 
and login to view the work item. 
 
Note: FDD must be installed on the recipient's computer. 

7. In the To Task Group field select a group or user you want to send the notification to for this 
specific task, in addition to the recipients already configured in the notification itself. 
 

 

8. Click OK. The notification is assigned to the task. 
 

 

9. In the Task Administrator, click OK. Your notification assignment is saved. 
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Modify Notification Assignment 

To modify a notification assignment: 

1. Double-click the desired task. The Task Administrator opens. 

2. On the Notify  tab, select the desired notification and click Modify Notification Assignment 
. The Assign Notification dialog opens. 

3. Modify the notification assignment options as desired. 

4. Click OK. The notification assignment is modified. 

5. In the Task Administrator, click OK. Your notification assignment is saved. 

  

Remove Notification 

To remove a notification from a task: 

1. Double-click the desired task. The Task Administrator opens. 

2. On the Notify  tab, select the desired notification and click Remove Notification . The 
notification is removed from the task. 

3. In the Task Administrator, click OK. Your changes are saved. 
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Create and Maintain Notifications 

Create and maintain email notifications which may be sent to workers or other parties. For example, a 
notification may be sent to alert a worker of an important event in the workflow process. 

Once you create a notification it is available to assign to any task in any workflow. If desired, when creating 
a notification you may limit it to only be available in one specific workflow. 

See Notifications Overview for more general information on notifications and when they can be sent. See 
Assign Notification for more information on assigning a notification to a task. 

See the following sections for instructions: 

• Create Notification 

• Modify Notification 

• Clone Notification 

• Delete Notification 

Note: Notifications can also be created and maintained in the Notification Administrator under the Tools 
menu. 

  

Tip: When creating or modifying a notification, you may want to include values that are stored in a location 

in the database other than the file cabinet. Use Rule Tokens to write custom SQL (Structured Query 
Language) to retrieve values you want to use in the notification's To, Cc, Bcc, From, From Name, Reply 
To, Subject, or Body. For example, you may write SQL to retrieve a custom list of email addresses to use 
as the email recipients. See Rule Tokens for more information. 

  

Create Notification 

To create a notification: 

1. Select Tools>Notification Administrator. The Notification Administrator opens. 
 
You can also create a notification from inside a task in the Task Administrator on the Notify tab 

by clicking Assign Notification . 

2. Click Create Notification . The Create Notification dialog opens. 
 

Alternatively, you may Clone   an existing notification. See Clone Notification for more 
information. 

3. Enter the notification Name. 

4. Click Show All Selectable Groups and Users . All workflow users and groups with members 
that are workflow users are displayed in the list. 

5. Locate the desired group and user recipients in the list and specify whether you want to send the 
email notification To them, Cc them, or Bcc them. You may select multiple groups and users using 

CTRL+click or SHIFT+click and right-click to choose Send To Selected Groups , Carbon 

Copy Selected Groups , or Blind Carbon Copy Selected Groups . 
 
Tip: In the group/user list hit the key of the first letter of the group/user name to jump to that part of 
the list. Hit the letter key multiple times to cycle through all groups/users that start with that letter. 
Also, use the up and down arrow keys to navigate in the group/user list. 

6. Optionally enter additional recipients in the To, Cc, and Bcc fields. When entering multiple email 
addresses, separate each value with a semicolon ;. You may use the Token list to Insert tokens 
into the To, Cc, or Bcc fields. See Appendix A: Tokens for more information. 
 
For example, jsmith@abc.com;{FC_VALUE|mgr_email};jdoe@abcinc.com;{RULE|7} 



Design Workflows 

Feith Workflow iQ Manager 9.2 User Guide     96 

7. Optionally enter the From email address that you want to send the email notification (other than the 
Rex global default). You may use the Token list to Insert tokens into the From field. See Appendix 
A: Tokens for more information. 

8. Optionally enter the From Name that you want to display as the friendly name of the email 
notification's sender.   You may use the Token list to Insert tokens into the From field. See 
Appendix A: Tokens for more information. 

9. Optionally enter one or more Reply To email addresses that the notification recipient would reply 
to. When entering multiple email addresses, separate each value with a semicolon ;. You may use 
the Token list to Insert tokens into the Reply To field. See Appendix A: Tokens for more 
information. 
 
For example, jsmith@abc.com;{FC_VALUE|mgr_email};jdoe@abcinc.com;{RULE|7} 

10. Enter the email notification's Subject. You may use the Token list to Insert tokens into the Subject 
field. See Appendix A: Tokens for more information. 

11. Choose the Body format you want to use, either Plain Text or HTML. 

12. Enter the Body of the notification email. You may use the Token list to Insert tokens into the Body 
field. See Appendix A: Tokens for more information. 
 
Tips: 

• If you are using the HTML format, click Show Source  to add advanced HTML 
features, such as pictures, links, etc. 

• If the body is long, you may drag the gray split bar up to see more of the body. 

13. Optionally turn off the Limit to Workflow option to allow this notification to be used in multiple 
workflows. Leave this option on to limit the notification to only be available in this specific workflow. 
 

 

14. Click OK. The notification is created. See Assign Notification for more information on assigning a 
notification to a task. 

  



Design Workflows 

Feith Workflow iQ Manager 9.2 User Guide     97 

Modify Notification 

To modify a notification: 

1. Select Tools>Notification Administrator. The Notification Administrator opens. 
 
You can also modify a notification from inside a task in the Task Administrator on the Notify tab 

by clicking Assign Notification . 
 
Tip: When the workflow is checked in, double-click the notification in the Notify tab to open the 
notification assignment. 

2. Select the desired notification and click Modify Notification . The Modify Notification dialog 
opens. 

3. Modify the notification as needed. 
 
Note: If you uncheck the Limit to Workflow option and save the notification, it cannot be turned 
back on for that notification. 

4. Click OK. The notification is modified. 

  

Clone Notification 

To clone a notification: 

1. Select Tools>Notification Administrator. The Notification Administrator opens. 
 
You can also clone a notification from inside a task in the Task Administrator on the Notify tab by 

clicking Assign Notification . 

2. Select the desired notification and click Clone Notification . The Clone Notification dialog 
opens. 

3. Modify the clone notification as needed. 

4. Click OK. The notification is created. 

  

Delete Notification 

To delete a notification: 

1. Select Tools>Notification Administrator. The Notification Administrator opens. 
 
You can also delete a notification from inside a task in the Task Administrator on the Notify tab 

by clicking Assign Notification . 

2. Select the desired notification and click Delete Notification . A prompt opens to confirm the 
delete. 

3. Click Yes to proceed with the delete. The notification is deleted. 
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Priority 

Optionally change the work item's Priority On Arrival to a task and/or At an Interval while it sits in a 
user, rendezvous, wait-for, or subflow task. Priority is on a scale of 1 to 9, with 1 being the highest priority. 
The default priority is 9. 

  

Update Priority on Arrival 

To update a work item's priority on arrival to a task: 

1. Double-click the desired task. The Task Administrator opens. 

2. On the Priority tab, check on Update Priority on Arrival To. The arrival priority options enable. 

3. Select a specific priority to which you want to update a work item when it arrives or Upgrade or 
Downgrade the priority one or more Levels relative to a work item's current priority when it arrives. 
 

 

4. Click OK. Your priority configuration is saved. 
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Update Priority at Interval 

To update a work item's priority at an interval in a user, rendezvous, wait-for, or subflow task: 

1. Double-click the desired task. The Task Administrator opens. 

2. On the Priority tab, check on Update Priority At Interval To. The interval priority options enable. 

3. Select a specific priority to which you want to update a work item at an interval or Upgrade or 
Downgrade the priority one or more Levels relative to the work item's current priority at an interval. 

4. Select the Calendar on which to base the interval. 

5. Enter the interval time in Months, Days, Hours, and/or Minutes. 
 

 

6. Click OK. Your priority configuration is saved. 
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Processing 

Optionally specify how many work items Rex should be Processing  in the task in a given cycle. By 
default, Rex processes up to 1,000 work items in each task. You may increase the number for more 
important tasks or decrease the number for less important tasks. 

  

To configure specific processing rules for a task: 

1. Double-click the desired task. The Task Administrator opens. 

2. On the Processing tab, change the Number Of Items In Task To Process Per Rules Engine 
Cycle from Use Default to entering a specific number. 

3. Enter the number of work items in the task that you want Rex to process per cycle. Increase the 
number above 1,000 for more important tasks or decrease the number below 1,000 for less 
important tasks. 
 

 

4. Click OK. Your processing configuration is saved. 
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Finishing Touches 

Assign Finishing Touch 

Optionally assign Finishing Touches  to run custom SQL (Structured Query Language) when a work 

item leaves the task. When a finishing touch is assigned to a task, it is indicated by a pen icon . 

Note: A system finishing touch with a yellow icon  is a specialized finishing touch created by Feith and it 
is not recommended to make changes to a system finishing touch. 

See Create and Maintain Finishing Touches for more information on creating and maintaining finishing 
touches. 

  

To assign a finishing touch to a task: 

1. Double-click the desired task. The Task Administrator opens. 

2. On the Finishing Touches tab, click Assign Finishing Touch . The Assign Finishing 
Touches dialog opens. 
 

Alternatively, you may Create a Finishing Touch . See Create Finishing Touch for more 
information. 
 

 

3. Select one or more finishing touches. Select multiple finishing touches using CTRL+click or 
SHIFT+click. 
 

Tip: View a finishing touch's SQL by selecting it and clicking Describe Finishing Touch . 
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4. Click OK. The finishing touch(es) is added to the list. 
 

 

5. Optionally reorder the finishing touches by selecting one or more and using the Move Selected 

Finishing Touches Up  and Move Selected Finishing Touches Down  buttons, specifying 
the order in which they should run. Select multiple finishing touches using CTRL+click or 
SHIFT+click. 

6. Click OK. Your finishing touch assignment is saved. 

  

To remove a finishing touch from a task: 

1. Double-click the desired task. The Task Administrator opens. 

2. On the Finishing Touches tab, select the desired finishing touch and click Remove Finishing 

Touch . The finishing touch is removed from the task. 
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Create and Maintain Finishing Touches 

Optionally assign Finishing Touches  to run custom SQL when a work item leaves the task. 

See the following sections for instructions: 

• Create Finishing Touch 

• Modify Finishing Touch 

• Clone Finishing Touch 

• Retire/Un-Retire Finishing Touch 

• Delete Finishing Touch 

Note: Finishing touches can also be created and maintained in the Finishing Touch Administrator under 
the Tools menu. 

  

Create Finishing Touch 

To create a finishing touch: 

1. Select Tools>Finishing Touch Administrator. The Finishing Touch Administrator opens. 
 
You can also create a finishing touch from inside a task in the Task Administrator on the 
Finishing Touches tab. 

2. Click Create a Finishing Touch . The Create Finishing Touch dialog opens. 
 

Alternatively, you may Clone   an existing finishing touch. See Clone Finishing Touch for more 
information. 

3. Enter the finishing touch Name. 

4. Enter the SQL to run in the finishing touch. You may use the Token list to Insert tokens into the 
SQL field. See Appendix A: Tokens for more information. 
 

 
 
Note: The table referenced in the above SQL is not in the standard Feith FDD Schema but is used 
only for the purpose of this example. 

5. Click OK. The finishing touch is created. See Assign Finishing Touch for more information on 
assigning a finishing touch to a task. 

  



Design Workflows 

Feith Workflow iQ Manager 9.2 User Guide     104 

Modify Finishing Touch 

To modify a finishing touch: 

1. Select Tools>Finishing Touch Administrator. The Finishing Touch Administrator opens. 
 
You can also modify a finishing touch from inside a task in the Task Administrator on the 
Finishing Touches tab. If the finishing touch you want to modify is not assigned to the task, you 

can view all finishing touches by clicking Assign Finishing Touch . 
 

Note: A system finishing touch with a yellow icon  is a specialized finishing touch created by 
Feith and it is not recommended to make changes to a system finishing touch. 

2. Select the desired finishing touch and click Modify Finishing Touch . The Modify Finishing 
Touch dialog opens. 

3. Modify the finishing touch as needed. 

4. Click OK. The finishing touch is modified. 

  

Clone Finishing Touch 

To clone a finishing touch: 

1. Select Tools>Finishing Touch Administrator. The Finishing Touch Administrator opens. 
 
You can also clone a finishing touch from inside a task in the Task Administrator on the Finishing 

Touches tab by clicking Assign Finishing Touch . 

2. Select the desired finishing touch and click Clone Finishing Touch . The Clone Finishing 
Touch dialog opens. 

3. Modify the clone finishing touch as needed. 

4. Click OK. The finishing touch is created. 

  

Retire/Un-Retire Finishing Touch 

You can retire a finishing touch so it continues to be used where it is currently assigned but cannot be 
assigned anywhere new. This would be an "intermediate" step taken prior to deleting the finishing touch; 
maybe you have a newer, better finishing touch to replace it but you want to keep around the old finishing 
touch while preventing other workflow designers from using it in new places. 

To retire a finishing touch: 

1. Select Tools>Finishing Touch Administrator. The Finishing Touch Administrator opens. 

2. Select the desired finishing touch and click Retire Finishing Touch . The finishing touch is 
retired. It will run where it is currently assigned but it cannot be assigned anywhere new. 

To view retired finishing touches: 

• In the Finishing Touch Administrator, click the radio button to view All Finishing Touches. A 
combined list of available and retired finishing touches displays. 

To un-retire a finishing touch: 

• In the Finishing Touch Administrator, right-click the desired finishing touch and select Un-

Retire Finishing Touch . 



Design Workflows 

Feith Workflow iQ Manager 9.2 User Guide     105 

 Delete Finishing Touch 

Tip: If you do not want to delete the finishing touch yet, consider retiring the finishing touch instead. 

To delete a finishing touch: 

1. Select Tools>Finishing Touch Administrator. The Finishing Touch Administrator opens. 
 
You can also delete a finishing touch from inside a task in the Task Administrator on the 

Finishing Touches tab by clicking Assign Finishing Touch . 

2. Click Assign Finishing Touch . The Assign Finishing Touches dialog opens. 

3. Select the desired finishing touch and click Delete Finishing Touch . A prompt opens to 
confirm the delete and removal of the finishing touch from all tasks where it is assigned. 

4. Click Yes to continue with the delete. The finishing touch is deleted. 
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Rule Tokens 

Insert Rule Token 

Optionally insert a Rule Token  into a notification, work-o-gram, or hub task program to retrieve values 
from anywhere in the database using custom SQL (Structured Query Language). For example, you may 
write SQL to retrieve a custom list of email addresses, stored in a location other than the file cabinet, to use 
as email recipients. 

See Create and Maintain Rule Tokens for more information on creating and maintaining rule tokens. 

  

To insert a rule token: 

1. Open the desired notification, work-o-gram, or hub task program. See Create and Maintain 
Notifications, Configure Work-o-gram, and Configure Program for more information. 

2. Place your cursor in the field where you want to insert the rule token. For example, a notification's 
To. 

3. In the Tokens list select the desired rule token. 
 

You may create or edit a rule token by clicking Edit Rule Tokens . See Create and Maintain 
Rule Tokens for more information on creating and maintaining rule tokens. 

4. Click Insert. The rule token is inserted in the cursor location. 
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Create and Maintain Rule Tokens 

Optionally insert a Rule Token  into a notification, work-o-gram, or hub task program to retrieve values 
from anywhere in the database using custom SQL (Structured Query Language). 

Note: A rule token returns a single value or a comma-separated list of values from one column. 

See Insert Rule Token for more information on using rule tokens in a notification, work-o-gram, or hub task 
program. 

See the following sections for instructions: 

• Create Rule Token 

• Modify Rule Token 

• Clone Rule Token 

• Delete Rule Token 

  

Create Rule Token 

To create a rule token: 

1. Select Tools>Rule Token Administrator. The Rule Token Administrator opens. 
 
You can also access the Rule Token Administrator from inside a notification, work-o-gram, or hub 

task program by clicking Edit Rule Tokens . 

2. Click Create Rule Token . The Create Rule Token dialog opens. 
 

Alternatively, you may Clone   an existing rule token. See Clone Rule Token for more 
information. 

3. Enter the rule token Name. 

4. Select the Return Type of the data coming back from the SQL query (e.g. String for email 
addresses). 

5. Enter the SQL to retrieve the desired values from the database. You may use the Token list to 
Insert tokens into the SQL field. See Appendix A: Tokens for more information. 
 

 
 
Note: The table referenced in the above SQL is not in the standard Feith FDD Schema but is used 
only for the purpose of this example. 

6. Click OK. The rule token is created. See Insert Rule Token for information on using rule tokens in a 
notification, work-o-gram, or hub task program. 
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Note: If your rule token is retrieving date or datetime values, select a Return Type of String and in your 
SQL format the date or datetime value using the appropriate database function. 

To change a date or datetime into a string in the desired format: 

• On Oracle use the "to_char" function. For example, format a datetime as a string in 24-hour time: 

select to_char(Submitted, 'MM/DD/YYYY HH24:MM:SS') from fdd.Requests 

• On MS SQL Server use the "convert" function. For example, format a datetime as a string with 
just the date: 

select convert(varchar, Submitted, 101) from fdd.Requests 

See Oracle and MS SQL Server documentation for more information on using these functions to format a 
date or datetime as desired. 

  

Modify Rule Token 

To modify a rule token: 

1. Select Tools>Rule Token Administrator. The Rule Token Administrator opens. 
 
You can also access the Rule Token Administrator from inside a notification, work-o-gram, or hub 

task program by clicking Edit Rule Tokens . 

2. Select the desired rule token and click Modify Rule Token . The Modify Rule Token dialog 
opens. 

3. Modify the rule token as needed. 

4. Click OK. The rule token is modified. 

  

Clone Rule Token 

To clone a rule token: 

1. Select Tools>Rule Token Administrator. The Rule Token Administrator opens. 
 
You can also access the Rule Token Administrator from inside a notification, work-o-gram, or hub 

task program by clicking Edit Rule Tokens . 

2. Select the desired rule token and click Clone Rule Token . The Clone Rule Token dialog 
opens. 

3. Modify the clone rule token as needed. 

4. Click OK. The rule token is created. 

  

Delete Rule Token 

1. Select Tools>Rule Token Administrator. The Rule Token Administrator opens. 
 
You can also access the Rule Token Administrator from inside a notification, work-o-gram, or hub 

task program by clicking Edit Rule Tokens . 

2. Select the desired rule token and click Delete Rule Token . A prompt opens to confirm the 
delete and invalidation of the token wherever it exists in a notification, work-o-gram, or hub task 
program. 

3. Click Yes to continue with the delete. The rule token is deleted. 
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Calendars 

A Calendar   defines business hours and holidays. Calendars are used with the following: 

• Deadline Tasks 

• Reminder and Repeating Reminder Notifications 

• Priority 

• Deadline Route 

The FDD system includes two calendars by default: 

• 24 Hours/Day, 7 Days/Week: Business hours are 12 AM to 12PM, Sunday to Sunday with no 
holidays. 

• Standard Business Calendar: Business hours are 9 AM to 5 PM, Monday to Friday with some 
holidays. 

See the following sections for instructions: 

• Create Calendar 

• Modify Calendar 

• Clone Calendar 

• Export Calendar 

• Import Calendar 

• Delete Calendar 

  

Create Calendar 

To create a calendar: 

1. Select Tools>Calendar Editor. The Calendar Editor opens. 

2. Click Create Calendar . The Create Calendar window opens. 
 

Alternatively, you may Clone   an existing calendar. See Clone Calendar for more information. 

3. Enter a calendar Name. 

4. Define the business days in the Work Week: 

a. For a given day, double-click the box that says All Day. The Business Hours dialog 
opens, displaying the business hours highlighted green. 

b. Select one or more hours and right-click and choose to Turn On Selected Hours  or 

Turn Off Selected Hours . To select multiple days use CTRL+click or SHIFT+click. 
Business hours are highlighted green. 
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c. Click OK. The business hours for that day are defined. 

d. Repeat this process as needed for each work day. Days with business hours are 
highlighted green. 
 

 

5. Optionally create Holidays: 

a. Click Create Holiday . The Create Holiday dialog opens. 
 
Alternatively, use the calendar control on the right side and double-click the date you want 
the holiday to start. 

b. Select or enter the date and time the holiday Starts. 

c. Select or enter the date and time the holiday Ends. 
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d. Click OK. The holiday is created. 
 
Note: If you create a holiday that is right next to another holiday, the two will be combined 
into a single holiday. 

e. Repeat this process as needed to create more holidays. 
 

 

6. Click OK. The calendar is created. 

  

Modify Calendar 

To modify a calendar: 

1. Select Tools>Calendar Editor. The Calendar Editor opens. 

2. Select the desired calendar and click Modify Calendar . The Modify Calendar dialog opens. 

3. Modify the calendar as needed. 

4. Click OK. The calendar is modified. 

  

Clone Calendar 

To clone a calendar: 

1. Select Tools>Calendar Editor. The Calendar Editor opens. 

2. Select the desired calendar and click Clone Calendar . The Clone Calendar dialog opens. 

3. Modify the clone calendar as needed. 

4. Click OK. The calendar is created. 
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Export Calendar 

To export a calendar: 

1. Select Tools>Calendar Editor. The Calendar Editor opens. 

2. Select the desired calendar and click Export Calendar. The Export Calendar dialog opens, 
prompting you to save the file. 

3. Browse to the desired location and click Save. The .xml export file containing the calendar 
definition is saved to the specified location. 

  

Import Calendar 

To import a calendar: 

1. Select Tools>Calendar Editor. The Calendar Editor opens. 

2. Click Import Calendar. The Open dialog opens, prompting you to select the export file.  

3. Browse to the export file and select it. You can select either a: 

• .xml calendar export file 

• .fwx workflow export file 

4. Click Open. 

5. If a calendar with the same name already exists, you are asked whether you want to replace the 
existing calendar. 
 
Click Yes to replace the existing calendar with the same name. Click No to create a new calendar 
with a different name. 

6. The calendar is imported. 

  

Delete Calendar 

To delete a calendar: 

1. Select Tools>Calendar Editor. The Calendar Editor opens. 

2. Select the desired calendar and click Delete Calendar . A prompt opens to confirm the delete. 

3. Click Yes to proceed with the delete. The calendar is deleted. 
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Add Routes 
A route is a path that moves work from one task to another, defining how and why a work item arrives at a 
particular task. A route is represented by a line in the workflow map. There are several route types as well 
as various display options. 

See the following sections for instructions: 

• Route Types 

• Draw and Adjust Routes 

• Route Display Options 

  

Route Types 

There are several route types: 

LINE TYPE 

 

Automatic Route 

Automatically routes work items to the next task. 

 

Single-Select Manual Route 

An end user in a user task marks a work item as done and manually selects one, and 
only one, path for a work item to go. 

For example, a user may choose to "approve" or "reject" a work item. 

 

Multi-Select Manual Route 

An end user in a user task marks a work item as done and manually selects one or 
more paths for a work item to go. 

For example, a user may choose to route a new hire form to "IT" and "Training" 
because the new hire needs a computer and training, but not "Security" because they 
are not given access to unlock the building. 

 

Optional Route 

An end user in a user task marks a work item as done and manually selects one or 
more, or none, of the optional paths for a work item to go. 

For example, a user may optionally choose to route a work item to their manager for 
further review. 

 

Conditional Route 

Routes a work item that meets the specified condition. 
 
For example, if an expense report approved by a manager is $1,000.00 or more it is 
sent to the boss before final approval, while another expense report less than 
$1,000.00 is approved without further review. 

 

Deadline Route 

Work items that have been in the task "too long" by reaching a specified deadline are 
routed away from the task. 

For example, tasks following a deadline route may be designed to makes sure these 
"late" work items get addressed. 
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Error Route 

Routes a work item that went into error. 
 
For example, if a work item goes into error because a finishing touch failed then the 
work item is sent along the error route to tasks designed to make sure the error gets 
addressed. 

 

Auto-Distribute Route 

Distributes work items evenly across multiple tasks. 

For example, work items may be evenly distributed to John Smith, Jane Doe, and Joe 
Schmoe. 

 

Information Route 

A purely illustrative route that represents a path in the process that occurs outside the 
workflow or the flow of work between summarizing information tasks. 

For example, a page may be scanned before the start of the workflow and an email 
may be sent after the end of the workflow. Also, the path between information tasks 
summarizing various sections of the workflow could be illustrated. 

  

Draw and Adjust Routes 

To draw a route on the workflow map: 

1. Select the desired route tool in the administrator toolbar. 

2. Click on the origin task and drag the cursor over the destination task and release the mouse 
button.  The route is drawn between the two tasks and the route arrow indicates the route direction. 
 
Tip:  After adding routes, you can quickly switch back to the Pointer tool using CTRL+1. 

To adjust a route: 

1. Use the Pointer tool to select the route.  The route handles appear. 

2. Click on an inner handle (not the start point or end point) and drag to the desired location. 

To change the type of an existing route: 

• Right click the route and under Route Type select the desired route type.  The route is changed to 
the selected type. 

To copy a route: 

1. Right click the route and choose to Copy to New Origin task or Copy to New Destination 
task.  The Choose New dialog opens. 

2. Select the one or more tasks.  To select multiple tasks use CTRL+click or SHIFT+click. 
 

 

3. Click OK.  The route is copied to the selected task(s). 
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To move a route: 

1. Use the Pointer tool to select the route.  The route handles appear. 

2. Click the start point or end point, depending on whether you want to change the route's origin or 
destination, and drag the cursor over the desired task and release the mouse button.  The route is 
moved. 

    Alternatively: 

1. Right click the route and choose to Move to New Origin task or Move to New Destination 
task.  The Choose New dialog opens. 

2. Select the one or more tasks.  To select multiple tasks use CTRL+click or SHIFT+click. 
 

 

3. Click OK.  The route is moved to the selected task(s). 

Tip: If your routes are criss-crossing, getting too long, or otherwise cluttering up your map, try tidying it up 
with wormholes. 

  

Route Display Options 

To change the route style: 

1. Right-click the route and under Route Style select one of the following: 

• Polyline:  A straight or angular line with a directional arrow in the middle. 
 

 

• Polyline with Destination Arrow:  A straight or angular line with a directional arrow in the 
middle and at the end. 
 

 

• Bezier Curve:  A curving line with a directional arrow at the end. 
 

 
 
Note:  A Bezier Curve style route does not visually "jump over" or "go under" intersecting 
routes. 

2. If you selected a Bezier Curve, the line may need to be adjusted to have a curve.  Adjust the route, 
clicking-and-dragging the handles, until there are three or more points and the line curves. 
 
Tip:  Change the default route style for all routes using View>Default Route Style. 
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To show or hide a route label: 

• Right-click the desired route and select Hide Text to hide the label or Show Text to show the label. 
 
To show or hide labels for multiple routes, use the Pointer tool to select multiple routes with 
CTRL+click and then right-click one of the selected routes and select Hide Text or Show Text. 
 
To show or hide all route labels in a workflow, first select Edit>Select All Routes then right-click a 
selected route and select Hide Text or Show Text. 
 
Tip:  The view setting View>Route Labels may be used to toggle the display of all route labels 
across all workflows. 

To change a route label's font, size, style, and color: 

1. Right-click the desired route and select Font.  The Font dialog opens. 
 
To change the label font for multiple routes, use the Pointer tool to select multiple routes with 
CTRL+click and then right-click one of the selected routes and select Font. 

2. Choose the desired font options and click OK.  The label font on the route(s) is changed. 
 
Tip:  Change the default font for all text in all workflows using View>Default Font. 

To view origin, destination, and other route information: 

• Right-click the desired route and select Route Information.  The Route Information dialog opens 
and displays the route's origin task, destination task, type, and description, which may be helpful to 
know if the route is quite long or arranged in such a way that this information is not immediately 
apparent visually in the workflow map. 

  



Design Workflows 

Feith Workflow iQ Manager 9.2 User Guide     117 

Automatic Route 

An Automatic Route  automatically routes work items to the next task. 

  

To add an automatic route: 

1. Select the Automatic route tool in the administrator toolbar. 

2. Click on the origin task and drag the cursor over the destination task and release the mouse button. 
The route is drawn between the two tasks and the route arrow indicates the route direction. 

3. Optionally set a route Description: 

a. Double-click the route. The Route Administrator opens. 

b. Enter a Description. 
 

 

c. Click OK. Your route description is saved. 
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Single-Select Manual Route 

A Single-Select Manual Route  moves work items when an end user in a user task marks a 
work item as done and manually selects one, and only one, path for a work item to go. For example, a user 
may choose to "approve" or "reject" a work item. 

Note: Single-select manual routes can only originate from user tasks. 

  

To add a single-select manual route: 

1. Select the Single-Select Manual route tool in the administrator toolbar. 

2. Click on the origin task and drag the cursor over the destination task and release the mouse button. 
The route is drawn between the two tasks and the route arrow indicates the route direction. 

3. Double-click the route. The Route Administrator opens. 

4. Enter the Single-Select Manual Route option name, which the end user in the user task will see 
when choosing a route in the client (e.g. FDD, WebFDD). 

5. Optionally turn on Select By Default which makes this the default or first choice when users are 
selecting routes in the client (e.g. FDD, WebFDD). Only one single-select route can be the default. 

6. Optionally enter a Description (the end user does not see the description). 
 

 

7. Click OK. The route is configured. The route line changes from dashed to solid, indicating the route 
is complete. 
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Multi-Select Manual Route 

A Multi-Select Manual Route  moves work items when an end user in a user task marks a 
work item as done and manually selects one or more paths for a work item to go. For example, a user may 
choose to route a new hire form to "IT" and "Training" because the new hire needs a computer and training, 
but not "Security" because they are not given access to unlock the building. 

Note: Multi-select manual routes can only originate from user tasks. 

  

To add a multi-select manual route: 

1. Select the Multi-Select Manual route tool in the administrator toolbar. 

2. Click on the origin task and drag the cursor over the destination task and release the mouse button. 
The route is drawn between the two tasks and the route arrow indicates the route direction. 

3. Double-click the route. The Route Administrator opens. 

4. Enter the Multi-Select Manual Route option name, which the end user in the user task will see 
when choosing a route in the client (FDD or WebFDD). 

5. Optionally turn on Select By Default which makes this the default or first choice when users are 
selecting routes in the client (e.g. FDD, WebFDD). One or more multi-select manual routes can be 
the default. 

6. Optionally enter a Description (the end user does not see the description). 
 

 

7. Click OK. The route is configured. The route line changes from dashed to solid, indicating the route 
is complete. 
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Optional Manual Route 

An Optional Route  moves work items when an end user in a user task marks a work item as 
done and manually selects one or more, or none, of the optional paths for a work item to go. For example, a 
user may optionally choose to route a work item to their manager for further review. 

Note: Optional routes can only originate from user tasks. 

  

To add an optional route: 

1. Select the Optional route tool in the administrator toolbar. 

2. Click on the origin task and drag the cursor over the destination task and release the mouse button. 
The route is drawn between the two tasks and the route arrow indicates the route direction. 

3. Double-click the route. The Route Administrator opens. 

4. Enter the Optional Route option name, which the end user in the user task will see when choosing 
a route in the client (FDD or WebFDD). 

5. Optionally turn on Select By Default which makes this the default or first choice when users are 
selecting routes in the client (e.g. FDD, WebFDD). One or more optional routes can be the default. 

6. Optionally enter a Description (the end user does not see the description). 
 

 

7. Click OK. The route is configured. The route line changes from dashed to solid, indicating the route 
is complete. 
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Conditional Route 

A Conditional Route  routes a work item that meets the specified condition. For example, if 
an expense report approved by a manager is $1,000.00 or more it is sent to the boss before final approval, 
while another expense report less than $1,000.00 is approved without further review. 

Note: Conditional routes based on list fields route work items as follows: 

• If just one of the values in the list field meets the criteria, the work item meets the condition and will 
pass through the conditional route. For example, if a conditional route is configured to only route 
work items where review_dates<4/14/2012, a work item with the values 4/2/2012, 5/1/2012 will 
meet the condition and pass through the conditional route. The only exception to this rule is a "not 
equal to" condition (see next note). 

• If a conditional route includes a "not equal to" condition (using the <> operator), and just one of the 
values in the List field does not meet the condition, the work item does not meet the condition and 
will not pass through that conditional route. For example, if a conditional route is configured to only 
route work items where doc_states<>frozen, a work item with the values approved, frozen does 
not meet the condition and will not pass through the conditional route. 

  

To add a conditional route: 

1. Select the Conditional route tool in the administrator toolbar. 

2. Click on the origin task and drag the cursor over the destination task and release the mouse button. 
The route is drawn between the two tasks and the route arrow indicates the route direction. 

3. Double-click the route. The Route Administrator opens. 

4. Set the Condition or, alternatively, select Other. When a work item does not meet the condition of 
any other conditional route, it takes the Other conditional route. 
 

When setting the Condition you may Create  a "constructed" condition or write the SQL  
yourself: 

• Create a "constructed" condition: 

a. Click Create . The Edit Condition dialog opens. 

b. Select the desired field or system value 

c. Select the desired operator. Operators include equal to =, not equal to <>, less 
than <, less than or equal to <=, greater than >, greater than or equal to >=, IS 
(NULL or NOT NULL), IN (SQL), NOT IN (SQL). 

d. Select whether you want to compare a Value, Field, Function, or SQL. 

e. If you selected to compare a Value or SQL, enter the value or SQL. If the field 
has a lookup table, you can select a value from the lookup values. If you selected 
to compare a Field or Function, select the field or function. 

f. Choose whether to check the value in a Case Insensitive or Case Sensitive 
manner. 
 
Tips: 

o Click Test to see if your condition works. 

o Click Show SQL to switch to the SQL view. Note that if you make 
changes in the SQL view, you cannot go back to the "constructed" 
condition unless you revert the SQL. 
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g. Click OK. The condition is added. 

h. Optionally add more conditions by clicking And  or Or . You can add more 

criteria to an and or or statement by selecting and or or and clicking Add . 
 
You can change an existing and to and or, or vice versa, by double-clicking the 
and or or and changing it to the desired operator in the And or Or dialog. 
 

Modify  or Delete conditions as needed. 

• Enter a SQL condition: 

a. Click SQL . The Edit Condition dialog opens. 

b. Enter a SQL condition. 
 

 
 
Note: The table referenced in the above SQL is not in the standard Feith FDD 
Schema but is used only for the purpose of this example. 

c. Click OK. The condition is added. 

5. Optionally enter a Description. 
 

 

6. Click OK. The route is configured. The route line changes from dashed to solid, indicating the route 
is complete. 

  

Note: To use a table or view other than the base file cabinet in a conditional route's SQL, write your SQL 
as part of the "implied" conditional route query: 
 
select count(*) from [file cabinet workflow is based on] where [unique ID] = [ID of work item] and 
[your condition from Workflow iQ Manager] 
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Deadline Route 

A Deadline Route  moves work items that have been in the task "too long" by reaching a 
specified deadline. For example, tasks following a deadline route may be designed to makes sure these 
"late" work items get addressed. 

The deadline assigned by a Deadline Route is also known as a "Task Deadline", since the deadline applies 
to the task from which the route originates. 

If you want to set a deadline for the entire workflow, see Deadline Task for more information. 

Note: Deadline routes cannot originate from deadline tasks. 

  

To add a deadline route: 

1. Select the Deadline route tool in the administrator toolbar. 

2. Click on the origin task and drag the cursor over the destination task and release the mouse button. 
The route is drawn between the two tasks and the route arrow indicates the route direction. 

3. Double-click the route. The Route Administrator opens. 

4. Select the Calendar on which to base the deadline. 

5. Enter the deadline time in Months, Days, Hours, and/or Minutes. 

6. In the After field, select the system or file cabinet field date and/or time you want to reference to 
start counting down to the deadline. 

7. Optionally enter a Description. 
 

 

8. Click OK. The route is configured. The route line changes from dashed to solid, indicating the route 
is complete. 

  

Note: Using the interval of Months, Days, Hours, and/or Minutes and the After reference date, Rex 
calculates the future deadline date and time in the following sequence: 

1. Rex counts forward the given number of Months, taking into account changes in the year and the 
day of the month (based on the available days in the determined month). The time of day does 
not change and stays the same time as the After reference date. 

2. Rex counts forward the given number of Days, taking into account the Work Week business days 
of the selected Calendar. The time of day does not change and stays the same time as the After 
reference date. 

3. Rex counts forward the given number of Hours, taking into account the Business Hours of the 
Work Week in the selected Calendar. 

4. Rex counts forward the given number of Minutes, taking into account the Business Hours of the 
Work Week in the selected Calendar. 
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Error Route 

An Error Route  routes a work item that went into error. For example, if a work item goes into 
error because a finishing touch failed then the work item is sent along the error route to tasks designed to 
make sure the error gets addressed. 

  

To add an error route: 

1. Select the Error route tool in the administrator toolbar. 

2. Click on the origin task and drag the cursor over the destination task and release the mouse button. 
The route is drawn between the two tasks and the route arrow indicates the route direction. 

3. Optionally set a route Description: 

a. Double-click the route. The Route Administrator opens. 

b. Enter a Description. 
 

 

c. Click OK. Your route description is saved. 
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Auto-Distribute Route 

An Auto-Distribute Route  distributes work items evenly across multiple tasks. For example, 
work items may be evenly distributed to John Smith, Jane Doe, and Joe Schmoe. 

  

To add an auto-distribute route: 

1. Select the Auto-Distribute route tool in the administrator toolbar. 

2. Click on the origin task and drag the cursor over the destination task and release the mouse button. 
The route is drawn between the two tasks and the route arrow indicates the route direction. 

3. Optionally set a route Description: 

a. Double-click the route. The Route Administrator opens. 

b. Enter a Description. 
 

 

c. Click OK. Your route description is saved. 
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Information Route 

An Information Route  is a purely illustrative route that represents a path in the process that 
occurs outside the workflow or the flow of work between summarizing information tasks. For example, a 
page may be scanned before the start of the workflow and an email may be sent after the end of the 
workflow. Also, the path between information tasks summarizing various sections of the workflow could be 
illustrated. 

  

To add an information route: 

1. Select the Information route tool in the administrator toolbar. 

2. Click on the origin task and drag the cursor over the destination task and release the mouse button. 
The route is drawn between the two tasks and the route arrow indicates the route direction. 

3. Optionally set a route Description: 

a. Double-click the route. The Route Administrator opens. 

b. Enter a Description. 
 

 

c. Click OK. Your route description is saved. 
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Add Graphical Elements 

Text 

Use Text   for supplemental labeling or as a visual aid in the workflow map. 

 

  

To add text: 

1. Select the Text tool in the administrator toolbar. 

2. Click on the workflow map. The text element is added. 

3. Type the desired text. Enter multiple lines of text using CTRL+ENTER. While editing, right-click in 
the text element to Select All or Paste text from the clipboard. 
 
Use the BACKSPACE key to delete text. You may also highlight text and hit BACKSPACE or 
DELETE. 
 
Hit ESC or TAB to exit edit mode. 

4. Optionally move the text using click-and-drag or the arrow keys. 

  

To change the text font, size, style, and color: 

1. Right-click the text and select Font. The Font dialog opens. 
 
To change the font for multiple text elements, use the Pointer tool to select multiple text elements 
by clicking-and-dragging a selection box around the desired text elements or using CTRL+click 
and then right-clicking one of the selected text elements and selecting Font. 

2. Choose the desired font options and click OK. The text font is changed. 

Tip: Change the default font for all text in all workflows using View>Default Font. 
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Label 

Use a Label   for supplemental labeling or as a visual aid in the workflow map. 

 

  

To add a label: 

1. Select the Label tool in the administrator toolbar. 

2. Click on the workflow map to add the label. The label is added. 

3. Optionally double-click the label to add text. Enter multiple lines of text using CTRL+ENTER. While 
editing, right-click in the label to Select All or Paste text from the clipboard. 
 
Use the BACKSPACE key to delete text. You may also highlight text and hit BACKSPACE or 
DELETE. 
 
Hit ESC or TAB to exit edit mode. 

4. Optionally resize the label by selecting it and clicking-and-dragging its handles. 

5. Optionally move the label using click-and-drag or the arrow keys. 

  

To change the label fill color: 

1. Right-click the label and select Fill Color. The Color dialog opens. 
 
To change the color for multiple labels, use the Pointer tool to select multiple labels by clicking-
and-dragging a selection box around the desired labels or using CTRL+click and then right-clicking 
one of the selected labels and selecting Fill Color. 

2. Choose the desired color and click OK. The label fill color is changed. 

  

To change the label text font, size, style, and color: 

1. Right-click the label and select Font. The Font dialog opens. 
 
To change the font for multiple labels, use the Pointer tool to select multiple labels by clicking-and-
dragging a selection box around the desired labels or using CTRL+click and then right-clicking one 
of the selected labels and selecting Font. 

2. Choose the desired font options and click OK. The label font is changed. 

Tip: Change the default font for all text in all workflows using View>Default Font. 
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Picture 

Use a Picture for supplemental labeling or as a visual aid in the workflow map. 

 

  

To add a picture: 

1. Select the Picture tool in the administrator toolbar. 

2. Click on the workflow map to add the picture. The picture is added with a placeholder image. 

3. Double-click the picture. The Open dialog opens. 

4. Select the desired image file and click Open. The image file is put into the picture. 
 
Note: It is recommended to use small images. Workflow iQ Manager will shrink any large images, 
though you may resize them afterward if desired. 

5. Optionally resize the picture by selecting it and clicking-and-dragging its handles. 

6. Optionally move the picture using click-and-drag or the arrow keys. 
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Box 

Use a Box to visually group tasks in the workflow map. 

 

  

To add a box: 

1. Select the Box tool in the administrator toolbar. 

2. Click on the workflow map and drag to draw a box. The box is added. 

3. Optionally move the box using click-and-drag or the arrow keys. 

  

To change the box fill color: 

1. Right-click the box and select Fill Color. The Color dialog opens. 

2. Choose the desired color and click OK. The box fill color is changed. 

To change the box back to transparent, right-click the box and select Transparent. 

  

To change the box outline's width: 

• Right-click the box and under Line Width select the desired width. The box outline's width 
changes. 

  

To change the box outline's style: 

• Right-click the box and under Line Style select the desired style as Solid, Dashed, or Dotted. The 
box outline's style changes. 
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Wormhole 

Use a wormhole  to tidy up criss-crossing or long routes that are cluttering your map. 

For example, here is the beginning of a workflow and the first half of some routes going into a wormhole. 
These routes need to bypass a bunch of steps in the workflow. 

 

Here, near the end of the workflow, the routes re-emerge to finish processing documents that bypassed 
most of the workflow. 
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To add a wormhole: 

1. Select the Wormhole tool in the administrator toolbar. 

2. Click on the workflow map to add the wormhole. The wormhole is added. 

3. Draw the first half of the route from a task to the wormhole. The route is dashed (no matter what 
type it is) and the wormhole is pink to indicate that the route is not yet complete. 

4. Scroll over to another wormhole. You may choose any other wormhole, but you can only choose 
one other wormhole where you will complete the route. 

5. Draw the second half of the route from the wormhole to a task. The route is completed and can be 
configured as usual. 

  

To split an existing route through a wormhole: 

• Right-click the route and select Split. The route it split into two halves with wormholes on both 
ends. Move the wormholes as desired. 

  

To find the other end of a route that goes through a wormhole: 

• Right-click the route and select Find Other End. You are scrolled over to the other half of the 
route, which is selected for you. 

  

To remove a route from a wormhole: 

• Right-click the route and select Remove from Wormhole. The route is removed from the 
wormhole and goes from task to task as usual. 
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Workflow and Version Status 
The workflow status and workflow version status indicate where the workflow and its versions are or have 
been in the development and maintenance processes. 

  

Workflow Status 

The status of a workflow is one of the following: 

• In Development: The workflow is still being designed and has not yet been published and 
therefore is not yet in production. 

• Live: The workflow has been published and is in production. See Publish Workflow for more 
information. 

• Deleted: The workflow publication has been deleted and is no longer in production. See Delete 
Workflow for more information. 

  

Version Status 

The status of a workflow version is one of the following: 

• Current: The current published version of the workflow that is in production. 

• Retired: A previously published version of the workflow that used to be in production. 

• Non-Published: A checked in version that is not in production. A non-published version may be 
created by a user checking in a version (see Check In Version for more information) or a user's 
check out being overridden (see Override Check Out for more information). 

• Information: A version with no associated map that is sometimes created under certain 
circumstances (e.g. overriding the check out on a brand new workflow with no changes at all). 

See Version History for more information on accessing workflow versions. 
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Workflow Permissions 
In order to create, open, check out, modify, publish, import, delete, or purge workflows, you must have the 
necessary permissions. 

Many of these permissions, such as task permissions and database user type, are set in Feith Control 
Panel. See Feith Control Panel User Guide for more information. 

See the following for more information on what permissions are needed to: 

• Open Workflow 

• Create New Workflow and Check Out Workflow 

• Publish Workflow and Import Workflow 

• Delete Workflow 

• Purge Workflow 

  

Open Workflow 

• To Open any workflow in Workflow iQ Manager at all, you must have the View Workflow task 
permission. Task permissions are set in Feith Control Panel. 

• To Open a specific workflow, at least one of the following must apply to you: 

o You are a member of that workflow's Administration Group. See Workflow Properties for 
more information. 

o You are included in that Workflow's Permissions list. 
 
To assign groups and users in the workflow permissions list: 

a. Open a Workflow . See Open Workflow for more information. 

b. Click Workflow Permissions in the standard toolbar. The Workflow 
Permissions dialog opens, displaying the Administration Group (members of 
which can open the workflow), Super Administrators (who can open all 
workflows), and Assigned users (if any). 

c. Click Show All Selectable Groups and Users . All workflow users and 
groups with members that are workflow users are displayed in the list. 

d. Check the desired groups and users. 
 
Tip: In the group/user list hit the key of the first letter of the group/user name to 
jump to that part of the list. Hit the letter key multiple times to cycle through all 
groups/users that start with that letter. Also, use the up and down arrow keys to 
navigate in the group/user list. 
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e. Click OK. Your workflow permissions assignment is saved. 

o You are a Super Administrator user. Super administrator users can open all workflows. 
Super administrators are set in Feith Control panel. 

  

Create New Workflow and Check Out Workflow 

In order to Create a New Workflow or Check Out a Workflow for modifying you must have the Workflow 
Administration task permission. Task permissions are set in Feith Control Panel. 

  

Publish Workflow and Import Workflow 

In order to publish or import a workflow, you must be a Feith Admin user (on Oracle) or a Database Admin 
user (on MS SQL Server). Database user type is set in Feith Control Panel. 

If you are instead a Feith Connect user, although you cannot publish you may instead Check In a Version. 
See Check In Version for more information. 

  

Delete Workflow 

In order to Delete a Workflow publication, you must: 

• Have the Workflow Administration task permission. Task permissions are set in Feith Control 
Panel. 

• Be a Feith Admin user (on Oracle) or a Database Admin user (on MS SQL Server). Database 
user type is set in Feith Control Panel. 
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Purge Workflow 

In order to Purge a Workflow, you must: 

• Have the Modify/Delete from Version History and Workflow Administration task permissions. 
Task permissions are set in Feith Control Panel. 

• Be a Feith Admin user (on Oracle) or a Database Admin user (on MS SQL Server). Database 
user type is set in Feith Control Panel. 
 
Note: If the workflow publication has already been deleted (see Delete Workflow for more 
information), then a Feith Connect user may purge the workflow. 
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Workflow Properties 

The Workflow Properties  are the basic settings of the workflow and configured when the workflow is 
first created. See Create a New Workflow for more information. 

The workflow properties include: 

• Workflow Name. The name may be up to 32 characters long. 

• Workflow Description. The description may be up to 128 characters long. 

• Workflow's Base File Cabinet which contains the FDD documents you want to process through the 
workflow. 

• Workflow's Administration Group whose members may open the workflow in Workflow iQ 
Manager and see the workflow's admin file cabinet in the clients, as well as receive an email from 
Rex when an error occurs in the workflow (see Errors for more information). 
 
Tip: You may grant users not in the administration group access to the workflow in Workflow iQ 
Manager using Workflow Permissions. See Workflow Permissions for more information. 

File cabinets, groups, and users are created in Feith Control Panel. See Feith Control Panel User Guide 
for more information. 

  

To view a workflow's properties: 

1. Open a Workflow. See Open Workflow for more information. 

2. Click Workflow Properties in the standard toolbar. The workflow properties open, displaying the 
workflow's Name, Description, Base File Cabinet, and Administration Group. 
 

 

  

To modify a workflow's properties: 

1. Open a Workflow. See Open Workflow for more information. 

2. Check Out the Workflow. See Modify Workflow for more information. 

3. Click Workflow Properties  in the standard toolbar. The workflow properties open. 

4. Modify the workflow's Name, Description, and Administration Group as needed. 
 
Note: The workflow's Base File Cabinet cannot be modified. You can export and import the 
workflow design if you want to re-use it on another base file cabinet. See Export and Import for 
more information. 

5. Click OK. The workflow properties are saved. 

6. Publish the Workflow for your changes to take effect. See Publish Workflow for more information. 
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Workflow Bookmarks 
Bookmark your favorite workflows or bookmark a group of workflows that go together, then select the 
bookmark to open all its workflows at once. Bookmarks are helpful when you have several workflows to 
manage. 

See the following sections for instructions: 

• Create Bookmark 

• Open Bookmark 

• Reorder Bookmarks 

• Rename Bookmark 

• Delete Bookmark 

  

Create Bookmark 

To create a bookmark: 

1. Open the workflows that you want to be in the bookmark. See Open Workflow for more information. 

2. Select File>Workflow Bookmarks>Create Bookmark. The Create Bookmark dialog opens. 

3. Enter the Bookmark Name. 
 

 

4. Click OK. The bookmark is created and contains all the workflows you had open. 

  

Open Bookmark 

To open a bookmark: 

• Select File>Workflow Bookmarks then select your bookmark in the list. All workflows in the 
bookmark are opened. 
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Reorder Bookmarks 

You can reorder bookmarks to change the order in which they display in the Workflow Bookmarks list. 

To reorder bookmarks: 

1. Select File>Workflow Bookmarks>Organize Bookmarks. The Organize Bookmarks dialog 
opens. 
 

 

2. Select a bookmark then click-and-drag it up or down to your desired location. 

3. Click OK. The bookmarks are reordered in the Workflow Bookmarks list under the File menu. 

  

Rename Bookmark 

To rename a bookmark: 

1. Select File>Workflow Bookmarks>Organize Bookmarks. The Organize Bookmarks dialog 
opens. 

2. Select a bookmark then click Rename. The Rename Bookmark dialog opens. 

3. Enter the new Bookmark Name. 
 

 

4. Click OK. The bookmark is renamed. 

5. Click OK to close the Organize Bookmarks dialog and save your changes. 

  

Delete Bookmark 

To delete a bookmark: 

1. Select File>Workflow Bookmarks>Organize Bookmarks. The Organize Bookmarks dialog 
opens. 

2. Select a bookmark then click Delete. The bookmark is deleted. 

3. Click OK to close the Organize Bookmarks dialog and save your changes. 
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Open Workflow 

Open a Workflow  to view it for monitoring or check it out for modifying. See Monitor Workflows and 
Modify Workflow for more information. 

See Version History for information on how to open old retired or non-published workflow versions. See 
Save and Restore Backup Files for information on restoring a workflow from a backup .fwf file. 

Note: In order to open a workflow you must have the necessary permissions. See Workflow Permissions for 
more information. 

  

To open a workflow: 

1. Click Open Workflow in the standard toolbar. The Open Workflow dialog opens. 
 
View all workflows you can access in the My Workflows tab or view workflows you have checked 
out in the My Checked Out Workflows tab (see Modify Workflow for more information on 
Checked Out workflows). 
 

Note: A System workflow with a yellow icon   is a specialized workflow created by Feith and it is 
not recommended to make changes to a system workflow. 
 
Tip: Alternatively, select a workflow bookmark you created under File>Workflow Bookmarks. All 
the workflows in that bookmark will be opened. See Workflow Bookmarks for more information. 

2. Select one or more workflows to open. Select multiple workflows using SHIFT+click or 
CTRL+click. 
 
See Workflow and Version Status for more information on the Status of a workflow. See Modify 
Workflow for more information on Checked Out workflows. 
 

 

3. The workflow(s) is opened and the workflow tab(s) displays on the top of the screen. See The 
Workflow Tabs for more information on using and arranging the workflow tabs. 
 
Workflows display as follows: 

• A workflow in "read-only" mode may be monitored. See Monitor Workflows for more 
information. A workflow is read-only when it has not been checked out. All operations for 
modifying the workflow are disabled and only the navigational tools are available in the 
administrator toolbar. 

• A workflow that you have checked out may be modified. A checked out workflow is 

indicated by a checkmark icon  in the workflow tab, the map grid displaying, and the full 
tool set available in the administrator toolbar. See Modify Workflow for more information. 
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Modify Workflow 

Check Out a Workflow  to modify its design, adapting it to the changing requirements of your business 
process. 

Note: In order to modify a workflow you must have the necessary permissions. See Workflow Permissions 
for more information. 

  

1. Open a Workflow. See Open Workflow for more information. 
 
Note: Before the workflow is checked out for modifying, it is in "read-only" mode with all operations 
for modifying the workflow disabled and only the navigational tools available in the administrator 
toolbar. 
 

 

2. Click Check Out Workflow on the admin button in the administrator toolbar. The workflow is 

checked out for editing, indicated by a checkmark icon  in the workflow tab, the map grid 
displaying, and the full tool set available in the administrator toolbar. The workflow is locked by you 
and cannot be checked out by other users. 
 
Notes: 

• If you are prompted that another user has the workflow checked out and locked already, 
you cannot modify the workflow. If necessary, you can override the other user's check out 
(see Override Check Out for more information). 
  

• If you are prompted that a newer version of the workflow is available, you may opt to make 
your modifications to the newer version. 

• If you are prompted that the workflow is a system workflow - a specialized workflow 
created by Feith - it is not recommended to make changes to such a workflow. 
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3. Modify the workflow design as needed. See Add Tasks, Add Routes, and Add Graphical Elements 
for more information. 
 

As you make changes, click Save Draft   to save a personal draft of your workflow. If you want 
another user to see or work on the workflow in development, you can select File>Check In 
Version to make a non-published version of the workflow available for them to access. See Save 
Workflow and Check In Version for more information. 

4. When you are finished modifying the workflow and ready to put the changes into production, 
Publish the Workflow. See Publish Workflow for more information. 
 
Note: If when modifying the workflow you deleted any tasks containing work items, during the 
publication process you will be prompted with the Move Work dialog to move the work items to 
another task. Optionally check Use for All Deleted Tasks to move work from all deleted tasks to 
the same task. 
 

 

It is strongly recommended that you do not publish modifications to an in-production workflow 
while users are working in the FDD system. 
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Save Draft 

Save a Personal Draft  of the workflow with your changes, even with incomplete tasks and routes. 

Note: A draft is a personal workflow map with your changes that only you can see, it is not added to the 
workflow's version history, and it is not in production in the FDD system. 

If you want to save the workflow map with your changes as a non-published version in the workflow 
version history or let another user to see or work on the workflow version with your changes, Check in a 
Version. See Check In Version for more information. 

If you want to put the workflow with your changes into production, Publish the workflow. See Publish 
Workflow for more information. 

  

To save a personal draft of the workflow with your changes 

• Click Save Draft   on the standard toolbar. The workflow draft is saved and remains checked out 
and locked by you. 
 
Tip: Use the keyboard shortcut CTRL+S to save a draft. 
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Check In Version 

Check in a Non-Published Version  of the workflow with your changes, even with incomplete tasks and 
routes, to the workflow's version history. See Version History for more information. 

Note: A checked in version is added to the workflow's version history as a non-published version, is 
available to other users to see or work on the workflow version with your changes, and it is not in 
production in the FDD system. 

If you want to save a personal draft with your changes that only you can see and is not in the workflow's 
version history, Save a Draft. See Save Draft for more information. 

If you want to put the workflow with your changes into production, Publish the workflow. See Publish 
Workflow for more information. 

  

To check in a non-published version of the workflow with your changes: 

1. Select File>Check in Version. The Check In Version dialog opens. 

2. Enter a comment on the workflow version and, if desired, check Keep checked out to keep the 
workflow checked out after the check in to the workflow's version history. 
 

 

3. Click OK. A non-published version of the workflow with your changes is added to the workflow's 
version history. See Version History for more information. 
 
If you chose to keep the workflow checked out, it remains checked out and locked by you. 
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Publish Workflow 

Publish a Workflow  to put it into production in the FDD system. Once a workflow is published, work 
items go into it and processing begins. 

See Modify Workflow for more information on modifying a workflow design. See Delete Workflow for more 
information on taking a workflow out of production. 

  

To publish a workflow: 

1. Once a workflow design is complete and ready to go into production, click Publish Workflow on 
the admin button in the administrator toolbar. The Publish Workflow dialog opens. 

2. Enter a comment on the workflow version and, if desired, check Keep checked out to keep the 
workflow checked out after the publish. 
 

 

3. Click OK. The workflow publishing process begins and shows a progress bar for each step taken 
until the publish is completed and the workflow is in production. 
 
If you chose to keep the workflow checked out, it remains checked out and locked by you. 
 
Note: If there are any incomplete tasks or routes, you will be prompted to complete their 
configuration when attempting to publish the workflow. Once all tasks and routes are complete, 
then publish the workflow. 
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Clone Workflow 
Clone an existing workflow design to create a new workflow. 

  

To clone a workflow: 

1. Open a Workflow. See Open Workflow for more information. 

2. Select File>Clone Workflow. The Create New Workflow dialog opens. 

3. Modify the workflow clone's Name, Description, and Administration Group as needed. 
 
Note: The workflow's Base File Cabinet cannot be modified. You can export and import the 
workflow design if you want to re-use it on another base file cabinet. See Export and Import for 
more information. 

4. Click OK. The clone workflow is created. 

5. Modify the workflow design as needed. See Add Tasks, Add Routes, and Add Graphical Elements 
for more information. 

6. When you are ready to put the new workflow into production, Publish the Workflow. See Publish 
Workflow for more information. 
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Version History 

Version History  contains all versions that have existed for a workflow. 

See the following sections for instructions: 

• View Version History 

• Open Version 

• Check Out Version for Republication 

• Edit Version Comment 

• Delete Version 

  

View Version History 

To view a workflow's version history: 

1. Click Open Workflow   in the standard toolbar. The Open Workflow dialog opens. 
 
View all workflows you can access in the My Workflows tab or view workflows you have checked 
out in the My Checked Out Workflows tab (see Modify Workflow for more information on 
Checked Out workflows). 

2. Select the desired workflow and click Show Version History . The Version History opens and 
displays all workflow versions. See Workflow and Version Status for more information on the 
Status of a version. 
 

 

  

Open Version 

To open a version: 

• In Version History, select the desired version and click Open Version . The workflow version is 
opened. 
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Check Out Version for Republication 

To open and check out a version: 

• In Version History, select the desired version and click Check Out for Republication . The 
workflow version is opened and checked out. 
  

  

Edit Version Comment 

To edit a version comment: 

1. In Version History, select the desired version and click Edit Comment . The Comment field for 
the selected version becomes editable. 

2. Modify the version comment as needed. To enter multiple lines use SHIFT+ENTER. 

3. Hit the ENTER key. The version comment is edited. 
 
Note: You must have the Modify/Delete from Version History task permission to modify a 
version comment. See Feith Control Panel User Guide for more information. 

  

Delete Version 

To delete a version: 

1. In Version History, select the desired version and click Delete Version . A prompt opens 
confirming the delete. 

2. Click Yes to proceed with the delete. The version is deleted from the FDD system. 
 
Notes: 

o You cannot delete the Current version of the workflow. See Workflow and Version 
Status for more information on version Status. 

o You must have the Modify/Delete from Version History task permission to delete from 
version history (with one exception, see next note). See Feith Control Panel User Guide 
for more information. 

o A user can always delete their own Non-Published   and Information versions 
Checked In By them, even without the Modify/Delete from Version History task 
permission. See Workflow and Version Status for more information on version Status. 
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Override Check Out 
Override another user's check out, breaking their lock on the workflow. 

Note: Only a super administrator can override a check out. See Feith Control Panel User Guide for more 
information on super administrators. 

It is strongly recommended that you contact the user who already checked out the workflow. 

You can find out who checked out the workflow by clicking Open Workflow in the standard toolbar and 
viewing the Checked Out By column for that workflow.  

  

To override a check out on a workflow: 

1. Click Open Workflow   in the standard toolbar. The Open Workflow dialog opens. 

2. Select the workflow for which you want to override the check out. In the Checked Out By column 
you can see who currently has the workflow checked out. 

3. Click Override Check Out . A prompt to confirm the override opens. 

4. Click Yes to proceed with the override. The check out is overridden, the map the other user had 
checked out is saved to the Version History as a Non-Published version (see Version History for 
more information), and a message confirming the successful override opens. 

5. Click OK to proceed. You may now check out the workflow. See Modify Workflow for more 
information. 
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Delete Workflow 

Delete a Workflow  publication to take the workflow out of production. Processing will cease and all work 
items will be removed from the workflow. The workflow design and version history are saved, and the 
deleted workflow can be re-published if desired. 

Note: In order to delete a workflow you must have the Workflow Administration task permission. See 
Workflow Permissions for more information. 

If you want to completely purge a workflow from the FDD system - design, version history, and all - then 
Purge the Workflow. See Purge Workflow for more information. 

  

Delete a Workflow 

To delete a workflow publication: 

1. Click Open Workflow   in the standard toolbar. The Open Workflow dialog opens. 
 
View all workflows you can access in the My Workflows tab or view workflows you have checked 
out in the My Checked Out Workflows tab (see Modify Workflow for more information on 
Checked Out workflows). 

2. Select the desired workflow and click Delete Workflow Publication . A prompt to confirm the 
delete opens. 

3. Click Yes to proceed with the delete. The workflow publication is deleted and no longer in 
production, and all work items are removed from the workflow. The workflow design and version 
history are saved, and the deleted workflow can be re-published if desired. 

  

Re-Publish a Workflow 

To re-publish a workflow: 

1. Open the Workflow. See Open Workflow for more information. 

2. Check Out the Workflow. The workflow is checked out. 

3. Make any changes if needed. See Modify Workflow for more information. 

4. Publish the Workflow. See Publish Workflow for more information. The workflow is re-published 
and in production, and work items go into it and processing begins. 
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Purge Workflow 

Purge a Workflow  to completely purge a workflow and its version history from the FDD system. 

Note: In order to purge a workflow you must have the Modify/Delete from Version History and Workflow 
Administration task permissions. See Workflow Permissions for more information. 

If you only want to take a workflow out of production and keep its design and version history you can Delete 
the Workflow publication instead. See Delete Workflow for more information. 

  

To purge a workflow completely from the FDD system: 

1. Click Open Workflow   in the standard toolbar. The Open Workflow dialog opens. 
 
View all workflows you can access in the My Workflows tab or view workflows you have checked 
out in the My Checked Out Workflows tab (see Modify Workflow for more information on 
Checked Out workflows). 

2. Select the desired workflow and click Purge Workflow from Archive . A prompt to confirm the 
purge opens. 

3. Click Yes to continue with the purge. The workflow and its version history are completely purged 
from the FDD system. 
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Save and Restore Backup Files 
Save a backup of a workflow map in a .fwf file on your local computer and restore the workflow in the 
database from that backup file. For example, you may want to save a backup of a workflow where you have 
made changes upon losing connectivity to the FDD database before exiting Workflow iQ Manager, and 
restore the workflow from the backup file once database connectivity is restored (see Disconnected for more 
information). 

  

To save a backup file: 

1. Open a Workflow. See Open Workflow for more information. 

2. Select Tools>Advanced Options>Save Backup File. The Save Workflow Backup dialog opens. 

3. Browse to the desired location and click Save. The .fwf file containing a backup of the workflow 
map is saved. 

  

To restore a backup file: 

1. Select Tools>Advanced Options>Restore Backup File. The Restore Backup File dialog opens. 

2. Browse to and select the desired backup .fwf file and click Open. The workflow map in the backup 
.fwf file is opened. 

3. Check Out and Save, Check In, or Publish the workflow as needed. See Modify Workflow, Save 
Draft, Check In Version, and Publish Workflow for more information. 
 
Note: If you are restoring from a backup file because you lost connectivity to the FDD database, 
when you check out the workflow map from the backup .fwf file you may be prompted that there is 
a newer draft of the workflow. If so, that draft from the database may be missing the changes you 
actually saved in the backup .fwf file and therefore you would not want to check out that draft from 
the database. You may want to check out the draft once to confirm what changes it may or may not 
have. 
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Monitor Workflows 
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Monitoring Overview 
Once a workflow is in production and work items go into it and processing begins, you can monitor the 
workflow in Workflow iQ Manager. 

To monitor one or more workflows: 

• Open one or more workflows (see Open Workflow for more information). The workflow(s) opens. 
 

 

  

Monitor workflows using the following options: 

• View and act on work items in a task using Work Info , such as clearing errors, removing holds, 
ad hoc routing, and etc. See View Work Info for more information. 

• Locate work items in error or on hold across all workflows to which you have access using the 

Status Locator . See Status Locator for more information. 

• Find and Clear Errors  on work items where Rex encountered an error in the workflow process. 
See Errors for more information. 

• Remove a User's Hold  on a work item to make it available to other workers again. See 
Remove Hold for more information. 

• Monitor Rex's activity or prompt Rex to process work items immediately using the Rex Toolbar and 

Rex Monitor . See Monitor Rex for more information. 

• Check the Wait-For Status of work items sitting in a wait-for task. See Wait-For Status for more 
information. 

• Ad Hoc Route   a work item from one task to another on an as-needed basis. See Ad Hoc 
Route for more information. 

• Withdraw  a work item From a Task or From an Entire Workflow. See Withdraw for more 
information. 
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• View a Dashboard iQ dashboard, which may be configured to show workflow processing or other 
relevant information, inside Workflow iQ Manager next to your workflows. See The Dashboard iQ 
Pane for more information. 

• View the Workflow History to see the audit trail of every step a work item has taken in any 
workflow. See Workflow History for more information. 

• Locate  a work item in all the workflow tasks where it currently resides. See Locate for more 
information. 

• Find a Task  in the workflow using Edit>Find Task. See Add Tasks for more information. 

• Adjust workflow map display options, such as zooming in and out, changing the theme or 
background color, showing or hiding task and route labels, turning animation on or off, etc. See The 
Workflow Map for more information. 

• When monitoring multiple workflows, reorder the workflow tabs as desired or optionally Auto-Cycle 
the workflows. See The Workflow Tabs for more information. 

• Double-click a task or route to view its configuration, or right-click a route and select Route 

Information  to view a route's origin task and destination task, which may not be immediately 
apparent visually in the workflow map. 

• Set up worker vacations and their substitutes using the Vacation Planner . See Vacation 
Planner for more information. 

• If you are in the workflow's Administration Group (see Workflow Properties for more information), 
you have access to the workflow's admin file cabinet which you can use to search for and view 
documents, search by task, view status information, ad hoc route documents, and more. The admin 
file cabinet is accessed through a client application such as FDD Client or WebFDD. See FDD 
User Guide and WebFDD User Guide for more information. 
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View Work Info 

View and act on work items in a task using Work Info , such as clearing errors, removing holds, ad hoc 
routing, and etc. 

To open Work Info: 

• Double-click the work item count above the task. The Work Info dialog opens and displays several 
columns containing information on the work items, offers several actions to perform on the work 
items, and has a few display options. 
 
Alternatively, right-click the task and select Work Info. 
 

 

Tip: If you only want to view items in error, view Error Info instead. 

See the following sections for information and instructions: 

• Work Info Columns 

• Work Info Actions 

• Work Info Display Options 

  

Work Info Columns 

There are several columns containing information the work items in Work Info: 

• The work item's type, indicated by an icon, as a document , folder , or dynamic folder . 

• Item ID: The internal ID of the work item. 

• Status: The current workflow status of the work item. Possible statuses are: 

o Available: The work item is available to be worked. 

o Locked: The work item is locked by a user in the client (FDD or WebFDD). 

o On Hold: The item has been put on hold by a user in the client (FDD or WebFDD) and 
only they can access that work item. See Remove Hold for more information. 

o Done: The work item has been processed in the task and will move on to the next step in 
the workflow. 

o Ad Hoc Route: The work item will be ad hoc routed to another task. See Ad Hoc Route 
for more information. 

o Complete: The work item has arrived in an end task and has completed the workflow. 

o Error: Rex encountered an error while processing the work item. See Errors for more 
information. 

o Withdrawn: The work item will be withdrawn from the task or workflow. See Withdraw for 
more information. 

• Status Reason: The reason the work item has its current Status (e.g. a work item is in Error 
because no applicable route was found). 

• The work item's index values from the workflow's base file cabinet. 
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• Last Modified: The date and time the work item was last acted upon, when the current Status took 
effect. 

• Modified By: The user who last acted on the work item, causing the current Status. 

• Subflowed From: The "parent" workflow and task that the document was subflowed from. See 
Subflow Task for more information. 

Tip: If a value does not display in its entirety, click the Best Fit Displayed Data   button in the upper left 
of the grid. Alternatively, you can just mouse over the value and it will display in a tooltip in its entirety. 

  

Work Info Actions 

There are several actions available to perform on work items in Work Info: 

• Withdraw All: Withdraw all work items from the task. See Withdraw for more information. 
 
Tip: The Withdraw All option is helpful if you need to clean out a large number of work items that 
have piled up in an end task. You may want to consider having completed work items in the end 
task withdrawn automatically (see End Task for more information). 

• Ad Hoc Route: Route one or more work items from one task to another on an as-needed basis. 
See Ad Hoc Route for more information. 

• Clear Error: Clear an error on one or more work items, once the cause is addressed, so they 
can move on in the workflow. See Errors for more information. 

• Remove Hold: Remove a user's hold on one or more work items to make them available again. 
See Remove Hold for more information. 

• Withdraw: Withdraw one or more work items From a Task or From an Entire Workflow. See 
Withdraw for more information. 

• Leap: Perform a leap on the work item in FDD. 
 
Notes: 

o FDD must be installed on your computer. 

o Only SQL and URL leaps are supported. 

o  See FDD User Guide for more information on leaps and their types. 

• Locate: Locate one or more work items in all the workflow tasks where they currently reside. 
See Locate for more information. 

• View Item: View the work item in FDD or WebFDD In the Administrator File Cabinet or In the 
Base File Cabinet. 
 
Notes: 

o FDD must be installed on your computer and/or there must be a WebFDD server entry in 
your FDD system. The options provided here depend on which clients are available to 
you. 

o You must have permission to the selected file cabinet. 
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• Work: Open the work item in FDD or WebFDD to work it in the selected task. 
 
Notes: 

o FDD must be installed on your computer and/or there must be a WebFDD server entry in 
your FDD system. The options provided here depend on which clients are available to 
you. 

o This action is only supported for user tasks. 

o You must have permission to the user task. 

• Workflow History: View the Workflow History of where a work item has been across all workflows. 
See Workflow History for more information. 

• Copy Data: Copy the Work Info data for one or more work items to the clipboard (e.g. to paste into 
Microsoft Excel). 

• Copy Link: Copies the WebFDD link to the document to the clipboard, so you can paste it into an 
email or elsewhere. Select multiple documents to copy multiple links. 

• Mail Data: Email a document's metadata to another person, including a WebFDD link to the 
document, the internal document ID, and the file cabinet index values. 

  

Work Info Display Options 

There are a few display options in Work Info: 

• Refresh  the work item list. 

• Choose the Maximum Number of Rows to Retrieve . 

• When Work Info is retrieving a large number of work item rows, you can Cancel  and only the 
rows retrieved up until that point are displayed. 

• Click a column header (e.g. Status) to sort the rows by that column in ascending order. Click the 
column header again to sort the rows by that column in descending order. 
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Status Locator 

Use the Status Locator  to locate work items in error or on hold across all workflows to which you have 
access. A work item in Error had a problem where Rex encountered an error while processing the work 
item. A work item On Hold has been put on hold by a user in the client (FDD or WebFDD) and only they can 
access that work item. 

To open the Status Locator: 

• Select Tools>Status Locator. The Status Locator opens and displays several columns 
containing information on the work items, offers a few actions to perform on the work items, and 
has a few display options. 
 
You may select to Locate Status Errors or Holds. 
 
Tip: Double-click a row to open the workflow and go to the task. 
 

 

See the following sections for information and instructions: 

• Status Locator Columns 

• Status Locator Actions 

• Status Locator Display Options 

  

Status Locator Columns 

There are several columns containing information the work items in the Status Locator: 

• Item ID: The internal ID of the work item. 

• Workflow: The workflow containing the work item. 

• Task: The task containing the work item. 

• Subflowed From: If the work item is in a subflow, the "parent" subflow task the work item came 
from in the "parent" workflow. See Subflow Task for more information. 

• Status: The current workflow status of the work item. Depending on your Locate Status selection, 
you are viewing work items in Error or On Hold: 

o Error: Rex encountered an error while processing the work item. 

o On Hold: A work item has been put on hold by a user in the client (FDD or WebFDD) and 
only they can access that work item. 

• Status Reason: The reason the work item has its current Status (e.g. a work item is in Error 
because no applicable route was found). 

• Last Modified: The date and time the work item was last modified. 
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• Modified By: The user who last modified the work item. 

• Hold Reason: The reason the end user gave to put the work item on hold. 

• Hold Until: The date and time the end user selected to automatically remove the hold on the work 
item. 

  

Status Locator Actions 

There are a few actions available to perform on work items in the Status Locator: 

• Locate: Locate one or more work items in all the workflow tasks where they currently reside. 
See Locate for more information. 

• Clear Error: Clear an error on one or more work items, once the cause is addressed, so they 
can move on in the workflow. See Errors for more information. 

• Remove Hold: Remove a user's hold on one or more work items to make them available again. 
See Remove Hold for more information. 

• Withdraw From Task : Withdraw one or more work items from a task. See Withdraw for more 
information. 

  

Status Locator Display Options 

There are a few display options in the Status Locator: 

• Choose whether to Locate Status Errors or Holds. 

• Refresh  the work item list. 

• Click a column header (e.g. Workflow) to sort the rows by that column in ascending order. Click 
the column header again to sort the rows by that column in descending order. 
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Errors 
A work item goes into Error when Rex encountered a problem processing the item. For example, an error 
may occur when no applicable conditional routes are found for a work item that needs to be routed, or a 
finishing touch failed to execute, or a program on a hub task returned an error to Rex. 

Tip: If you are unsure why an error has occurred, view the Rex log to get more information on when and 
why Rex encountered the error. See Monitor Rex for more information. 

Errors are handled in the following ways: 

• A task containing a work item with a Status of Error has a red outline . Address the 
cause of the error then Clear the Error so the work item can move on in the workflow. See Clear 
Error for more information. 

• If the task has an outgoing Error Route, a work item that goes into Error takes the error route and 
arrives at the next task with a Status of Available and is ready to go through the workflow process 
designed to make sure the error gets addressed. See Error Route for more information. 

  

Find Error 

To find a work item in error: 

• Use the Status Locator to find Errors. 

• In the administrator toolbar on the left, view the Items in Error count in the current workflow 
information. 

• Notice a task with a red outline, which contains a work item with a Status of Error. 

• View a task that receives work items from an Error Route. 

• If you are in the workflow's administration group, you are notified by email that the error occurred. 
Details from the Rex log are in the email, including when the error occurred, the reason for the 
error, and the work item that went into error. 

  

Error Info 

To only view documents in error: 

• Right-click a task and select Error Info. The Error Info dialog opens. Error Info is like Work Info 
except it only lists items in error. 

  

Clear Error 

A task containing a work item with a Status of Error has a red outline. Address the cause of the error then 
Clear the Error so the work item can move on in the workflow. 

To clear an error: 

1. Locate the work item in Work Info in the specific task or in the Status Locator. See View Work 
Info and Status Locator for more information. 

2. Right-click the work item and select Clear Error. The error is cleared and Rex attempts to process 
the work item again. 
 
Note: Rex is automatically prompted to re-process the work item, though note that if Rex's 
processing is turned off the automatic prompt will have no effect. 
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Remove Hold 

Remove a User's Hold on a work item to make it available to other workers again. 

  

To remove a hold: 

1. Locate the work item in Work Info in the specific task or in the Status Locator. See View Work 
Info and Status Locator for more information. 

2. Right-click the work item and select Remove Hold. The hold is removed and the work item is 
available to all workers in the task again. 
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Monitor Rex 
Monitor Rex's activity or prompt Rex to process work items immediately using the Rex Toolbar and Rex 

Monitor . Feith Rules Engine (Rex) is the application that actually moves work items through workflows 
according to your business rules, routing work items, setting deadlines, queuing emails, etc. 

See the following sections for instructions and information: 

• Rex Connection and Status 

• Rex Actions 

• The Rex Monitor 

• The Rex Log 

See The Toolbars for general information on the Rex Toolbar. 

  

Rex Connection and Status 

Workflow iQ Manager connects to Rex to provide up-to-date information on the work items being processed, 
allow you to monitor Rex's activity, or prompt Rex to process work items immediately. 

To connect to Rex: 

• In the Rex toolbar select your Rex Connection. 

Tip: Mouse over the text Rex Connection to see how much time there is until the next time Rex is 
scheduled to process workflows. 

When Workflow iQ Manager is connected to Rex, it shows as connected in the Rex toolbar. If Workflow 

iQ Manger is not connected to Rex, it shows as disconnected in the Rex toolbar. You may manually 

disconnect or connect Rex by clicking the status indicator / . 

If the Rex Connection text in the Rex toolbar is blue then Rex is working the workflow. If the Rex 
Connection is red then Rex is not working the workflow. 

Rex may not be working the workflow because: 

• The workflow was just published and Rex does not know about the workflow yet in order to process 
it. Rex will find the workflow and begin processing on its own, or you can force Rex to take over the 

workflow by clicking the down arrow on the Rex action button in the Rex toolbar and 
selecting Take Over Workflow Processing. 

• The selected Rex is intentionally not assigned to work the workflow. This may occur if you have 
more than one Rex running and different Rexes work different workflows for purposes of load 
balancing. 

If at any time you need to refresh your connection to Rex: 

• Select Tools>Rules Engine>Refresh Connection. 

  

Rex Actions 

Rex processes work items as needed without requiring user interaction, but you may prompt Rex when 

needed such as for testing or troubleshooting. Use the Rex action button  in the Rex toolbar to 
process work items immediately or perform other actions by clicking the button's down arrow and selecting 
the desired action. 
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Available actions include: 

• Process Workflows: Prompt Rex to check for work items that need to be processed. 
 
Note: This action does not check polled conditions, wait-fors, rendezvous, or deadlines. 

• Check Polled Conditions: Prompt Rex to check whether there are more work items that need 
to be added to workflows according to the polled conditions configured in start tasks. See Set Start 
Condition for more information. 

• Check Wait-Fors: Prompt Rex to check whether work items in wait-for tasks meet the rule(s) 
specified in order to move on in the workflows. See Wait-For Task for more information. 
 
Note: If the document meets the conditions upon arrival at the wait-for task, the document will pass 
through immediately. If the document meets the conditions later on, after it arrived in the task, Rex 
will move the document the next time the wait-for tasks are checked. 

• Check For Rendezvous: Prompt Rex to check whether work items in rendezvous tasks have 
been reunited with all copies of themselves in the workflows. See Rendezvous Task for more 
information. 

• Check Deadlines: Prompt Rex to check whether there are work items that have passed 
deadlines in a deadline route or deadline task. See Deadline Route and Deadline Task for more 
information. 

• Take Over Workflow Processing: Prompt Rex to take over all workflows it is allowed to work. 

• Retrieve Rex Log: View the Rex log to see Rex's activity. 

• Retrieve Rex Status: View the Rex status report to see Rex's connection information, current 
status, and events that have occurred since Rex started. 

Tips: 

• If you do not want the Rex Monitor to launch every time you prompt Rex, turn off Show Monitor on 
Requests under Tools>Rules Engine. 

• Rex will perform the above checks on its own at configured intervals. You may change the intervals 
for Rex's checks in order to tune Rex according to the needs of your system. See Rex Manual for 
more information. 

  

The Rex Monitor 

The Rex Monitor  reports Rex's activity. It provides all the same actions available in the Rex toolbar (see 
Rex Actions for more information) plus a few more actions. 

To open the Rex Monitor: 

• Click Rex Monitor   in the Rex toolbar. The Rex Monitor opens. 
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Under the Action menu, in addition to the actions available in the Rex toolbar (see Rex Actions for more 
information), the Rex Monitor offers the following actions: 

• Update Resources: Prompt Rex to check whether there are new or expired resource allocations 
(i.e. substitutes for vacationing users). 

• Turn Processing On: Turn Rex on. Rex is active, checking for work items that need to be 
processed and processing those work items. 

• Turn Processing Off: Turn Rex off. Rex is inactive and does not do anything unless manually 
prompted. 

• Purge Cache: Clears Rex's cache of workflows, tasks, task options, and routes, in order to ensure 
from that point forward that Rex is retrieving the most up-to-date workflow and task information 
from the database. 

  

The Rex Log 

View the Rex log to see Rex's activity. 

To open the Rex log: 

• In the Rex toolbar click the down arrow on the Rex action button   and select Retrieve Rex 
Log. The Rex Log opens. 
 

 

Options in the Rex log include: 

• Refresh the log using File>Refresh. 

• Look for a word or phrase in the log text using File>Find and Find Next (F3). 

• Copy Rex log text to the clipboard by selecting the desired text then right-clicking and selecting 
Copy. To select all text right-click and choose Select All. 

• Save the entire Rex log to a file on your machine using File>Save As. 
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Wait-For Status 
The status of each work item in a wait-for task in regard to meeting the specified rule(s). See Wait-For Task 
for more information on wait-for rules. 

  

To view Wait-for Status: 

• Right-click the desired wait-for task and select Wait-For Status. The Wait-For Status dialog opens 
and displays each work item by ID, the number of Days Waited, the specified wait-for rules, and 
whether each rule has been met for the waiting work items. A work item that has satisfied all the 
rules will move on to the next step in the workflow. 
 
When you open Wait-For Status, the check on each rule for each document will begin to run and 

fill in the status. At any time you may click Cancel  to stop the check at that point. 
 

Mouse over the header of a rule to view the full rule. Refresh   the list as needed. 
 

 

To view the Work Info of a waiting work item from Wait-For Status: 

1. In the Wait-For Status dialog, select one or more waiting work items. Select multiple work items 
using CTRL+click or SHIFT+click. 

2. Right-click and select Work Info. The Work Info dialog opens and displays the selected waiting 
work items. You may check the work item information in Work Info, such as index values used in a 
wait-for rule. 
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Ad Hoc Route 

Ad Hoc Route   a work item from one task to another on an as-needed basis. 

  

To ad hoc route a work item: 

1. Double-click the work item count above a task. The Work Info dialog opens. 

2. Select one or more work items you want to ad hoc route. Select multiple work items using 
CTRL+click or SHIFT+click. 

3. Right-click and select Ad Hoc Route. The Ad Hoc Route dialog opens and lists all tasks in the 
workflow. 

4. Choose one or more tasks to which you want to ad hoc route the work item. Select multiple tasks 
using CTRL+click or SHIFT+click. 
 
Optionally Show Other Workflows to also select from all tasks in all workflows built on the same 
file cabinet. 
 

 

5. Click OK. The work item(s) is routed to the select task(s) by Rex. 
 
Note: Rex is automatically prompted to ad hoc route the work item, though note that if Rex's 
processing is turned off the automatic prompt will have no effect. 
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Withdraw 

Withdraw   a work item from a task or from an entire workflow. Withdrawing a work item from a workflow 
does not delete the document or folder from the FDD system; the work item is merely removed from the 
workflow. 

Notes: 

• In order to withdraw a work item from a workflow you must have the Withdraw from Workflow 
task permission. See Feith Control Panel User Guide for more information on granting task 
permissions. 

• Work items can only be withdrawn if they have a status of Available, Complete, Error, or 
Subflow. 

• Withdrawing multiple work items at once from the entire workflow is not supported. 

  

To withdraw a work item: 

1. Double-click the work item count above a task. The Work Info dialog opens. 

2. Select one or more work items you want to withdraw. Select multiple work items using CTRL+click 
or SHIFT+click. 

3. Right-click and select Withdraw. You are presented with the following options: 

• From Task: Withdraw the work item from the current task. 

• From Entire Workflow: Withdraw the work item from all tasks in the current workflow. 

4. Choose to withdraw From Task or From Entire Workflow. A prompt opens confirming the 
withdrawal. 

5. Click Yes to proceed with the withdrawal. The work item is withdrawn by Rex. 
 
Note: Rex is automatically prompted to withdraw the work item, though note that if Rex's 
processing is turned off the automatic prompt will have no effect. 

  

To withdraw all work items from a task: 

1. Double-click the work item count above a task. The Work Info dialog opens. 

2. Click the Withdraw All  button in the toolbar. A confirmation prompt opens to verify you want to 
withdraw all work items from the task. 

3. Click Yes to proceed. All work items are withdrawn from the task. 

Tip: The Withdraw All option is helpful if you need to clean out a large number of work items that have piled 
up in an end task. You may want to consider having completed work items in the end task withdrawn 
automatically (see End Task for more information). 
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Workflow History 
View the Workflow History to see the audit trail of every step a work item has taken in any workflow. 

  

To view the Workflow History of a work item: 

1. Double-click the work item count above a task. The Work Info dialog opens. 

2. Right-click the work item and select Workflow History. The Workflow History dialog opens and 
displays the audit trail of every step the work item has taken in any workflow. 
 
Click a column header (e.g. Process User) to sort the rows by that column in ascending order. 
Click the column header again to sort the rows by that column in descending order. 
 

 

  

There are several columns containing information on the work item in its Workflow History: 

• Process Start: The date and time the process began. 

• Process End: The date and time the process ended (if applicable). 

• Process: The type of process that occurred. 

• Process User: The user who caused the process. 

• Client: The application in which the process occurred. 

• Workflow: The workflow in which the process occurred. 

• Task: The task in which the process occurred (if applicable). 

• From Task: The task from which the work item came (if applicable). 

• Next Workflow: The workflow to which the work item was sent (if applicable). 

• Next Task: The task to which the work item was sent (if applicable). 
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Locate 

Locate   a work item in all the workflow tasks where it currently resides. 

  

To locate a work item: 

1. Double-click the work item count above a task. The Work Info dialog opens. 

2. Right-click the work item and select Locate. The Locations dialog opens and displays every 
workflow and task where the work item currently resides. 
 
Click a column header (e.g. Workflow) to sort the rows by that column in ascending order. Click 
the column header again to sort the rows by that column in descending order. 
 
Tip: Double-click a row to open the workflow and go to the task. 
 

 

  

There are several columns containing information on the work item in its Locations: 

• Item ID: The internal ID of the work item. 

• Workflow: The workflow containing the work item. 

• Task: The task containing the work item. 

• Subflowed From: If the work item is in a subflow, the "parent" subflow task the work item came 
from in the "parent" workflow. See Subflow Task for more information. 

• Status: The current workflow status of the work item. 

• Status Reason: The reason the work item has its current Status (e.g. a work item is in Error 
because no applicable route was found). 

• Last Modified: The date and time the work item was last modified. 

• Modified By: The user who last modified the work item. 

• Hold Reason: The reason the end user gave to put the work item on hold. 

• Hold Until: The date and time the end user selected to automatically remove the hold on the work 
item. 
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Vacation Planner 

Set up worker vacations and their substitutes using the Vacation Planner . During the regular worker's 
vacation, the substitute worker temporarily has permission to tasks where the vacationing user is assigned, 
including user tasks and start tasks (see Start Task and User Task for more information). The substitute 
worker gets all resource permissions on the tasks, including Search, View, Insert, Update, and Delete, as 
well as all the vacationing user's task permissions (see Feith Control Panel User Guide for more 
information on task permissions). When the vacation is over, the substitute worker is removed from the 
vacationing worker's tasks and no longer has the vacationing user's task permissions. 

See the following sections for instructions; 

• Create Vacation Assignment 

• Modify Vacation Assignment 

• Delete Vacation Assignment 

  

Create Vacation Assignment 

To create a vacation assignment: 

1. Select Tools>Vacation Planner. The Vacation Planner opens and displays all workflow users. 
 

 

2. Select the user(s) for which you want to create a vacation assignment. Either select one or more 

specific users and click Edit Selected  (select multiple users with CTRL+click or SHIFT+click) 

or click Edit All  to select all users. The Modify Vacation Days dialog opens. 

3. Click Create Vacation Assignment . The Create Vacation Assignment dialog opens. 

4. In the For User field, select the user going on vacation. 
 
Note: If you only selected one user, their name is already selected and cannot be changed. 

5. Enter the Starting and Ending dates of the vacation. 
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6. In the Assign User field, select the substitute user who will work in place of the vacationing user. 
 

 

7. Click OK. The vacation assignment is created and Rex will assign the substitute user when the 
vacation begins. 
 

 

  

Modify Vacation Assignment 

To modify a vacation assignment: 

1. Select Tools>Vacation Planner. The Vacation Planner opens and displays all workflow users. 

2. Select the user(s) for which you want to modify a vacation assignment. Either select one or more 

specific users and click Edit Selected  (select multiple users with CTRL+click or SHIFT+click) 

or click Edit All  to select all users. The Modify Vacation Days dialog opens. 

3. Select the vacation assignment you want to modify and click Modify Vacation Assignment . 
The Modify Vacation Assignment dialog opens. 

4. Modify the vacation assignment as needed. 

5. Click OK. The vacation assignment is modified. 

  

Delete Vacation Assignment 

To delete a vacation assignment: 

1. Select Tools>Vacation Planner. The Vacation Planner opens and displays all workflow users. 

2. Select the user(s) for which you want to delete a vacation assignment. Either select one or more 

specific users and click Edit Selected  (select multiple users with CTRL+click or SHIFT+click) 

or click Edit All  to select all users. The Modify Vacation Days dialog opens. 

3. Select the vacation assignment you want to delete and click Delete Vacation Assignment . 
The vacation assignment is deleted. 
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Export and Import Workflows 
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Export 
Export a workflow design to a .fwx file, then use the file to import the workflow design to another FDD 
database (e.g. from a test system to a production system). 

  

To export a workflow design: 

1. Open a Workflow. See Open Workflow for more information. 

2. Select File>Export. The Export Workflow dialog opens. 

3. Choose from the following export options for features used in the workflow design: 

• Lookup Values: Optionally include the values from lookup tables in the export file. When 
included, a lookup table created during the import process will have the values of the 
original lookup table; when excluded, the lookup table will be empty. 

• Calendar Data: Optionally include the work week (business days) and holidays from 
calendars in the export file. When included, a calendar created during the import process 
will have the data of the original calendar; when excluded, the calendar will have no data, 
in other words a 24/7 calendar with no holidays. 

• Group Permissions: Optionally include task permissions (e.g. scan/import, index, search 
file cabinets, etc) from groups in the export file. When included, a group created during the 
import process will have the task permissions of the original group; when excluded, the 
group will have no task permissions. 

• Subflows and Summarized workflows: Optionally include subflows and summarized 
workflows in the export file. When included, you can choose to import the "parent" 
workflow as well as its subflows and summarized workflows at the same time. 
 

 

4. Click OK. The Export Workflow dialog opens, prompting you to save the file. 

5. Browse to the desired location and click Save. The .fwx export file containing the workflow design 
is saved to the specified location. 
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Import 
Import a .fwx export file containing a workflow design to the desired FDD database (e.g. from a test system 
to a production system). 

The import process prompts you with questions on various kinds of objects used in the workflow design. See 
the following for more information on what these objects are and how they are used in the workflow design: 

• The base file cabinet 

• Subflows 

• Summarized workflows and summarized tasks 

• Lookup tables and columns 

• Tasks 

• Calendars 

• Groups and users on user tasks, start tasks, notifications, work-o-grams, and the workflow 
properties 

• Finishing touches and rule tokens 

• Notifications 

• Referenced file cabinets and fields for expected documents rules 

• Integration links 

  

Tips: 

• When mapping various objects, sometimes the Compare Objects   option is available and can 
provide you with more information on what you are mapping to and from (e.g. a file cabinet field's 
Description and Type). 

• For objects you can Replace (e.g. notifications, finishing touches, rule tokens, etc), right-click on 
the Replace checkbox and choose Check All or Uncheck All to change the selection for multiple 
objects quickly. 
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To import a workflow design: 

1. Select File>Import. The Import Workflow dialog opens, prompting you to select the .fwx export 
file. 

2. Browse to the .fwx export file and select it, then click Open. 

3. In the Import Workflow screen, choose whether you want to: 

• Create New Workflow: Create a new workflow. 

• Use Existing Workflow: Overwrite an existing workflow, such as if you were updating the 
workflow to a newer version from a development system. 
 
If the export file contains more than one workflow (e.g. a subflow or summarized workflow; 
see Export for more information), choose which Workflow To Import. If you import the 
"parent" workflow, its subflows and summarized workflows can be imported as well as the 
same time. If you choose a "child" subflow or summarized workflow, just that individual 
workflow will be imported. 
 

 
 
Click Next. 

4. If you chose to Create New Workflow, the Map Base File Cabinet screen displays. 
 
Choose whether you want to: 

• Create New File Cabinet: Create a new file cabinet for the new workflow using the same 
fields and properties as the original file cabinet. 
 
Notes: 

o A created file cabinet has no resource permissions by default. Assign 
permissions to the new file cabinet in Feith Control Panel (see Feith Control 
Panel User Guide for more information). 

o If the original workflow from which you made the export file was based on a 
virtual file cabinet, creating a new file cabinet here will make a "regular" file 
cabinet, not a virtual file cabinet. 

• Map To An Existing File Cabinet: Build the new workflow on an existing file cabinet. 
 

 
 
Click Next. 
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5. If you are using an existing file cabinet (either because you chose to Use Existing Workflow or 
Map To An Existing File Cabinet), the Map File Cabinet Fields screen displays. 
 

Choose which fields map to which. Alternatively, you may Create  a field in the file cabinet. 
 
Note: When mapping to a field with a different name, the name will be updated in all locations 
where it is used (e.g. User task Fields, Deadline routes or tasks, Expected Documents rules, file 
cabinet field Tokens, etc). 
 

 
 
Click Next. 

6. Map the following if they are in the workflow design you are importing: 

a. Map Subflows and Other Referenced Workflows: 

Choose which subflows or other referenced, summarized workflows map to which and 
whether you want to Replace the existing subflows or summarized workflows. 

Alternatively, you may Create  a workflow (if it was included in the export file; see 

Export for more information) or Delete the Assignment  to a subflow or summarized 
workflow. 
 

Note: If you Delete the Assignment  of a subflow, the subflow task in the "parent" 
workflow will have a dashed outline indicating it is incomplete. The subflow task must be 
re-configured or deleted before the workflow can be published. If you Delete the 

Assignment  of a summarized workflow, the assignment is simply removed from the 
information task and no further configuration is required. 
 

 
 
Click Next. 
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b. Map Lookup Tables: 

Choose which lookup tables map to which. Alternatively, you may Create  a lookup 
table. 
 

 
 
Click Next. 

c. Map Lookup Table Columns: 

Choose which lookup table columns map to which. Alternatively, you may Create  a 
lookup table column. 
 

 
 
Click Next. 

7. If you chose to overwrite an existing workflow (either because you chose to Use Existing 
Workflow or map to and Replace subflows or other referenced, summarized workflows), the Map 
Tasks screen displays. 
 

Choose which tasks map to which. Alternatively, you may Create  a task. 
 

 
 
Click Next. 
 
Note: At this point you cannot go Back, unless you chose to Use Existing Workflow, because the 
workflow, file cabinet, and lookup table entries have been established. 
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8. Map the following if they are in the workflow design you are importing: 

a. Map Summarized Tasks: 

If you chose to map to but not Replace subflows or other referenced, summarized 
workflows, the Map Summarized Tasks screen displays. 
 

Choose which tasks map to which. Alternatively, you may Delete the Assignment  to 
the task in the summarized workflow. 
 

 
 
Click Next. 

b. Map Calendars: 

Choose which calendars map to which. Alternatively, you may Create  a calendar. 
 
Note: If you did not choose to include Calendar Data in your export (see Export for more 
information), the calendar you create will basically be a 24/7 calendar with no holidays. 
 

 
 
Click Next. 

c. Map Users and Groups: 

Choose which groups and users map to which. Alternatively, you may Create  a group 
or user. 
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Click Next.  
 
To create a group: 

• In the Add Workflow Group screen, set the following: 

o Group Name:  Enter the group name. 

o Description:  Optionally enter a description. 

o E-Mail Address:  Optionally enter the group's email address. 

o Workflow Users:  Assign one or more workflow users as members of 
the new group. 
 

 

Note:  If you did not choose to include Group Permissions in your export (see Export for 
more information), the group you create will have no task permissions (e.g. scan/import, 
index, search file cabinets).  The task permissions can be set in Feith Control Panel (see 
Feith Control Panel User Guide for more information). 

To create a user: 

Add a Database Authenticated or Externally Authenticated (e.g. Single Sign-On) user: 

• Database Authenticated:  Unless your FDD system is configured for external 
authentication, users should be added as database authenticated. 
 
In the Add Workflow User screen click the Database Authenticated tab and 
set the following: 

o User Name:  The user login name. 

o Full Name:  Optionally enter a full name. 

o E-Mail:  Optionally enter the user's email address. 

o Password:  The user's password. 

o Confirm:  Re-enter the user's password for verification. 
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• Externally Authenticated:  Users are typically added as externally 
authenticated when your FDD system is configured to authenticate using 
Kerberos, for example if you are integrating with Microsoft Active 
Directory.  Integrating with Active Directory using Kerberos/LDAP authentication 
provides Single Sign-On (SSO) in addition to external authentication.  Note that 
external authentication requires additional configuration. 
 
In the Add Workflow User screen, click the Externally Authenticated tab and 
set the following: 

o Domain:  If you are running on MS SQL Server, enter the Domain 
name. 

o User Name:  The user login name.  The login name must be entered as 
it appears in your external authentication system (e.g. Microsoft Active 
Directory). 

o Full Name:  Optionally enter a full name. 

o E-Mail:  Optionally enter the user's email address. 
 

 

Note:  The created user will be a Feith Connect database user type, be a Workflow 
User, have no task permissions (e.g. scan/import, index, search file cabinets), and only be 
a member of the public group.  You can set task permissions and group membership in 
Feith Control Panel (see Feith Control Panel User Guide for more information). 

  

d. Map Finishing Touches and Rule Tokens: 

Choose which finishing touches and rule tokens map to which and whether you want to 

Replace the existing finishing touches or rule tokens.  Alternatively, you may Create  a 
finishing touch or rule token. 
 

 
 
Click Next. 
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e. Map Notifications: 

Choose which notifications map to which and whether you want to Replace the existing 

notifications. Alternatively, you may Create  a notification. 
 

Note: Limited notifications default to Create , but you may map them to a non-limited 
notification if desired. 
 

 
 
Click Next. 

f. Map Referenced File Cabinets: 

Choose which referenced file cabinets map to which for Expected Documents rules. 
 

 
 
Click Next. 

g. Map Referenced Fields: 

Choose which referenced file cabinet fields map to which for Expected Documents rules. 
 

 
 
Click Next. 
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h. Map Integration Links: 

Choose which integration links map to which and whether you want to Replace the 

existing integration links. Alternatively, you may Create   an integration link. 
 

 
 
Click Next. 

i. Map Forms iQ Forms: 

Choose which Forms iQ forms map to which for Forms iQ integration links. 
 

 
 
Click Next. 

j. Map Forms iQ Servers: 

Choose which Forms iQ Servers map to which for Forms iQ integration links. 
 

 
 
Click Next. 

9. The workflow is imported. Save, Check In, or Publish the workflow as needed. See Save Draft, 
Check In Version, and Publish Workflow for more information. 
 
Note: If when importing a workflow you deleted any tasks containing work items, during the 
publication process you will be prompted with the Move Work dialog to move the work items to 
another task. Optionally check Use for All Deleted Tasks to move work from all deleted tasks to 
the same task. 

If you are replacing an existing workflow as part of your import, it is strongly recommended that 
you do not publish modifications to an in-production workflow while users are working in the FDD 
system. 
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Appendix A: Tokens 
Tokens are placeholders for dynamic information that will be inserted in notifications, work-o-grams, 
program commands, finishing touches, rule tokens, and integration links. For example, the file cabinet field 
"Amount" token may be included in an email notification to review an Expense Report or the Document ID 
token may be used in a SQL join to look at data in an external table in a finishing touch. See Notify, 
Configure Work-o-gram, Configure Program, Finishing Touches, Rule Tokens, and Assign Integration Link 
for more information. 

Notes: 

• Rule tokens are only available in notifications, work-o-grams, and hub task programs. See Notify, 
Configure Work-o-gram, and Configure Program for more information. 

• Integration links use different, but similar tokens compared to all other locations. 

• The View Document URL token is not supported in integration links, finishing touches, or rule 
tokens. 

• File cabinet field tokens are generally not available when creating objects from the Tools menu 
(e.g. Tools>Notification Administrator). 

• For Work-o-grams, only the file cabinet field tokens (Field field name) and rule tokens (Rule # - 
rule name) are supported. 

TOKEN NAME TOKEN DESCRIPTION 

Document ID {DOC_ID} The internal ID of the work item. 

Field field name {FC_VALUE|field name} 
The work item's value from the selected file cabinet field. 
All fields in the workflow's base file cabinet are in the 
token list. 

Priority {WF_DOC_PRTY} 
The priority of the work item. See Priority for more 
information. 

View Document 
URL 

{URL_VIEW_DOC} 
A WebFDD View Document URL to the work item. An 
end user may click the URL and login to WebFDD to 
view the work item. 

CUser {WF_DOC_CUSER} The user who created the work item. 

CTime {WF_DOC_CTIME} The date and time the work item was created. 

MUser {WF_DOC_MUSER) The user who last modified the work item. 

MTime {WF_DOC_MTIME} The date and time the work item was last modified. 

Workflow Name {WF_NAME} The name of the workflow containing the work item. 

Task Name {WF_TASK_FC} The name of the task containing the work item. 

Task View {WF_TASK_TBL} The name of the task view containing the work item. 

Base FC Name {WF_BASE_FC} The name of the workflow's base file cabinet. 

Base FC Table {WF_BASE_TBL} The name of the workflow's base file cabinet table. 

Task Deadline {WF_TASK_DL} 
The time of a task deadline defined by a deadline route. 
See Deadline Route for more information. 
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Workflow Deadline {WF_DL} 
The time of the workflow deadline defined by the 
deadline task. See Deadline Task for more information. 

Timestamp {DATETIME} The current date and time. 

Rule # - rule name {RULE|#} 
The value(s) returned by the custom SQL in the rule 
token. See Rule Tokens for more information. 

  

More Tokens 

In addition to the tokens above, Rex supports the below tokens in notifications, hub task programs, finishing 
touches, and rule tokens. These tokens must be entered by hand and some require additional information. 

TOKEN DESCRIPTION 

{DOC_CUSER} The user who created the FDD document. 

{DOC_CTIME} The date and time the FDD document was created. 

{DOC_MUSER} The user who last modified the FDD document. 

{DOC_MTIME} The date and time the FDD document was last modified. 

{GRP_EMAIL|group id} 

The specified group's email address based on the given group ID. 
You may specify multiple group IDs by separating them with 
commas. 

Note: If you are using Microsoft Outlook as your email client, Outlook 
may complain about sending an email to a list of comma-separated 
email addresses. You can change this, for example, in Outlook 2010 
by turning on the option Commas can be used to separate 
multiple message recipients under File>Options>Mail>Send 
messages. 
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{BUSINESS_DAYS|interval} 

The number of calendar days to arrive at the business day specified 
by the given interval. Days are calculated from the current date 
 
The interval is provided in the format: 
calendar number years:months:days:hours:minutes:seconds 
optionally specify date 

For example: 

• BUSINESS_DAYS{1 0:0:7:0:0:0} uses the Standard 
Business Calendar to go forward 7 business days from the 
current date. On Monday 7/1/2013, 7 business days forward 
would be 7/11/2013 because July 4th and the one weekend 
are skipped, and therefore the token returns a value of 10 
calendar days. 

• BUSINESS_DAYS{1 0:0:-7:0:0:0} uses the Standard 
Business Calendar to go backward 7 business days from 
the current date. On Monday 7/1/2013, 7 business days 
backward would be 6/27/2013 because the two weekends 
are skipped, and therefore the token returns a value of -11 
calendar days. 

{ENV|environment variable} 
The specified environment variable from the machine where Rex is 
running. 

  



Appendix 

Feith Workflow iQ Manager 9.2 User Guide     191 

Appendix B: Command Line Arguments 
Workflow iQ Manager may be run from a command prompt to perform a few simple operations, including 
creating a workflow, exporting a workflow, and importing a workflow. 

Note: When exporting from command line, subflows and other, referenced summarized workflows are not 
included in the export file. See Export for more information. 

  

Arguments 

ARGUMENT EXAMPLE DESCRIPTION 

-u [user name] -u jsmith Login user name. 

-p [password] -p jsmith123 Login user's password. 

-s [database 
connect string] 

-s fdd 
Database to which you want to 
connect. 

-n [new workflow 
name] 

-n AP 
When creating a new workflow, the 
name of the new workflow. 

-f [base file 
cabinet] 

-f AP 

When creating a new workflow, the 
name of the base file cabinet on 
which you want to build the new 
workflow. 

-g [administration 
group] 

-g AP_Admin 
When creating a new workflow, the 
name of the workflow's administration 
group. 

-w [workflow 
name] 

-w AP 
When exporting a workflow, the name 
of the workflow you want to export. 

-x [export file 
name] 

-x C:\Users\John\Desktop\AP_export.fwx 

When exporting a workflow, the name 
of the workflow export file and, if 
desired, the path to the location 
where you want the file saved. The 
file must have the extension ".fwx". If 
no path is specified, the export file is 
saved in your operating system user's 
folder (e.g. C:\Users\John). 
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-c -c 
Close Workflow iQ Manager after the 
operation is complete (e.g. after 
export). 

-q -q 
Run in "quiet" mode. Currently this 
only applies to export by removing the 
export's success message. 

-a [action] -a publish 
Perform an action. The only available 
action at this time is "publish" (e.g. 
publish a workflow you just imported). 

Notes: 

• Values with spaces should be enclosed in double quotes (e.g. -w "Accounts Payable"). 

• There is no specific argument for import because Workflow iQ Manager knows that you want to 
import when you give it an .fwx file. 

  

Examples 

For example, creating a workflow called "AP" built on the "AP" file cabinet with the administration group 
"AP_Admin": 

"C:\Feith\Workflow iQ\WorkflowiQManager.exe" -u jsmith -p jsmith123 -s fdd 

-n AP -f AP -g AP_Admin 

For example, exporting a workflow called "AP" to a file called "AP_export.fwx" on your desktop in quiet mode 
and then closing Workflow iQ Manager after the export: 

"C:\Feith\Workflow iQ\WorkflowiQManager.exe" -u jsmith -p jsmith123 -s fdd 

-w AP -x C:\Users\John\Desktop\AP_export.fwx -q -c 

For example, importing a workflow from a file on your desktop called "AP_export.fwx" and then publishing 
the workflow: 

"C:\Feith\Workflow iQ\WorkflowiQManager.exe" -u jsmith -p jsmith123 -s fdd 

C:\Users\John\Desktop\AP_export.fwx -a publish 
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Appendix C: Keyboard Shortcuts 
Workflow iQ Manager supports the following keyboard shortcuts: 

SHORTCUT ACTION 

CTRL+N Create new workflow (File>New). 

CTRL+O Open workflow (File>Open). 

CTRL+S Save draft of workflow (File>Save Draft). 

CTRL+P Print workflow map (File>Print). 

CTRL+Z Undo last action (Edit>Undo). 

CTRL+Y Redo last action (Edit>Redo). 

CTRL+X Cut object (Edit>Cut). 

CTRL+C Copy object (Edit>Copy). 

CTRL+V Paste object from clipboard (Edit>Paste). 

CTRL+L Clone object (Edit>Clone). 

DELETE Delete object (Edit>Delete). 

CTRL+A Select all objects (Edit>Select All). 

CTRL+TAB Go to next workflow tab (View>Next Workflow). 

SHIFT+CTRL+TAB Go to the previous workflow tab. 

F1 Open Workflow iQ Manager Help (Help>Feith Workflow iQ Manager Help). 

CTRL+1 Change to Pointer tool. 

Middle-click (mouse 
wheel) workflow tab 

Close the workflow tab. 

F5 Refresh work item counts. 
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A 
Ad Hoc route: Allows a user to send a work item from a task to any other task on an as-needed basis. 

Auto-Distribute route: A route that distributes work items between several tasks. 

Automatic route: A route that automatically moves a work item to the next task. 

B 
Base File Cabinet: A workflow is based on a File Cabinet. A file cabinet is a permanent storage area for 

indexed documents. Each file cabinet is defined by the index fields (e.g., name, date, amount) it 
uses to organize stored images. Each entry in the file cabinet consists of a group of index field 
values (e.g., John Smith, 04/06/2009, $140.43) and the images associated with those values. 

C 
Calendar: Defines the calendar by which the workflow should operate. A calendar defines business hours 

and company holidays, and is used to determine when deadlines, reminder notifications, and 
priority changes should occur. 

Check In Version: A "Non-Published" version of the workflow is checked in to the workflow's version 
history. Other designers can see the non-published version and check it out for modifications. 

Check Out: A workflow must be checked out in order to modify its design. The user who checks out the 
workflow has that workflow locked and no other user can modify the design while they are working 
on it. 

Conditional route: A route that moves work items based on a specified condition. 

D 
Deadline route: A route that moves expired work items from a task. 

Deadline task: A deadline that applies to the entire workflow. When the workflow deadline expires for a 
work item, the item is automatically sent to the deadline task. 

Delete Publication: Removes a workflow from production in the FDD system. However, the workflow 
design and version history are saved. A deleted workflow can be re-published if desired. 

Document: A permanent grouping of related pages. Documents reside in File Cabinets. The pages in a 
document were indexed a set of index values. 

E 
End task: A task that is the end point of the workflow. 

Error Route: A route that moves errored work items from a task. 
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F 
FDD: Feith Document Database (FDD) is Feith's imaging and document management system. The 

documents stored in FDD can be sent through a workflow in order to accomplish a desired process. 

Feith Control Panel: The application which handles the administration of the FDD system. 

File Cabinet: A workflow is based on a File Cabinet. A file cabinet is a permanent storage area for indexed 
documents. Each file cabinet is defined by the index fields (e.g., name, date, amount) it uses to 
organize stored images. Each entry in the file cabinet consists of a group of index field values (e.g., 
John Smith, 04/06/2009, $140.43) and the images associated with those values. 

Finishing Touch: A SQL statement that executes each time a work item leaves the task to which the rule is 
assigned. 

Folder: A container for multiple documents. 

Forms iQ Designer: A Feith application for designing web forms that are used in the FDD system. 

H 
Hub task: A node in the workflow. This task type is typically used as an intersection in the workflow (e.g., a 

task from which to conditionally route documents). The hub task may also be used to run a 
program. 

I 
Index Values: The values associated with a document or folder; metadata (e.g., invoice id, vendor id, total, 

date). 

Information route: A route used to connect information tasks for illustrative purposes only. 

Information task: A task used for illustrative purposes only to represent steps that occur outside the 
workflow process or to summarize work item counts from a set of tasks. 

Integration Link: A link that is optionally assigned to a user task when action is required outside of FDD in 
order to process the work item. If a task has an integration link assigned to it, the link will launch 
automatically when you retrieve a work item from that task. Three types of links are available: 
Forms iQ link, application link, and URL link. 

L 
Lookup Table: A list of suggested index values; can be used when indexing or searching. Configured in 

Feith Control Panel. 

M 
Manual route: The following route types are manual routes: Single-Select route, Multi-Select route, and 

Optional route. A manual route moves work items based on a workflow user's route selection in the 
client (FDD or WebFDD). 

Multi-Select route: A manual route that moves work items based on the workflow user's route selection. 
This route type requires the user to make a selection, and they can select multiple routes if desired. 

N 
Notification: An email sent to workflow users to notify them of events in the workflow process. 
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O 
Optional route: A manual route that moves items based on the workflow user's route selection. This route 

type does not require the user to select it; it is optional. 

Overflow: When the number of work items in a user task gets too high, additional users are temporarily 
assigned to the task to handle the workload. Once the overflow of work has been addressed, the 
additional users are removed. 

P 
Priority: The priority of a work item, assigned on a scale of 1 to 9 (where 1 is the highest priority). 

Publish: Publishing a workflow puts that workflow into production. 

Purge: Purging a workflow completely removes the workflow and its version history from the FDD system. 

R 
Rendezvous task: A task that collects and combines copies of a work item. When a work item is routed to a 

rendezvous task, it remains in the task until all other copies (in the preceding tasks) arrive at the 
rendezvous task. When all copies have reached the rendezvous task, the work item is then routed 
to the next task. 

Rex: The Feith Rules Engine (REX) processes work items according to the workflow design (e.g., routes 
work items, sets deadlines, sends e-mails, handles resource allocation, etc). 

Route: Moves work items from task to task, defining how and why the work arrives at a particular task. 

S 
Save Draft: Saves a draft of the workflow and keeps it checked out by the user that is working on the 

design. Saving a draft does not publish the workflow, nor does it add to the workflow's version 
history. 

Single-Select route: A manual route that moves work items based on the workflow user's route selection. 
This route type requires the user to make a selection, and they can only select one of the routes. 

Start task: The task which is the entry point to the workflow. All work items added to the workflow are 
initially sent to the start task. A start task is automatically added to the workflow design when you 
create the workflow. 

Subflow task: A task that routes a work item from a parent workflow into a subflow. 

Super Administrator: A special user type that has more authority than the typical user. See the Feith 
Control Panel User's Guide for more information. 

T 
Task: A node in the workflow where work is performed. 

Task Permission: Defines what tasks a user or group can perform in the FDD system (e.g., scan, index, 
delete page, etc). 

U 
User task: A node in the workflow where FDD users retrieve and process work items in a client (FDD or 

WebFDD). 
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V 
Version History: All versions that have existed for a given workflow are recorded in its version history. 

W 
Wait-For task: A task that waits for a specified condition to be true. 

Withdraw: Removes a work item from the workflow. Note that withdrawing a work item from a workflow 
does not delete the work item from FDD. 

Work Info: The list of work items that are in a given task. 

Work Item: The general term applied to items going through the workflow. A work item is either a document 
or a folder. 

Work Item Count: The number of work items in a workflow. The total work item count is displayed on the 
lower left of the screen. The work item count is also displayed per task as a number in a hexagon 
displayed over each task. 

Work-o-grams: An email sent to a specified user for each work item that enters a task. The user can 
process the work item by responding to the work-o-gram email. 

Workflow: A network of tasks that moves an FDD document or folder through a set of defined rules. 
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