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Introduction 

Background 
This instruction manual will help you to create one of three types of finished circuit boards with 
the LPKF Circuit Board Milling Machine (ProtoMat C30s): a simple single-sided board, a 
double-sided board, or a single-sided board with labels engraved on the component side. The 
main instructions will refer to the process of making a single-sided circuit board. Additional 
instructions for making the other types of circuit boards will be noted on each pertinent step with 
italic text. This process will require the use of TraxMaker, CircuitCAM, and BoardMaster 
software. Slight familiarity with TraxMaker, and general familiarity with Windows-based 
computers, is required.  
 
 
 
 
 
 
Examples 
Throughout this instruction manual, example screenshots and photographs have been provided to 
give an idea of what to expect. Please take the time to familiarize yourself with the instructions 
and programs for best results. 
 
Precautions 
The LPKF ProtoMat C30s is a well-designed machine, and has very few safety considerations. 
However, it is necessary to observe the following precautions: 

 Never reach into the machine while it is running. 
 Be sure the motor has come to a complete stop before changing the tooling bits. 
 Do not operate the machine without a tooling bit properly inserted. 
 Do not use the control computer for other tasks, while the machine is running. 
 Take care when handling the tooling bits, as there is a risk of cutting yourself. 
 Keep the cover closed when the machine is operating, whenever possible. If it is 

necessary to operate the machine with the cover open, wear hearing protection and eye 
protection. 

NOTE: Other PCB layout software than TraxMaker may be used, if the software generates 
standard Gerber X and NC-Drill output files, but some adjustments to these instructions may 
be necessary. 



Definitions 
The following definitions may help to familiarize you with the terms used in this manual. 

 Trace - A “wire” on a circuit board, used to connect components together. 
 Pad -  A place to solder components on a circuit board, often has a hole in the center for 

the leads of through-hole components. 
 Via - A spot in a circuit board used to connect a trace on the top side of the board to a 

trace on the bottom side of the board. Often consists of a pad on each side with a wire 
soldered between. 

 Layer - One set of features in a PCB layout program (for example, bottom side traces, top 
side traces, board outline, or top markings). 

 LPKF ProtoMat C30s - A high-precision CNC milling machine used to produce 
prototype Printed Circuit Boards. 

 
 Working Depth Limiter – The cylindrical part surrounding the tooling bit. It provides a 

work light, a connection to the dust-collection system, a feeler ring which presses against 
the circuit board material, and a knurled ring to adjust the depth of the cutting tool. 

 
 Collet - The tool-holding mechanism on the LPKF ProtoMat C30s. The collet is loosened 

(in order to change tooling bits) by pushing the side handle down, and swinging it 
towards the rear of the machine. 

 Mils - A mil is one one-thousandth of an inch, or 0.001” 



 Reference Pin - A steel pin located at the front or rear of the machine table, used to keep 
the circuit board material from moving around during milling, and also used to line up the 
two sides of the board, after flipping the PCB material over. 

 
 Spoil Board - A thin white board approx 2mm thick placed between the PCB material 

and the machine table. It is used to keep drill and router bits from cutting into the 
machine table. 

 
 Home Position - The “zero” position for the machine head, located at the center of the 

front reference pin. All measurements on the machine and in the BoardMaster software 
are referenced from this position. 

 Tool Exchange Position - The position for the machine head locate at the nearest right-
hand corner of the machine table. It has a space cut into it to allow clearance for changing 
the tooling bits. The machine head in the Tool Exchange Position is shown on the front 
cover of these instructions. 

 Drill Bit - Used for making a round hole through the PCB material. 
 Milling Bit - Used for engraving or cutting on the surface of PCB material, to make 

marks or remove copper. 
 Router Bit - Used for cutting a path completely through the PCB material, to make 

internal break-outs, cut oversized holes, or cut the outside edge of the board. 

Left to Right: 1mm Mill, 0.2mm Universal Cutter (UC) Mill, 2mm Router, 0.8mm Spiral Drill, 1.5mm  Spiral Drill 



I. Section 1 - Design Considerations 
 
 
 

 
A. Board Style 

There are three different styles of board than can be easily produced by the LPKF 
ProtoMatC30s. 
1. Single-Sided - This board has traces on the bottom side of the board, with nothing on 

the top side. Surface-mount components can be mounted to the bottom side of the 
board, and through-hole components and wires mount on the top side. Labels or 
markings may be placed on the bottom side of the board in empty spaces. 

 
2. Single-Sided with marking - This board is almost the same as a Single-Sided board, 

but uses the 0.2mm Universal Cutter to engrave labels and markings on the top side 
of the board. This can help with assembly when working with more complicated 
circuits. Labels or markings may be placed anywhere on the top side of the board, or 
on the bottom side of the board in empty spaces. 

 
3. Double-Sided - This board has traces on both sides. Through-hole components should 

be mounted on the top side, but surface-mount components may be mounted on the 
top or bottom. Traces may be connected between top and bottom sides by vias or 
component leads. Labels or markings may be placed on the top or bottom sides of the 
board in empty spaces. 

 
  

NOTE: At this time, it is necessary to use the computer at lab station 202-17, and log on 
as user: LPKF password: lpkf4work to use the LKPF Milling Machine.



B. TraxMaker - The following considerations may lead to quicker, more successful circuit 
board production. 
1. Track Width – Try to place a majority of tracks and pads with at least 1mm of space 

between them. Recommended settings for general usage are as follows: 
o Track Width: 40 or 50 mils (1 mil = 0.001”) 
o Snap Grid: 25 mils 
o Text Height: 50 or 60 mils 
o Space between tracks: 50 mils or greater 

 Metric Units 
o Track Width: 1 or 1.5mm 
o Snap Grid: 0.5mm 
o Text Height: 1 or 1.5mm 
o Space between tracks: 1mm or greater 

 
2. Pads 

 Pads should be created on the bottom side of the board for every component pin 
or lead, even if the pin or lead is not connected to anything. 

 Additional pads should be created for every external wire connection. 
 Pads can be created to connect components to traces on the top side of the board, 

but this will not work when the body of the component blocks access to the pin or 
lead from the top side of the board. 

 If you need a mounting hole for screws, place a pad, double-click on it, and adjust 
the X-Sixe (and Y-Size) and Hole Size to be the size of the hole you need. 
 

3. Jumpers/Vias - If it would be necessary for two traces to cross without touching, this 
can be accomplished by using a jumper (for single sided boards) or creating a via (for 
double sided boards). A jumper or via must not be placed where it would be covered 
by a component. A via can be created by using an existing component pad, running a 
trace from the bottom side of the board to the bottom pad and a trace from the top 
side of the board to the top pad, and soldering the component pin or lead on the top 
and bottom sides of the board. 

          



4. Layer Usage - The following features should be placed on the corresponding layers” 
 Bottom Layer (blue) - Traces and text labels on the Bottom Side 
 Top Layer (red) - Traces and text labels on the Top Side if you are making a 

double-sided board 
 Top Overlay (yellow) - Component outlines and text labels if you are making a 

single sided board marked on the top side 
 Board Layer (brown) - Pads for Top and/or Bottom Sides, automatically 

generated 
 Keep Out Layer (purple) - Traces determining board outline (see below) 

 
5. Board Outline - On the Keep Out Layer, place traces showing the lines where you 

wish the board to be cut. Double-click each of these traces and change the track width 
to 1 mil or .01mm. Make sure the traces form a closed loop. 
 

6. If you are going to put text onto the board it is suggested that you use the layer “Top 
Overlay” and that you also change the size and width of the text to the following sizes 
as seen in the picture below.  When you place the text onto your design it will appear 
very thick.  The text will not be so thick when it is cut on the machine but for a 
placement reference use this thickness.  

 

 



II. Section 2 - Exporting Gerber and NC-Drill files 
A. Exporting Gerber Files - Once you have finished your design, you must export the layer 

data as Gerber Files, to be used in other programs 
1. It is recommended that you save your layout in TraxMaker at this point 
2. In TraxMaker, click on File > Create Gerber File… 

 
3. In the Gerber Setup window that appears, check that the filename in the “Gerber 

Filename” box is acceptable. You may wish to change the filename or path. 

 
4. You may wish to click the “More Options” button and verify that the following boxes 

are checked: 
 Top Layer 
 Bottom Layer 
 Top Overlay 
 Keep Out Layer 
 Board Layer 
 Pads 
 Vias 
 Text Strings 

5. Click “OK” 
6. The files generated will have the following extensions and purposes: 

 *.GBL - Gerber Bottom Layer 
 *.GBO – Gerber Bottom Overlay 
 *.GTL - Gerber Top Layer 
 *.GTO - Gerber Top Overlay 



 *.GKO - Gerber Keep Out 
B. Exporting NC-Drill Files - If you are making a board with through-hole component 

mounting, you must export the drilling data as an NC-Drill file. 
1. Click on File > Create N/C Drill File… 

 
2. In the N/C Drill Setup window that appears, check that the filename in the “N/C Drill 

Filename” box is correct. 

 
3. Click “OK” 
4. The files generated will have the following extensions and purposes: 

 *.TOL - NC-Drill tooling file 
 *.TXT - NC-Drill data file 
 *.DRL - NC-Drill additional data file 

C. You may now close TraxMaker 



III. Section 3 – Working in CircuitCam - Once you have the files exported from 
TraxMaker, you must import them to CircuitCam and prepare your design for machining. 
A. Importing Gerber and NC-Drill files - In order to work with your design, you must 

import your Gerber and NC-Drill files to CircuitCam 
1. Bottom Layer 

 Start CircuitCam 
 Click on File > Import… 

 
 In the Import window which appears, navigate to your files, highlight your *.GBL 

file, and click “Open” 

 
 CircuitCam should automatically import the file to the Bottom Layer (green) 

2. Bottom Overlay – You only need to do this step if you have placed text down into the 
bottom overlay layer. 
 Click on File > Import… 
 In the Import window which appears, highlight your *.GBO file and click “Open” 
 CircuitCam should automatically import the file to the Text Bottom Layer(purple) 

3. Top Layer - You only need to do this step if you are making a double-sided circuit 
board 
 Click on File > Import… 
 In the Import window which appears, highlight your *.GTL file and click “Open” 
 CircuitCam should automatically import the file to the Top Layer (red) 

4. Top Overlay - You only need to do this step if you are making a single-sided circuit 
board with engraved markings on the top side  
 Click on File > Import… 
 In the Import window which appears, highlight your *.GTO file and click “Open” 
 CircuitCam should automatically import the file to the Text Top Layer (pink) 

5. Board Outline 
 Click on File > Import… 



 In the Import window which appears, highlight your *.GKO file and click “Open” 
 CircuitCam should automatically import the file to the BoardOutline Layer 

(yellow) 
6. Tool Definitions  

 Click on File > Import… 
 In the Import window which appears, highlight your *.TOL file and click “Open” 
 CircuitCam should automatically import the tooling data, and then return you to 

the main program without any messages. 
7. Holes - You only need to do this step if you need holes drilled into the board 

 Click on File > Import… 
 In the Import window which appears, highlight your *.TXT file and click “Open” 
 CircuitCam should automatically import the file to the DrillUnplated layer (grey-

blue) 
B. Processing - Having the circuit board information loaded into CircuitCam, you now must 

specify the machining steps to create your circuit board. 
1. Insulating – Bottom 

 If you wish to remove all the extra copper from the board (not recommended): 

o Click on the 4th large toolbar button:  
o Click at the top-left corner of the area you wish to have cleared 
o Click a second time at the bottom-right corner of the area you wish to have 

cleared 
 Click on Edit > Insulate… 

 



 In the Insulate window that appears, make sure the job is set to “Bottom (Solder 
Side)” 

 
 The default settings are best for most applications, but some exceptions are: 

o If all the tracks and pads are at least 1mm apart, and you desire a large 
separation between tracks, you may set Tools - Standard pull-down menu 
to “End Mill 1.0 mm (39 mil)” 

o If you need more or less separation between tracks or pads, you may 
adjust the values in the Width box as you like, but don’t go under 0.2mm 

o If  the board has many large spaces between and around tracks, you may 
set Tools > Rubout pull-down selection to “End Mill 2.0 mm (79 mil)” 

o The Layout Tracking buttons are only used when removing all the excess 
copper on the board. If you are doing so, click the horizontal or vertical 
button to match the direction that most of your tracks run. This can result 
in a slightly faster machining time. However, either setting will work. 

 Click on “Run”, this will produce dark red lines representing the path of the 
smaller milling bit, and purple lines representing the path of the larger milling bit. 

2. Insulating – Top  - You only need to do this step if you are producing a double-sided 
circuit board 
 Click on Edit > Insulate… 
 In the Insulate window that appears, make sure the job is set to “Top (Component 

Side)” 
 The default settings are best for most applications; see the section on Insulate - 

Bottom for some exceptions 
 Click on “Run”, this will produce dark green lines representing the path of the 

smaller milling bit, and light blue lines representing the path of the larger milling 
bit. 



Inside Cutting - If you need any large holes (other than drilled holes) in the interior of 
the circuit board, perform the following steps: 
 Click and drag a box around the yellow BoardOutline lines representing the area 

you wish to remove, so they are highlighted 
 Click on Edit > Contour Routing… 

 
 In the Contour Routing window which appears, select “Inside” and “Current 

Selection” 

 
 Click on “Run” 

3. Outside Cutting 
 Click on Edit > Contour Routing… 
 In the Contour Routing window which appears, select “Outside” and “Layer > 

BoardOutline” 

 



 Click on “Run” 
4. Text and Marking - You only need to do this step if you are making a single-sided 

circuit board with engraved markings on the top side 
 Click on or near one of the pink traces until one is highlighted 

 
 Click on Select > Layer (this will highlight all the pink traces) 

 
 In the pull-down menus at the top of the screen, set the three menus to 

“InsulateTop_Std”, “LPKFMillingTools”, and “Universal Cutter 0.2 mm (8 mil)”. 
The pink traces will change to dark green, and get very narrow. 

 
 Hit the “Esc” key to un-highlight everything 

5. Rubout Boarder – You only need to do this step if want to have a nice copperless 
boarder on the bottom and/or top of your board 
 Select your board outline(yellow) layer by clicking on one of the yellow lines and 

going to Select > Layer 

 
 In the pull-down menus at the top of the screen, set the three menus to 

“InsulateTop_Bigger”, “LPKFMillingTools”, and “End Mill 2.0 mm (79 mil)”. 
The yellow traces will change to a green, and get very narrow and if you have 
done the contour routing step you may not even see them at all.   

 
 Hit the “Esc” key to un-highlight everything 

 
 



6. Clean Up 
 If any of the dark red or purple lines, or dark green or light blue lines, are in 

useless places (such as outside the gray contour routing lines) you may click on or 
near them to highlight them, and press the “Delete” key to remove them. 

 You may remove any of these lines that you would like, if you would prefer the 
machine not cut the copper from those places. 
 

C. Saving and Exporting from CircuitCam - Finally, you must export the machine 
instruction file as *.LMD file so that the BoardMaster software can make use of it. 
1. Click on File > Export > LPKF > LpkfCircuitBoardPlotter 

 
2. At this point, if you have not saved your work yet, it will prompt you to do so 
3. CircuitCam will produce a message indicating if the export was successful or not 

 
D. You may now close CircuitCam 



IV. Working in BoardMaster - BoardMaster is the software that controls the LPKF 
ProtoMat C30s. Using this software you can have the milling machine produce your circuit 
board. 
A. Starting BoardMaster 

1. Turn on the LPKF ProtoMat C30s 
2. The machining head of the milling machine will move slowly to the Tool Exchange 

Position, then “kerchunk” for a moment, before stopping 
3. After the LPKF ProtoMat C30s has been turned on, you may start the BoardMaster 

Program 
4. If the machine head has not yet reached the Tool Exchange Position, the “Waiting to 

transmit…” window will appear. Simply wait until the machine head has finished 
moving, and the program will continue to load. 

 
B. Importing and Placement - You must bring your project into the software and tell it 

where to produce it on the circuit board material 
1. Importing 

 Click on File > Import > LMD / LPR… 
 Navigate to your saved *.LMD file, highlight it and click “Open” 
 Your project will appear in the main window 

2. Placement 
 Assure that the blank circuit board material has an adequate space for your 

project, is foil-side up, firmly affixed to the machining table. If not: 
o Click on Go to > Pause 

 



o The machine head will move to the rearmost left corner of the machine 
table. 

 
o Remove any tape holding the circuit board material down, and lift it from 

the reference pins 
o Replace the circuit board material with the foil side up, placing the hole 

over the front reference pin, and the slot over the rear reference pin 
 

 
 

o Secure the edges of the circuit board material tightly down to the table at 
any point they are raised by running a short piece of masking tape from 
the edge of the board, over the side of the table. Make sure the masking 
tape is at least a half-inch away from the area where your project will be. 

 Locate a suitable area on the circuit board material for your project. Your project 
must not cover the front reference pin. 

 On the circuit board,  measure the location of this area from the home position (in 
mm) in the X direction (the long dimension of the machine table, with +X being 
away from the home position) and the Y direction (the short direction of the 
machine table, with +Y being away from the tool exchange position) 

 There are two ways to adjust the placement of the project 
 

 
 

 Method 1 
o Click Edit > Placement… 

NOTE: As displayed in the program, the X direction is left-right on the screen (+X being 
right) and the Y direction is up-down (+Y is up when viewing the bottom side of the project, 
and +Y is down when viewing the top side of the project) 

NOTE: The circuit board material must lie flush to the machine table. If the circuit board 
material or spoil board lifts up at the center, away from the machining table, you may be able 
to fix this by removing the circuit board material, flipping the spoil board over, and replacing 
the circuit board material. 



 



o In the Placement window which appears, in the Origin fields, enter the 
values you have measured for X and Y, enter an angle (multiples of 90°) 
then hit “OK” 
 If after changing the rotation angle you may not be able to see your 

board if this happens then go back to placement and click on the 
center button and press okay to have it re-centered so you can see 
the circuit board placement again 

 
o Move your mouse cursor near the corners of your project, and read the 

position from the bottom left corner of the screen (in mm) 

 
o If the project is in the wrong place, click Edit > Placement… again and 

adjust the X and Y Origin values until the project is in the right place. 
 Method 2: 

o Click the Move button on the toolbar   
o Click on project and drag it to the desired position 
o Move your mouse cursor near the corners of your project, and read the 

position from the bottom left corner of the screen (in mm) 
o If the project is in the wrong place, click the move button again and drag 

the project until it is in the right place. 
3. Multiple Projects - The milling machine can load multiple projects and work on them 

at the same time. 
 If you wish to make a duplicate of the existing project, click on the Copy button 

on the toolbar    click on the  existing project, and drag the new instance of 
the project to the desired location 

 If you wish to add a different project, import it as a LMD file as described above 
 Adjust the placement of the new project instance using either of the above 

methods. 



C. Machining Processes - This section details the steps of the actual machining process 
 

 
 

1. Marking Drills - The first step is to mark pilot plots for the tips of the drill bits. This 
will improve the accuracy of hole placement, and reduce the chances of drill bit 
breakage. 
 In the toolbar at the top of the screen, click on the pull-down menu and select “1. 

MarkingDrills”. 

 
 

 In the toolbar, click on the “All +” button . All of the orange dots in the center 
of the holes will change to yellow, indicating that they are enabled. 

 In the toolbar, click on the “Start/Stop” button  
 The Tool Exchange window will pop up; load the 0.2mm UC tool into the 

machine and press “OK” 

 
 If the machine has not run for several hours, the Warm Up window will pop up. 

Wait approx 3 minutes and the window will disappear and the machine will 
continue. 

 
 The machine will move the head and make pilot plots for the drills. As each mark 

is made, the corresponding yellow dot will turn orange. 

NOTE: In each small case of bits, the bit on the far right is the one you should always use 
because the machine tracks the number of uses each bit has had and so we need to 
consistently use the same bit for the count to be accurate.  When the machine tells you to 
replace the bit, throw away the old one and the next bit you use will go into the far right slot 
when you put it back into the case.



 Once the machine has stopped, it will display an End of Phase window and play a 
repetitive low tone through the speaker. Hit Enter or click OK. 

 
 Examine the circuit board and make sure that the marks have been cut deep 

enough across the board. If not, turn the depth adjustment ring about 5 “clicks” to 
the left (in the direction of the “Down” arrow) and repeat this step. 

2. Drilling Unplated  
 In the toolbar at the top of the screen, click on the pull-down menu and select “2. 

DrillingUnplated”. 

 
 

 In the toolbar, click on the “All +” button . All of the dark blue dots 
representing the holes will change to bright blue, indicating that they are enabled. 

 In the toolbar, click on the “Start/Stop” button  
 The Tool Exchange window will pop up; load the indicated  tool into the machine 

and press “OK” 
 The machine will move the head and drill the first set of holes. As it drills each 

hole, the corresponding bright blue dot will change to dark blue. 
 If there are holes of larger sizes, the machine will stop, move to the tool exchange 

position, and the Tool Exchange window will pop up again. Insert the indicated 
tool and click OK, until the machine finishes the drilling phase. 

 Once the machine has stopped, it will display an End of Phase window and play a 
repetitive low tone through the speaker. Hit Enter or click OK. 

 
3. Milling Bottom  

 Make sure that there are no burrs or residue on the circuit board material, within a 
half-inch of your project. 

 In the toolbar at the top of the screen, click on the pull-down menu and select “3. 
MillingBottom”. 



 
 

 In the toolbar, click on the “All +” button . All the dark green lines will 
change to bright green, indicating that they are enabled. 

 In the toolbar, click on the “Start/Stop” button  
 The Tool Exchange window will pop up; load the indicated tool into the machine 

and press “OK” 
 The machine will move the head and cut insulation paths around the circuit traces. 

As each cut is completed, the corresponding line will change from bright green to 
dark green. 
 

 
 

 If, at any point, the machine produces an inadequate cut, perform the following 
steps: 

o Click the Start/Stop button . (It may be necessary to click it more than 
once; if the machine is performing very short or very long instructions, it 
will not recognize the click.) 

o If necessary, move the depth adjustment ring to adjust the depth of cut. 
o If necessary, click the Go to > Exchange menu to bring the machining 

head to the tool exchange position, and replace the milling bit. 
o To re-enable tooling paths (to re-cut them): 

 Click the Select Elements button . 
 Click and drag a box across the paths you want to re-enable. 
 The paths you have selected will turn bright white. 

 Click the + button , and the paths will turn bright green, 
indicating that they are enabled. 

 If there are paths enabled that you do not wish cut, click the Select 

Elements button, highlight the paths, and click the - button  . 
o Once all the desired paths are enabled, click the Start/Stop Button again. 
o These steps may also be performed while not in a machining phase, in 

which case do not click the Start/Stop button initially. 
 If the program requires a milling bit of a different size, the machine will stop, 

move to the tool exchange position, and the Tool Exchange window will pop up 

NOTE: Adjust the depth of the machine head until the milling bit just barely cuts completely 
through the copper, across the circuit board. If you are using a brand new 1mm milling bit, set 
the depth so that the two blue marks on the depth adjustment ring line up. As milling bits wear, 
you will need to adjust the milling depth down. 



again. Insert the indicated tool and click OK, until the machine finishes the 
milling phase. 
 

 
 

 
 Once the machine has stopped, it will display an End of Phase window and play a 

repetitive low tone through the speaker. Hit Enter or click OK. 

 
 Examine the circuit board and make sure that the marks have been cut deep 

enough across the board. If not, refer to the above instructions to re-enable cutting 
paths. 

 Click on Go to > Pause to send the machining head to the back of the machine 
table. 

 Remove the circuit board from the reference pins, and remove any masking tape 
on the board. Flip the board over and replace it upside down, placing the hole 
over the front reference pin and the slot over the rear reference pin. Re-apply 
adequate masking tape to hold it down tight to the table. 

4. Milling Top - You will need to do this step if you are making a double-sided circuit 
board, or a single-sided circuit board with engraved markings. 
 Make sure that there are no burrs or residue on the circuit board material, within a 

half-inch of your project. 
 In the toolbar at the top of the screen, click on the pull-down menu and select “4. 

MillingTop”. 

 
 

 In the toolbar, click on the “All +” button . All the dark red lines will change 
to bright red, indicating that they are enabled. 

 In the toolbar, click on the “Start/Stop” button  

NOTE: When using the 1mm milling bit, as the bit becomes slightly dull, the machine 
sometimes lacks sufficient downward force to plunge the bit through the copper. It may be 
necessary to operate the machine with the cover open, and press down on the top of the motor 
each time the head lowers onto the circuit board. While operating the machine with the 
cover open, wear hearing and eye protection. Discard and replace the 1mm milling bit 
when it starts leaving ragged edges on the copper as it cuts. 



 The Tool Exchange window will pop up; load the indicated tool into the machine 
and press “OK” 

 The machine will move the head and cut the programmed paths. As each cut is 
completed, the corresponding line will change from bright red to dark red. 
 

 
 

 If the program requires a milling bit of a different size, the machine will stop, 
move to the tool exchange position, and the Tool Exchange window will pop up 
again. Insert the indicated tool and click OK, until the machine finishes the 
milling phase. 

 Once the machine has stopped, it will display an End of Phase window and play a 
repetitive low tone through the speaker. Hit Enter or click OK. 

 
 Examine the circuit board and make sure that the marks have been cut deep 

enough across the board. If not, refer to the above instructions to re-enable cutting 
paths. 

5. Cutting Inside 
 In the toolbar at the top of the screen, click on the pull-down menu and select “5. 

CuttingInside”. 

 
 

 In the toolbar, click on the “All +” button . All the dark yellow lines for this 
phase will change to bright yellow, indicating that they are enabled. 

 In the toolbar, click on the “Start/Stop” button  
 The Tool Exchange window will pop up; load the indicated tool into the machine 

and press “OK” 
 The machine will move the head and cut the board around the inside path. As 

each cut is completed, the corresponding line will change from bright yellow to 
dark yellow.  

 Once the machine has stopped, it will display an End of Phase window and play a 
repetitive low tone through the speaker. Hit Enter or click OK. 

NOTE: All the considerations and adjustments that apply in the previous step, 3. Milling 
Bottom also apply in this step. 



 

 
 

 
6. Cutting Outside  

 In the toolbar at the top of the screen, click on the pull-down menu and select “6. 
CuttingOutside”. 

 
 

 In the toolbar, click on the “All +” button . All the dark yellow lines for this 
phase will change to bright yellow, indicating that they are enabled. 

 In the toolbar, click on the “Start/Stop” button  
 If the proper tool is not already in the machine, the Tool Exchange window will 

pop up; load the indicated tool into the machine and press “OK”. 
 The machine will move the head and cut the board around the outside path. As 

each cut is completed, the corresponding line will change from bright yellow to 
dark yellow.  

 Once the machine has stopped, it will display an End of Phase window and play a 
repetitive low tone through the speaker. Hit Enter or click OK. 

 
 Click Go to > Pause to move the machining head to the rear of the machine. 
 Remove your circuit board from the machining table. 

7. Turning Off the Machine 
 Click File > Exit. 

NOTE: At this point, it may be desirable to remove the board from the machine and inspect 
the traces and cuts. Click on Go to > Pause, remove the circuit board from the reference pins, 
and use the Motic 60x Lighted Inspection Microscope to examine anything that may be 
imperfect. If any re-work is needed, you can replace the board with the proper side up, secure 
it with tape, and follow the instructions for that phase again. 



 
 The BoardMaster program will prompt you to save the job you have created. 

If you wish to make the same board(s) again later (in exactly the same 
position(s)) then you may save it, otherwise hit Cancel. 

 Switch off the LPKF ProtoMat C30s. 
8. Final Preparation - You have finished machining your board. There are a few final 

steps that you may wish to perform for professional looking results. 
 The corner where the CuttingOutside phase finished may have a small “tab” 

protruding on the edge. You may remove this with a fine file. 
 The inside and outside cut edges may have a copper burrs on them. You can 

smooth these quickly with a fine file applied at a 45° to the face of the board. 
 You can polish the board with steel wool. 
 If you have polished the board, you may apply a tinning solution to the board. 

 
V. Trouble Shooting 

A. Circuit Cam: When you are importing the files if they aren’t automatically loaded then 
you will need to go into Config > General Settings and add or change the following file 
extensions to match the following 

 
File – Spec Layer Aperture/Tool List Type 
*.GBO Text Bottom ApeTutor Gerber X 
*.GBL Bottom Layer ApeTutor Gerber X 
*.GTO Text Top ApeTutor Gerber X 
*.GTL Top Layer ApeTutor Gerber X 
*.GKO Board Outline ApeTutor Gerber X 
*.TOL TraxTools.TXT (NcDrill) NcDrill Default Apeture/Tool Select 
*.TXT Drill Unplated NcDrill Default Excellon 

 



 
 

B. Board Master: 
1. If there are any problems with alignment make sure that the board is properly inserted 

on the reference pins and that it is taped down 
2. Check the machine dimension settings by going to Configuration > settings and 

verify that all the settings are correct  

    
 

3. Check that the project you are working on is within the boundaries for milling by 
going to configuration > material > size and input the following dimensions 
 



  
 
When you hit “OK” you will see a dark square appear on the machine mat.  Verify 
that all projects are within this dark area. 

 
C. Reference manual / tutorial – if you want to you can go to the complete trainers manual 

for CircuitCAM and BoardMaster are here 
http://www.ee.cuhk.edu.hk/pcblab/manual/CCAM40tut-e.pdf  

D. Additionally the school has a website with several useful links for the LPKF milling 
machine and CircuitCAM at http://www.byui.edu/csee/cadence/relatedLinks.htm  

 
 
 


